Contribute
Register

Wake from sleep issue related to Bios XMProfile

Joined
Apr 28, 2011
Messages
902
Motherboard
ASRock Fatal1ty Z370 Gaming-ITX/ac
CPU
i7-8700
Graphics
UHD 630
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I know, there are tons of threads about sleep issues, wake troubles etc... but I've never noticed (until now) nor read anywhere, that this could be related to Extreme Memory Profile in bios settings. And this is a fact, cause I am just experiencing it!
Specs:
  • Intel i7 3770k (tried both overclocked and default clock values)
  • GA-Z77X-UD5H F14 bios version
  • RAM Corsair vengeance 32 GB 1600 MHZ CMZ32GX3M4X1600C10
After a bunch of trial and error bios setting, bios upgrading (beta F15o and F15q) and downgrading, dsdt tricks, usb connectors, plist editing, etc, I came up to this.
Loading EXTREME MEMORY PROFILE to gain 1600 MHz instead of default 1333 MHz, cause this sleep issue: first time you put in sleep it goes flawlessly, then to wake it up you have to press two times the command (keyboard, mouse etc). After that, the system refuses to sleep again, furthermore when shutting down, it takes some extra seconds (about 20-25) to do that.
Unloading EXTREME MEMORY PROFILE makes the system working as it should.
Note that in both cases, darkwake=10 to allow auto sleep.

Any kind of tip is gratefully accepted.
G.
 

beelzebozo

Super Moderator
Joined
Mar 31, 2010
Messages
3,732
Motherboard
ASUS z170-Deluxe
CPU
i7 - 6700K
Graphics
RX 5700 XT
Mac
  1. iMac
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
then to wake it up you have to press two times the command (keyboard, mouse etc).G.

With darkwake=0, which is what MultiBeast adds to your org.chameleon.boot.plist, it makes your system wake with only one click of the mouse or hitting the keyboard.

Therefore, darkwake=10 is not the correct option if you want a one click system wake.

If your system is having hard time going to sleep with Energy Saving prefs, you might want to try a free app called PleaseSleep. I use it on my z77x build.
 
Joined
Apr 28, 2011
Messages
902
Motherboard
ASRock Fatal1ty Z370 Gaming-ITX/ac
CPU
i7-8700
Graphics
UHD 630
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
With darkwake=0, which is what MultiBeast adds to your org.chameleon.boot.plist, it makes your system wake with only one click of the mouse or hitting the keyboard.

Therefore, darkwake=10 is not the correct option if you want a one click system wake.

If your system is having hard time going to sleep with Energy Saving prefs, you might want to try a free app called PleaseSleep. I use it on my z77x build.

Autosleep is not an issue, and even with darkwake=10, without XMP profile1 in bios system wakes up in zero secs with one click. Now the issue to me is wake from sleep with xmp profile 1 set in bios! No ideas?
 
Joined
Apr 28, 2011
Messages
902
Motherboard
ASRock Fatal1ty Z370 Gaming-ITX/ac
CPU
i7-8700
Graphics
UHD 630
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Top