Contribute
Register

VDA Decoder failed

Joined
Apr 29, 2012
Messages
155
Motherboard
ASUS ROG Mamimus XI Hero (Wifi)
CPU
i9-9900K
Graphics
Vega 64
Mac
iMac, MacBook Pro, Mac mini
Mobile Phone
iOS
Hello. Hoping someone can point me in the right direction to get my VDA Decoder working on my rig. Hackintool shows:

-----------------------------------------------------------------------
GPU Info
-----------------------------------------------------------------------
GPU Name ???
GPU Device ID 0x00000000
VRAM 0 MB
Quartz Extreme (QE/CI) Yes
Metal Yes
VDA Decoder Decoder Failed
 
Joined
Jul 23, 2012
Messages
526
Motherboard
GA-Z77N-WIFI - F3 - Clover UEFI
CPU
E3-1225 v2
Graphics
GT 640 | P4000
Mac
Mac mini
macOS do not make use of the dGPU for hardware video acceleration
IGPU should be enabled in the BIOS, and set ig-platform-id in headless mode
and rename the graphics device name properly, IGPU, GFX0
 
Joined
Apr 29, 2012
Messages
155
Motherboard
ASUS ROG Mamimus XI Hero (Wifi)
CPU
i9-9900K
Graphics
Vega 64
Mac
iMac, MacBook Pro, Mac mini
Mobile Phone
iOS
thank you, @itwas. I was under the impression that video cards were used for acceleration. At least my previous build did, or do I not understand you properly? I also understand that the Radeon RX 580 is natively supported by Mojave, is it not?

In the mean time, my hackintool now shows:

GPU Info
-----------------------------------------------------------------------
GPU Name UHD Graphics 630 (Desktop 9 Series)
GPU Device ID Ox3E988086
VRAM 1536 MB
Quartz Extreme (QE/CI) Yes
Metal Yes
VDA Decoder Decoder Failed

I have no idea how to "set ig-platform-id in headless mode", and also admit that I don't understand "rename the graphics device name properly, IGPU, GFX0". So the name should not be "UHD Graphics 630 (Desktop 9 Series)"?

If you can point me at something I can read to help me understand how to get VDA Decoder to read "supported" I'd sure appreciate it.

Thanks again.
 
Joined
Jul 23, 2012
Messages
526
Motherboard
GA-Z77N-WIFI - F3 - Clover UEFI
CPU
E3-1225 v2
Graphics
GT 640 | P4000
Mac
Mac mini
macOS do not works like microsoft windows, hardware video acceleration tasks are handled by the IGPU usually.

use your previous Ivy Bridge build as example (GA-Z77X-UD5H | i7 3770K | GeForce GTX 970)
If you playback a H.264 video clip, the H.264 hardware decoding task is handled by the IGPU HD4000 not the dGPU GTX970.
Apple designed how the MAC system/macOS works (macOS supposed to be only running on Apple MAC hardware), don't argue for why not use the GTX 970 for hardware decoding.

the system setting should be like this

SMBIOS : iMac13,2
HD4000 IGPU device name -> IGPU (iMac13,2 use this name)
GTX970 dGPU device name -> GFX0 (iMac13,2 use this name, other SMBIOS may use different device name)

ACPI DSDT rename:
GFX0 -> IGPU
PEGP -> GFX0

ig-platform-id : 0x01620007 (headless mode, i.e. no video framebuffer, no video port)

your display monitor is connected to dGPU, the IGPU do not has any connection to your monitor, the IGPU is working in headless mode or offline mode.
 

jaymonkey

Moderator
Joined
Aug 27, 2011
Messages
2,678
Motherboard
ASRock-Z97 EX6
CPU
i7-4790K OC @ 4.8GHz
Graphics
Vega 64LC + HD4600
Mac
MacBook Air, MacBook Pro
Mobile Phone
Android, iOS
Wow... thank you for all your time and help. I'll give that a try. Will iMac 13,2 work with my 8-core, 16 thread i9-9900K?

@kentval,

If you have i9-9900K CPU use one of the new iMac19,X SMBIOS's, lot of good success reported with those now when used with i9 CPU's (search the forums) and should work fine as long as you the appropriate headless IGPU PlatformID ...

See the headless section of this guide :-


Cheers
Jay
 
Joined
Jul 23, 2012
Messages
526
Motherboard
GA-Z77N-WIFI - F3 - Clover UEFI
CPU
E3-1225 v2
Graphics
GT 640 | P4000
Mac
Mac mini
Wow... thank you for all your time and help. I'll give that a try. Will iMac 13,2 work with my 8-core, 16 thread i9-9900K?
No, select the best matched SMBIOS for your Coffee Lake system, maybe iMac19,1, (macOS 10.14.4 (18E2034) is required)

Apple iMac "Core i9" 3.6 27-Inch (5K, 2019) Specs
 
Joined
Apr 29, 2012
Messages
155
Motherboard
ASUS ROG Mamimus XI Hero (Wifi)
CPU
i9-9900K
Graphics
Vega 64
Mac
iMac, MacBook Pro, Mac mini
Mobile Phone
iOS
Gentlemen - thank you. After visiting the guide, I see this:
while -My- sysdef is 19,1 and PlatformID is 0x3EA50009

the guide only goes to

18,x and suggests a sys def of 0x3E920003 or 0x3E910003
(the connectors look OK, except that the final flag of mine is 20, and that headless page says it should be 40.

I'm kinda hanging on to the 19,1 sysdef in anticipation of the imminent release of 10.14.5, which as I understand the rumors, should more fully support the i9-9900K (I'm running 10.14.4 now)

Last edited: 3 minutes ago
 
Joined
Mar 27, 2013
Messages
15
Motherboard
MSI Meg Z390 GodLike
CPU
i9-9900K
Graphics
Radeon VII
Mac
iMac, MacBook Pro
Mobile Phone
iOS
I'm stuck as well. VDA Decoder Failed.
 
Top