Contribute
Register

Troubleshooting iMessage Login Issues

Joined
Aug 21, 2012
Messages
3
Motherboard
P8P67 DELUXE ASUS patched bios (2302)
CPU
Intel Core i7 2600k
Graphics
MSI R6850 Cyclone
Mac
Classic Mac
Mobile Phone
Article: Troubleshooting iMessage Login Issues

Does this also fix the Messages beta expiration on mac os x Lion?
 
Joined
Feb 27, 2013
Messages
2
Motherboard
Gigabyte H77N-WIFI
CPU
Intel Core i3 3225
Graphics
Intel HD Graphics 4000 512 MB
Mac
Classic Mac
Mobile Phone
I installed Chimera a two weeks ago and imessage was working wonderfully until the morning of Feb 26 when the FaceTime (never used before) challenged me for my password. iMessage crashed shortly thereafter and whenever I tried to start it up, I'd get the "Your Apple ID "XXXXX@email.com" can't be used to set up iMessage at this time." I tried Chimera 2.0.1 which didn't help. Here's what DID work. *I changed my Apple ID password.* I had an old password without a CAP letter and read somewhere that it might be an issue....which I didn't believe but tried anyway. I know, sounds like voodoo but thought I'd share it in case it saves someone else a few hours of searching around.
 
Joined
Feb 9, 2012
Messages
43
Motherboard
GA-Z68XP-UD3
CPU
i7-2600K
Graphics
HD 6870
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
  4. Mac mini
Mobile Phone
  1. iOS
I am running a fusion drive setup and at first, this fix did not work for me. I was able to get it working by using Chameleon Wizard to do two things: first, I generated a new serial number and profile in smbios, and second, set my default drive (in org.chameleon.boot.plist) to my SSD in my fusion drive, which is disk (0,2) in Chameleon/Chimera. I then copied my /Extra folder to the "Boot OS X" helper partition on my SSD (disk0s3 on my machine). Just to make sure, I also extracted and copied boot, boot0 and boot1h to the correct places using the commands in Neilhart's guide. After a reboot, I was able to log into Messages and it is working fine. I know a few of you have fusion drive setups and I hope this is helpful to you. Like many of us, I've been working on this for a few evenings trying to get Messages working!

My build: GA-Z68XP-UD3, i7 2600k, Radeon 6870, 16GB RAM, MacMini 5,1 profile
 
Joined
Jan 17, 2013
Messages
3
Motherboard
hackintosh
CPU
i7-3770k
Graphics
intel hd 4000
Mac
Classic Mac
Mobile Phone
  1. iOS
Has anyone got it to work with a Fusion drive? Because i haven't. otherwise it works great :)
 
Joined
Dec 1, 2010
Messages
55
Motherboard
Z390 DESIGNARE
CPU
i9-9900K
Graphics
RX 5500 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
i ran the new chimera tried to log in to imessage and got the above message, rebooted and tried to log in and it works, oh also make sure you are either using ethernet or wifi card, both cannot be turn on and be connected to your network
 
Joined
Dec 19, 2011
Messages
147
Motherboard
Gigabyte GA-Z77-UD5H rev. 1.1
CPU
i5 3570k 3.4ghz (OC 4.3)
Graphics
Nvidia GeForce GTX 660, 2GB; HD4000 both using HDMI Audio
Mac
  1. iMac
Classic Mac
Mobile Phone
  1. iOS
Article: Troubleshooting iMessage Login Issues

You forgot the 'Call apple issue" that if you add a valid creditcard or login any legit apple device will fix the problem.

Or you can update your apple ID password. All I ad to do was add a unique character to the end of my password and voila! Chimera, Clover USB and Chameleon fixes all work.
 
Joined
Dec 19, 2011
Messages
147
Motherboard
Gigabyte GA-Z77-UD5H rev. 1.1
CPU
i5 3570k 3.4ghz (OC 4.3)
Graphics
Nvidia GeForce GTX 660, 2GB; HD4000 both using HDMI Audio
Mac
  1. iMac
Classic Mac
Mobile Phone
  1. iOS
Article: Troubleshooting iMessage Login Issues

as per comment 1, thanks for telling us that, but how about telling us how to know when it matches, i have no way of knowing this.

Anyway, from what i've seen the main article here is not my issue, i even tried a clean rebuild, used the latest chameloeon wizard to generate a unique serial, and imessage still wont login "Cannot be used at this time......" errors, it seems to me so far for many people this chimera fix is only partial, ie i can login if i get my iPad/iphone etc to login using the macs credentials then login again on the hack, and although this works every time it is NOT a full fix when the hack depends on having another idevice do the validating first. Basically i beleive although progress has been made it is not yet complete (we are missing something that apple is using to validate which hacks do not have yet).

I wish i knew more than i do having only been a hackintosher for about 6 months, i'd love to be able to fix this for everyone.

Use Chameleon Wizard to generate a unique SMBIOS.plist. Now apple recognizes 17 digit serials, all I had to do was add 6 random digits to the serial number and iMessages worked like a charm.
 
Joined
Dec 19, 2011
Messages
147
Motherboard
Gigabyte GA-Z77-UD5H rev. 1.1
CPU
i5 3570k 3.4ghz (OC 4.3)
Graphics
Nvidia GeForce GTX 660, 2GB; HD4000 both using HDMI Audio
Mac
  1. iMac
Classic Mac
Mobile Phone
  1. iOS
Article: Troubleshooting iMessage Login Issues

Install Chimera 2.0, then move Extra folder to the desktop. Mount your boot drives and copy the extra folder to the 2 boot drives (like you did wen you created the drive). Once done, reboot and try logging in - should be good to go!
 
Top