Contribute
Register

Trouble installing El Capitan 10.11.4 - Hard Disk not found in Disk Utility

Status
Not open for further replies.
Joined
Jan 27, 2017
Messages
15
Motherboard
Acer Aspire V3 372 Mobo, Chipset : SkylakeU Premium PCH
CPU
Intel Core i5 6267u 2.9ghz
Graphics
Intel Iris 550
Mobile Phone
  1. Android
Hi All,

I bought my Acer v3 372 laptop recently. I found the specs of this machine to be very much similar to the late 2016 MacBook Pro with touchbar and thus I always have tried to install Mac OS on this system.

I began by trying a vanilla install of El capitan. I followed the Rehabman guide for preparing the usb. But as soon as I reach the clover bootloader and select my usb, I get a black screen with no response. I did search the web and tried using the 'OsxAptioFix2Drv' driver. It did not help. BTW I have UEFI support and all attempts are made in this mode. I then tried Unibeast to create the Installer. The installer successfully booted but my keyboard and mouse was not working. I then used KextBeast to install voodooPS2controller kext by Rehabman on it (I know I could copy kext into efi partition but the efi folder was empty!). That fixed my keyboard and mouse. I moved onto preparing my drive and more bad news :( ... My SSD (only storage) was missing and all the disk utility showed was the installer usb. I am stuck in this situation and have no idea about moving on. Please help. And ! I observed the verbose mod output while using unibeast : It gave the following warning before booting into the installer : IOAHCIBlockStorageDriver : Could not recover SATA HDD after 5 attempts, terminating . Please help me install the OS. And I promise all the people out there with this laptop that I will publish a full guide if I can successfully hackintosh. I am including the specs below :

Intel Core i5 6267u 2.9Ghz Skylake
4 GB DDR3 Ram
Iris 550 GPU
256 GB SSD
Full HD Screen
For more info, please see the HWinfo screenshot attached.

Thanks in Advance.

systemspec.png
 
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,466
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi All,

I bought my Acer v3 372 laptop recently. I found the specs of this machine to be very much similar to the late 2016 MacBook Pro with touchbar and thus I always have tried to install Mac OS on this system.

I began by trying a vanilla install of El capitan. I followed the Rehabman guide for preparing the usb. But as soon as I reach the clover bootloader and select my usb, I get a black screen with no response. I did search the web and tried using the 'OsxAptioFix2Drv' driver. It did not help. BTW I have UEFI support and all attempts are made in this mode. I then tried Unibeast to create the Installer. The installer successfully booted but my keyboard and mouse was not working. I then used KextBeast to install voodooPS2controller kext by Rehabman on it (I know I could copy kext into efi partition but the efi folder was empty!). That fixed my keyboard and mouse. I moved onto preparing my drive and more bad news :( ... My SSD (only storage) was missing and all the disk utility showed was the installer usb. I am stuck in this situation and have no idea about moving on. Please help. And ! I observed the verbose mod output while using unibeast : It gave the following warning before booting into the installer : IOAHCIBlockStorageDriver : Could not recover SATA HDD after 5 attempts, terminating . Please help me install the OS. And I promise all the people out there with this laptop that I will publish a full guide if I can successfully hackintosh. I am including the specs below :

Intel Core i5 6267u 2.9Ghz Skylake
4 GB DDR3 Ram
Iris 550 GPU
256 GB SSD
Full HD Screen
For more info, please see the HWinfo screenshot attached.

Thanks in Advance.

View attachment 246162

Follow the Clover guide linked from the FAQ.
http://www.tonymacx86.com/el-capita...faq-read-first-laptop-frequent-questions.html

Make sure your profile is filled with hardware details as requested in the FAQ and guide.

And if you have an issue, reply with "Problem Reporting" files as per FAQ.
 
Joined
Jan 27, 2017
Messages
15
Motherboard
Acer Aspire V3 372 Mobo, Chipset : SkylakeU Premium PCH
CPU
Intel Core i5 6267u 2.9ghz
Graphics
Intel Iris 550
Mobile Phone
  1. Android
Follow the Clover guide linked from the FAQ.
http://www.tonymacx86.com/el-capita...faq-read-first-laptop-frequent-questions.html

Make sure your profile is filled with hardware details as requested in the FAQ and guide.

And if you have an issue, reply with "Problem Reporting" files as per FAQ.

Thanks for the reply. I did a bit of research and managed to install El capitan + Clover. Most of the things are working except audio and Wifi. I used a clover folder from someone who had the same Laptop in this forum. The system is fairly stable. I have not patched DSDTs or SSDTs. I am a beginner in hackintoshing and would like to get away without much of the advanced patching stuff. All the fixes post install was done on the config.plist in the clover folder and also some essential kexts are installed in efi clover. I know my wifi is incompatible but the audio is the biggest issue now.

I have got a Realtek ALC255 audio chipset (recognized from linux dump). I searched the web for different fixes but none of them worked. Finally I tried an AppleHDA.kext+HDAEnabler3.kext and got my speakers and microphone recognized. But the sound is still not there. I can adjust the volume but no sound is heard nor any audio and video files can be played. I also plugged in a pair of headphones and it recognized it but still no sound. Further, I guessed the mic is working from the variation of the signal level in settings panel.I also started getting random Kernel panics. I am attaching my clover folder and also linking the audio kexts I installed. Please help me fix the issue.

I was successfully able to configure audio by installing the kexts below and use rehabman's 'Audio Layout 3' DSDT patch.

Kexts:

  1. View attachment 167494
  2. View attachment 167495
Patch: https://github.com/RehabMan/Laptop-DSDT-Patch
 

Attachments

  • CLOVER.zip
    2 MB · Views: 94

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,466
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Thanks for the reply. I did a bit of research and managed to install El capitan + Clover. Most of the things are working except audio and Wifi. I used a clover folder from someone who had the same Laptop in this forum. The system is fairly stable. I have not patched DSDTs or SSDTs. I am a beginner in hackintoshing and would like to get away without much of the advanced patching stuff. All the fixes post install was done on the config.plist in the clover folder and also some essential kexts are installed in efi clover. I know my wifi is incompatible but the audio is the biggest issue now.

I have got a Realtek ALC255 audio chipset (recognized from linux dump). I searched the web for different fixes but none of them worked. Finally I tried an AppleHDA.kext+HDAEnabler3.kext and got my speakers and microphone recognized. But the sound is still not there. I can adjust the volume but no sound is heard nor any audio and video files can be played. I also plugged in a pair of headphones and it recognized it but still no sound. Further, I guessed the mic is working from the variation of the signal level in settings panel.I also started getting random Kernel panics. I am attaching my clover folder and also linking the audio kexts I installed. Please help me fix the issue.

Audio/WiFi is covered in the FAQ.
http://www.tonymacx86.com/el-capita...faq-read-first-laptop-frequent-questions.html
 
Status
Not open for further replies.
Top