Contribute
Register

Three Monitor Setup wont work, need help HD7850

Status
Not open for further replies.
Joined
May 19, 2011
Messages
29
Motherboard
GA-z68x-ud3h-b3
CPU
i7 2600k
Graphics
AMD HD7850 2GB
Mac
  1. iMac
Classic Mac
Mobile Phone
My settings:

DP = DisplayPort
OSX = 10.9
GraphicsEnabler= Yes (otherwise i dont get acceleration, laggy animations etc..)

Default Framebuffer = Futomaki (originally, only one screen would work on only 1 port, DisplayPort 2)

After hours and pages and txt documentation of what i have done, ive finally was able to get all 4 ports working (DP1, DP2, HDMI, DVI1) (Once again DVI2 (bottom), did not even tried to fix it since i dont use it)

Dual monitor works with any combination of the 4 ports (didnt test DP1+DP2, since i only got 1 DP cable) that is, DP1+HDMI, DP2+HDMI, DVI1+HDMI, DP1+DVI1,DP2+DVI1

Triple monitor works if i use GraphicsEnabler=no, but again, i get no acceleration (i have to use the sleep trick, otherwise at start up only one screen works)

My system does not use DSDT.aml, so i cant inject my card through dsdt.aml



Hello,



i have just patched my own personality to get all ports working on my HD 7850 (it has 5 ports, and patched it to have the top 4 work, since i dont need the bottom DVI)



Now, all of these ports work with a single monitor and dual monitor as explained above. However, as soon as i plug in the third screen (DVI1+HDMI+DP1 or DVI1+HDMI+DP2, all my screens get re-arranged, which means it gets detected) , DP1 and HDMI works and DVI gives me a black screen.. if i tried to do something.. i get the spinning circle on the mouse and im not able to move anything, exept the mouse.. if i unplug the any of the three screens, then it goes back to normal and the two remaining screens begin to function normally again..



Any ideas on how to get the third monitor to work?



thanks!
 

neilhart

Moderator
Joined
May 25, 2010
Messages
2,704
Motherboard
ASRock Fatal1ty Z270 Gaming - ITX/ac
CPU
i7-7700T
Graphics
GTX960
Mac
  1. MacBook
  2. MacBook Pro
Mobile Phone
  1. iOS
You should go read the rules. You should complete your profile which will provide a description of your system hardware. And you need to share what OS X version you are attempting to run and the process that you followed in the installation.

Good modding,
neil
 
Joined
May 19, 2011
Messages
29
Motherboard
GA-z68x-ud3h-b3
CPU
i7 2600k
Graphics
AMD HD7850 2GB
Mac
  1. iMac
Classic Mac
Mobile Phone
You should go read the rules. You should complete your profile which will provide a description of your system hardware. And you need to share what OS X version you are attempting to run and the process that you followed in the installation.

Good modding,
neil

Hi, i don't think it really matters if i dont have my motherboard on my profile, as this question is not related to motherboard. However, i agree with you on the OSX version :p, forgot to post that..
thanks
 
Joined
May 12, 2011
Messages
2,601
Motherboard
GA-X99M-Gaming 5
CPU
i7-5930K
Graphics
GTX 970
Mac
  1. MacBook Pro
Classic Mac
  1. Color Classic
Mobile Phone
  1. Android
Hi, i don't think it really matters if i dont have my motherboard on my profile, as this question is not related to motherboard.
Regardless of what you think, the rules exist for a reason, you can of course ignore them and then wonder why no one willing to help... :rolleyes:
 
Joined
May 19, 2011
Messages
29
Motherboard
GA-z68x-ud3h-b3
CPU
i7 2600k
Graphics
AMD HD7850 2GB
Mac
  1. iMac
Classic Mac
Mobile Phone
Regardless of what you think, the rules exist for a reason, you can of course ignore them and then wonder why no one willing to help... :rolleyes:

Please stay on topic... i've added them to avoid this type of unnecessary comments...

thanks

Bump..
 
Status
Not open for further replies.
Top