Contribute
Register

Solved > System reboots on formerly rock solid setup after Catalina install

Joined
May 9, 2016
Messages
87
Motherboard
Gigabyte Z170X-UD5
CPU
i7-6700
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac mini
@dalilama

Dear Dalilama - still getting these crashes. what do you think of these messages:

Dec 3 06:57:08 carl-mac-desktop com.apple.xpc.launchd[1] (com.apple.xpc.launchd.user.domain.501.100003.Aqua): com.apple.ReportCrash (lint): Unrecognized MachService property: DrainMessagesOnCrash
Dec 3 21:06:10 carl-mac-desktop com.apple.xpc.launchd[1] (com.apple.xpc.launchd.user.domain.501.100006.Aqua): com.apple.ReportCrash (lint): Unrecognized MachService property: DrainMessagesOnCrash

(found near "crash")

and

Dec 3 02:47:47 carl-mac-desktop suhelperd[477]: objc[477]: Class KeychainMasterHandler is implemented in both /usr/lib/libIASAuthReboot.dylib and /System/Library/CoreServices/Software Update.app/Contents/Resources/suhelperd. One of the two will be used. Which one is undefined.
Dec 3 05:59:32 carl-mac-desktop suhelperd[477]: objc[477]: Class KeychainMasterHandler is implemented in both /usr/lib/libIASAuthReboot.dylib and /System/Library/CoreServices/Software Update.app/Contents/Resources/suhelperd. One of the two will be used. Which one is undefined.
Dec 3 06:57:30 carl-mac-desktop suhelperd[883]: objc[883]: Class KeychainMasterHandler is implemented in both /usr/lib/libIASAuthReboot.dylib and /System/Library/CoreServices/Software Update.app/Contents/Resources/suhelperd. One of the two will be used. Which one is undefined.
Dec 3 21:02:42 carl-mac-desktop suhelperd[501]: objc[501]: Class KeychainMasterHandler is implemented in both /usr/lib/libIASAuthReboot.dylib and /System/Library/CoreServices/Software Update.app/Contents/Resources/suhelperd. One of the two will be used. Which one is undefined.

(Found near "reboot" in the system.log)

Am not sure how to diagnose this problem further.. Appreciate any thoughts. Thanks, Carl
Also posted on this thread: https://www.tonymacx86.com/threads/success-catalina-on-gigabyte-ga-z170x-ud5-th.284708/post-2041020

I have tried installing a fresh version of Catalina from the installer on a clean drive. This is a completely fresh install. With nothing else on it only Catalina 10.15.1 (macOS 10.15.1 (19B88)). Then booted using that EFI. It still crashes, frequently. A search of the console system.log file finds:

Search for "reboot" in system.log:

Dec 3 14:41:22 CarlMacDesktop suhelperd[593]: objc[593]: Class KeychainMasterHandler is implemented in both /usr/lib/libIASAuthReboot.dylib and /System/Library/CoreServices/Software Update.app/Contents/Resources/suhelperd. One of the two will be used. Which one is undefined.
Dec 3 23:09:06 CarlMacDesktop suhelperd[571]: objc[571]: Class KeychainMasterHandler is implemented in both /usr/lib/libIASAuthReboot.dylib and /System/Library/CoreServices/Software Update.app/Contents/Resources/suhelperd. One of the two will be used. Which one is undefined.

Search for "crash" in system.log:

Dec 3 14:40:41 iMac com.apple.xpc.launchd[1] (com.apple.xpc.launchd.user.domain.248.100006.Aqua): com.apple.ReportCrash (lint): Unrecognized MachService property: DrainMessagesOnCrash
Dec 3 14:42:15 CarlMacDesktop com.apple.xpc.launchd[1] (com.apple.xpc.launchd.user.domain.501.100040.Aqua): com.apple.ReportCrash (lint): Unrecognized MachService property: DrainMessagesOnCrash
Dec 3 23:08:45 CarlMacDesktop com.apple.xpc.launchd[1] (com.apple.xpc.launchd.user.domain.501.100006.Aqua): com.apple.ReportCrash (lint): Unrecognized MachService property: DrainMessagesOnCrash

Appreciate any comments / thoughts from others. I am unable to diagnose this further and would much appreciate any help/pointers. Thanks.
 
Joined
Aug 23, 2017
Messages
3
Motherboard
Gigabyte GA-H370-HD3
CPU
i7-9700K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Hello @carljharris3141

Do you still have this issue?
I’ve got a similar behaviour but still on Mojave. Hackintosh boots and login, but after 1-2 min it crashes and reboots.

I’ve looked in Process Manager to find that mdsync process could be faulty. If I manually killed this process, the Hackintosh would crash and reboot right away.
Then problem is still occuring when I boot from an external backup.

---

Intel Core i7-9700K (3.6 GHz / 4.9 GHz)
Gigabyte H370 HD3
Corsair RM650x V2 80PLUS Gold
Sapphire NITRO+ Radeon RX 580 8GD
Samsung SSD 970 EVO M.2 PCIe NVMe 500 Go
G.Skill Aegis 32 Go (2 x 16 Go) DDR4 2400 MHz CL17
 
Joined
May 9, 2016
Messages
87
Motherboard
Gigabyte Z170X-UD5
CPU
i7-6700
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac mini
Hello @carljharris3141

Do you still have this issue?
I’ve got a similar behaviour but still on Mojave. Hackintosh boots and login, but after 1-2 min it crashes and reboots.

I’ve looked in Process Manager to find that mdsync process could be faulty. If I manually killed this process, the Hackintosh would crash and reboot right away.
Then problem is still occuring when I boot from an external backup.

---

Intel Core i7-9700K (3.6 GHz / 4.9 GHz)
Gigabyte H370 HD3
Corsair RM650x V2 80PLUS Gold
Sapphire NITRO+ Radeon RX 580 8GD
Samsung SSD 970 EVO M.2 PCIe NVMe 500 Go
G.Skill Aegis 32 Go (2 x 16 Go) DDR4 2400 MHz CL17
Yes. Unfortunately I still have this issue. On Catalina 10.15.1. To be clear my Mojave install was completely stable

Why do you hone in on mdsync? Any idea what this process does? Thanks, Carl
 
Joined
May 9, 2016
Messages
87
Motherboard
Gigabyte Z170X-UD5
CPU
i7-6700
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac mini
Just a brief update to this thread.. I have installed the Supplemental update 10.15.2 now. After 30 minutes it crashed. I went through the system.log and saw some error messages related to "Keystone" the buggy google service that runs updates for Chrome and Google Sync (that I thought I had removed). I decided to reinstall Chrome and Google Sync again.. which I did.. on-top.. then rebooted. The machine looks to be stable.. has been alive now for 45 minutes and counting.. will see if this fixes it..
 
Last edited:
Joined
May 9, 2016
Messages
87
Motherboard
Gigabyte Z170X-UD5
CPU
i7-6700
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac mini
Just a brief update to this thread.. I have installed the Supplemental update 10.15.2 now. After 30 minutes it crashed. I went through the system.log and saw some error messages related to "Keystone" the buggy google service that runs updates for Chrome and Google Sync (that I thought I had removed). I decided to reinstall Chrome and Google Sync again.. which I did.. on-top.. then rebooted. The machine looks to be stable.. has been alive now for 45 minutes and counting.. will see if this fixes it..
Update. I rebuilt the kernel kexts

sudo kextcache -i /

Following a reboot the machine has been up for over 7 hours now without crashing. I think it's time to mark this issue as solved. Even if the solution isn't entirely clear.
 
Joined
May 9, 2016
Messages
87
Motherboard
Gigabyte Z170X-UD5
CPU
i7-6700
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac mini
Just to report system has been up now for 1 day 3 hours. Please mark as solved. My suspicion is that this was caused by the google keystone application damaging the OS.That the removal and reinstall of all google apps. Followed by the install of 10.15.2 followed by the subsequent Kext cache repair fixed it. In any event, the system is now stable.
 
Joined
May 9, 2016
Messages
87
Motherboard
Gigabyte Z170X-UD5
CPU
i7-6700
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac mini
Just to add to this thread. Further diagnosis indicated that it was the DVD r/w drive that was causing 'random power downs' in Catalina. There is a patch which Trizel has put together for Clover, the discussion and patch can be found here. This is worth anyone who has a Catalina Hackintosh experiencing random shutdowns that has a DVD r/w or optical drive connected via SATA looking at:


And for ease Tizel's patch is here:

Add patch manually on KernelToPatch

Find : 636F6D2E 6170706C 65005F5F 6B65726E 656C5F5F 00
Replace : 6E6F742E 6170706C 65005F5F 6B65726E 656C5F5F 00
Comment : Disable power state change timeout kernel panic (10.15+)
MatchOS : 10.15.x
 
Joined
Dec 9, 2017
Messages
33
Motherboard
Gigabyte Z270X Gaming 5
CPU
i7-7700K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Dear All:

I had been using my system that was perfect working on Mojave upgraded to Catalina. The system installed without any issues. I experiences the same issue when running, just seems out of nowhere it just reboots (no shutdowns). Seems to happen after about 20 to 60 minutes after boot.

I’ve tried a completely fresh install of Catalina on a clean NVMe even with no additional programs installed and am getting the same result. I would very much appreciate guidance on how to dig further for a solution of this issue.

My system has the following configuration:

Installed OS:
macOS Catalina Version 10.15.2

Installed Kexts:
AppleALC
VirtualSMC
Lilu
USBInjectAll
WhateverGreen

Bootloader:
Clover 5100

Settings:
change HDAS to HDEF
change HECI to IMEI
change PEGP to GFX0
change EHC1 to EH01
change EHC2 to EH02
Boot arguments darkwake=8 nv_disable=1
XMPDetection=Yes
Product Model iMac 18,3

The machine is a standard build on a Gigabyte motherboard with a 256GB Samsung 960 NVME M.2 EVO drive
Gigabyte Z170X Gaming 5
Intel i7-7700K @ 5.0GHz
Gigabyte AORUS Radeon RX 580 GPU
Samsung 960 EVO NVMe M.2


I've tried all the solutions in this thread and noting helps. I've SATA DVD-RW drive and one external BD-RW connected via USB 3.0.


I would very much appreciate any advices on how to fix this issue. Thank you!
 
Joined
May 9, 2016
Messages
87
Motherboard
Gigabyte Z170X-UD5
CPU
i7-6700
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac mini
Dear All:

I had been using my system that was perfect working on Mojave upgraded to Catalina. The system installed without any issues. I experiences the same issue when running, just seems out of nowhere it just reboots (no shutdowns). Seems to happen after about 20 to 60 minutes after boot.

I’ve tried a completely fresh install of Catalina on a clean NVMe even with no additional programs installed and am getting the same result. I would very much appreciate guidance on how to dig further for a solution of this issue.

My system has the following configuration:

Installed OS:
macOS Catalina Version 10.15.2

Installed Kexts:
AppleALC
VirtualSMC
Lilu
USBInjectAll
WhateverGreen

Bootloader:
Clover 5100

Settings:
change HDAS to HDEF
change HECI to IMEI
change PEGP to GFX0
change EHC1 to EH01
change EHC2 to EH02
Boot arguments darkwake=8 nv_disable=1
XMPDetection=Yes
Product Model iMac 18,3

The machine is a standard build on a Gigabyte motherboard with a 256GB Samsung 960 NVME M.2 EVO drive
Gigabyte Z170X Gaming 5
Intel i7-7700K @ 5.0GHz
Gigabyte AORUS Radeon RX 580 GPU
Samsung 960 EVO NVMe M.2


I've tried all the solutions in this thread and noting helps. I've SATA DVD-RW drive and one external BD-RW connected via USB 3.0.


I would very much appreciate any advices on how to fix this issue. Thank you!
Pls read this thread here https://www.tonymacx86.com/threads/success-catalina-on-gigabyte-ga-z170x-ud5-th.284708/post-2048873


The problem is most likely your optical drive causing the kernel panic. The exact patch I posted in that posting works and should solve this issue.
 
Joined
Dec 9, 2017
Messages
33
Motherboard
Gigabyte Z270X Gaming 5
CPU
i7-7700K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Pls read this thread here https://www.tonymacx86.com/threads/success-catalina-on-gigabyte-ga-z170x-ud5-th.284708/post-2048873


The problem is most likely your optical drive causing the kernel panic. The exact patch I posted in that posting works and should solve this issue.

Thanks for pointing me to this guide. I've tried already the injection but no change, no idea what's wrong. The only one thing I forgot is a 4-port Marvell 9230 SATA RAID card connected on the PCIe bus. I will disconnected it to see if this helps.
 
Top