Contribute
Register

System Freezes; Screens go to one black one white.

Joined
Jul 13, 2016
Messages
553
Motherboard
ASUS ROG STRIX Z370-F
CPU
I5-8600K
Graphics
Vega 56
Mac
Mac mini, Mac Pro
Mobile Phone
iOS
If you are not using any injections, macOS sets the ig-platform-id to 3E920000 which is a headless/connectorless id. I'm surprised it gave you an output at all.
I tried with nothing and then I tried with WG. They both produced the same thing. I also thought the 18,1 would have a port enabled because it was the SM for intel only.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
7,387
Motherboard
Asus ROG Strix Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
When it crashed with just Messages and Mail open, did you have one or two monitors connected?
 
Joined
Jul 13, 2016
Messages
553
Motherboard
ASUS ROG STRIX Z370-F
CPU
I5-8600K
Graphics
Vega 56
Mac
Mac mini, Mac Pro
Mobile Phone
iOS
When it crashed with just Messages and Mail open, did you have one or two monitors connected?
Always two, I know you do not use 2 monitors but it has been so many years I am not sure how to work without them bolth of them.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
7,387
Motherboard
Asus ROG Strix Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
Always two, I know you do not use 2 monitors but it has been so many years I am not sure how to work without them bolth of them.
I was asking because you previously mentioned reaching stability with one monitor.
 
Joined
Jul 13, 2016
Messages
553
Motherboard
ASUS ROG STRIX Z370-F
CPU
I5-8600K
Graphics
Vega 56
Mac
Mac mini, Mac Pro
Mobile Phone
iOS
I was asking because you previously mentioned reaching stability with one monitor.
Yes but it was only for like half a day, basically with all the stuff open that had triggered the crashes fastest like within 2/hrs. When I only had one monitor it did not happen in the 2/hr - 4/hr time frame. The crash yesterday came after 4 days of uptime, however I had limited my use of WOW to only wow without movies on iTunes. I know other people run two monitors do not experience these issues but most do not have two 4k at least the people I talked with. I generated a topic but no one replied to the post, So I take it that dual 4k monitors is not common @ least here on Tonymac! Honestly these monitors have been some source of contention for a while since the Mac Pro 2013 runs awesome with 1080 monitors but soon as you plug in 4K Frame rates drop considerably. It was one of the main reason I turned to a Hack instead of waiting out the new Mac Pro expected in 2019. For me it was never about money it was about being able to keep my system up to date hardware wise.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
7,387
Motherboard
Asus ROG Strix Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
Yes but it was only for like half a day, basically with all the stuff open that had triggered the crashes fastest like within 2/hrs. When I only had one monitor it did not happen in the 2/hr - 4/hr time frame. The crash yesterday came after 4 days of uptime, however I had limited my use of WOW to only wow without movies on iTunes. I know other people run two monitors do not experience these issues but most do not have two 4k at least the people I talked with. I generated a topic but no one replied to the post, So I take it that dual 4k monitors is not common @ least here on Tonymac! Honestly these monitors have been some source of contention for a while since the Mac Pro 2013 runs awesome with 1080 monitors but soon as you plug in 4K Frame rates drop considerably. It was one of the main reason I turned to a Hack instead of waiting out the new Mac Pro expected in 2019. For me it was never about money it was about being able to keep my system up to date hardware wise.
This guy has two 4K monitors running:
https://www.tonymacx86.com/threads/success-gigabyte-z370-gaming-7-intel-core-i7-8700k-rx-580-2x-dell-p2715q-4k-60hz.252989/
 
Joined
Jul 13, 2016
Messages
553
Motherboard
ASUS ROG STRIX Z370-F
CPU
I5-8600K
Graphics
Vega 56
Mac
Mac mini, Mac Pro
Mobile Phone
iOS
my system is almost identical, we have the same HD, Memory, CPU, we differ on the video card and the monitor brands/size. My system before using a modified version of your EFI I used this guide. One thing I noticed is that he was very specific about installing the injectusball.kext in L/E not Other. I can tell you that USBall in the other folder with my SSDT usb patch makes me lose BT not sure exactly why.. I use a card from OSXwifi in not sure what speed the port is prob 1x but it is the one right above the video card with a wire to the USB 2 header on the board. It has been in other places but since I use a water cooler it was better up top so I could mount the antenna on the inside of the case.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
7,387
Motherboard
Asus ROG Strix Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
my system is almost identical, we have the same HD, Memory, CPU, we differ on the video card and the monitor brands/size. My system before using a modified version of your EFI I used this guide. One thing I noticed is that he was very specific about installing the injectusball.kext in L/E not Other. I can tell you that USBall in the other folder with my SSDT usb patch makes me lose BT not sure exactly why.. I use a card from OSXwifi in not sure what speed the port is prob 1x but it is the one right above the video card with a wire to the USB 2 header on the board. It has been in other places but since I use a water cooler it was better up top so I could mount the antenna on the inside of the case.
I've had USBInjectAll in Other for quite a long time (I think more than 2 years) and I do it the same way on several hacks (both desktops and laptops). I've never lost Bluetooth on any of the systems.
 
Joined
Jul 13, 2016
Messages
553
Motherboard
ASUS ROG STRIX Z370-F
CPU
I5-8600K
Graphics
Vega 56
Mac
Mac mini, Mac Pro
Mobile Phone
iOS
I've had USBInjectAll in Other for quite a long time (I think more than 2 years) and I do it the same way on several hacks (both desktops and laptops). I've never lost Bluetooth on any of the systems.
Maybe ssdt is messed up causing it. I did not make it someone else did.
 
Joined
Jul 13, 2016
Messages
553
Motherboard
ASUS ROG STRIX Z370-F
CPU
I5-8600K
Graphics
Vega 56
Mac
Mac mini, Mac Pro
Mobile Phone
iOS
@pastrychef

Even though I had stability with two cards I was not happy with that I would rather solve the issue instead of placing a bandaid on it. It is a hardware problem as you have suggested from the beginning and I believe it is a faulty Motherboard.

I bought a new board Gigabyte Z370 HD3 it was the first on the buyers guide; and a new CPU I3 3800k just for good measure. I think together I think they were like $230. Popped the Vega 64, Hard drives some memory and a bench PSU. I did not put it in a case just left it on the cart next to me desk. it ran for 3 days without incident so I shut it down and changed out the CPU to the 8700k currently it has been 2 days without incident with the 8700k. I made my sincerest attempt at making it crash and so far have not been able to with this new MB. However, it has not been put into the case that is a project for this weekend after it has pulled a full week of stability.

Currently the I3 CPU is in the Gaming 5 board "the defective one" under windows running wow and rendering stuff in Revit, and running iTunes. I have yet to be able to crash this board under windows. I will also test the gaming 5 board in this configure under Mac OS this weekend and see if the same issue arise with a different CPU.

I am also not ruling out that it has something to do with the case only because I previously had a board similar to yours at the start of this journey and it also crashed "Could be for different reasons". It became my GF and has been running under windows for sometime without incident.

Hopefully I will have an answer as to case or Mother board after this weekend never had a faulty case before, but also have never had hardware that worked most of the time normally. Never experienced an intermittent problem that was not software.
 
Top