Contribute
Register

[Success] Z370M Plus II - Fix Shutdown Issue - Opencore

Joined
Dec 16, 2014
Messages
519
Motherboard
ASUS Z690-P DDR5 0404
CPU
i7-12700K
Graphics
RX 6600 XT
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
An old issue returned when upgrading from Catalina/Clover r5119 to Big Sur/OC 0.7.9 on a Z370M Plus II board - Signature/300 Series-3 - this board is a Z370M Plus II, not a TUF Z370-PLUS Gaming (closest option).

(The Z370M Plus II board was mainly sold outside the U.S. and maybe on e**y)

This issue may apply to other Z370 boards - the system does not fully shutdown (power LED light stays on) on shutdown.

Clover
In Clover there is a simply "FixShutdown" key that can be set to True and worked well on this board:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>ACPI</key>
<dict>
<key>DSDT</key>
<dict>
...
<key>Fixes</key>
<dict>
...

<key>FixShutdown</key>
<false -> true/>

...
</dict>
</dict>
....
</dict>
</plist>

Opencore

Dortania provides a fix for Opencore - https://dortania.github.io/OpenCore-Post-Install/usb/misc/shutdown.html - which provides patches for a missing s5 call - and a clue.

In BIOS the S4 and/or S5 calls can be enabled/disabled under APM/ErP (power settings):

1. Loading Optimized Defaults - disables ErP - shutdown seems to work on other Z370 boards, but not this one, or

2. Enable S5

3. Enable S4 + S5 - fixes shutdown issue for this board

That every problem could be fixed so easily!
 
Last edited:
Top