Contribute
Register

[SUCCESS] Z170X-UD5 TH, i7-6700K, AMD Radeon Pro WX 7100, 64GB DDR4

Joined
May 22, 2011
Messages
222
Motherboard
Gigabyte Z170X-UD5
CPU
i7-6700K
Graphics
RX 570
Mac
MacBook Air
Mobile Phone
iOS
Update 39 (Overclocking to 4.5 GHz):
1. changed the BIOS settings under "M.I.T." > "Advanced Frequency Settings" to "CPU Upgrade i7-6700k CPU 4.5 GHz"
2. created a fresh SSDT for my overclocked CPU with ssdtPRGen.sh with
Code:
~/ssdtPRGen.sh -f 4500 -turbo 450
3. Added "4500" to "Frequency MHz" in "Cpu" in my Clover config.plist because the "About This Mac" dialog did not show the higher CPU frequency OOB and was still resting at 4.01 GHz. However, I was able to see that the overclock worked with the Intel Power Gadget. Oddly enough, "About This Mac" now says 4.3 GHz i7 – I need to investigate this further.
4. updated Geekbench results in the build description
5. updated BIOS settings in the build description
6. I will upload the updated SSDT once I figured out why "About This Mac" shows a wrong value for the CPU clock frequency.
7. uploaded the updated SSDT even though my "About This Mac" dialogue still outputs the wrong CPU clock frequency
8. I created a thread about the issue and will try to eventually fix this issue in the future
Thanks for keeping this thread updated! I have the non-TH Z170x-UD5 and I ran into issues trying to overclock (boot loop). I'm going to try your steps above and see if that works.

Thanks again!
 
Joined
Sep 22, 2016
Messages
449
Motherboard
Z170X-UD5 TH-Clover
CPU
i7-6700K
Graphics
RX Vega 56
Mac
Mac mini
Mobile Phone
iOS
Thanks for keeping this thread updated!
Please note, that overclocking on macOS can be more complicated task than on using other OS. You really have to know, what you are doing, otherwise there is a huge risk to harm your system. Do not overclock if this I snot extremely needed! Stable and long working system is better investment that quickly damaged overlcloked one.
 
Joined
Aug 23, 2016
Messages
109
Motherboard
Gigabyte Z170X-UD5 TH
CPU
i7-6700K
Graphics
WX 7100
Mac
MacBook Pro, Mac mini, Mac Pro
Mobile Phone
iOS
Hey iLikeHackintosh. I agree. What I would advice, if at all, is to overclock in small increments, with thoroughly testing of the entire system and close observation of component temperatures under long term heavy load. In my experience, successful overclocking is closely connected to how well your build is ventilated and cooled. So, what works for some, might be too much for others because of enclosure and cooling combinations. And yes, there is always a certain risk involved.
 
Joined
Feb 22, 2018
Messages
110
Motherboard
GIGABYTE Z390 Designare
CPU
i7-8700K
Graphics
RX 580 & WX7100
Mac
MacBook Pro
Mobile Phone
iOS
@amadeusp81
I needed some help since you seem pretty knowledgable.
I have an RX 580 for gaming, and bought a WX7100 for 3D CAD Design.
I installed it and assumed it should work flawlessly, but it goes black after booting into clover. I select the macOS drive, then it goes black. Did you have this issue? Do you think you'd be able to help if I uploaded a picture of the verbose error?
 
Joined
Aug 23, 2016
Messages
109
Motherboard
Gigabyte Z170X-UD5 TH
CPU
i7-6700K
Graphics
WX 7100
Mac
MacBook Pro, Mac mini, Mac Pro
Mobile Phone
iOS
@amadeusp81
I needed some help since you seem pretty knowledgable.
I have an RX 580 for gaming, and bought a WX7100 for 3D CAD Design.
I installed it and assumed it should work flawlessly, but it goes black after booting into clover. I select the macOS drive, then it goes black. Did you have this issue? Do you think you'd be able to help if I uploaded a picture of the verbose error?
I'm happy to help, if I can.

So, you have both cards installed at once or did you replace the 580 with the 7100?

Let me ask you this first:
Have you enabled the internal GPU in the BIOS? I know from other cases with AMD cards that there were some cases of black screens when the internal GPU was turned off in the BIOS. In my BIOS the setting is located under Chipset > Internal Graphics. This has to be "Enabled".
 
Joined
Feb 22, 2018
Messages
110
Motherboard
GIGABYTE Z390 Designare
CPU
i7-8700K
Graphics
RX 580 & WX7100
Mac
MacBook Pro
Mobile Phone
iOS
I'm happy to help, if I can.

So, you have both cards installed at once or did you replace the 580 with the 7100?

Let me ask you this first:
Have you enabled the internal GPU in the BIOS? I know from other cases with AMD cards that there were some cases of black screens when the internal GPU was turned off in the BIOS. In my BIOS the setting is located under Chipset > Internal Graphics. This has to be "Enabled".
Sorry for the delayed response. I tried doing a fresh install, and the new Clover update locked me out of the PC til now.

I have 2 GPUs installed. The RX 580 in Slot 1 and the WX7100 in Slot 2.
I tried enabling eGPU in BIOS and Slot 2 selected, no go still.

The issue prior was it would boot until Clover screen, then when the drive was selected, it would go black.
Now it's the opposite. If I change the HDMI cable after macOS has booted, there's no problem. But I can't boot with the WX7100 selected or else it's black.
 
Joined
Aug 23, 2016
Messages
109
Motherboard
Gigabyte Z170X-UD5 TH
CPU
i7-6700K
Graphics
WX 7100
Mac
MacBook Pro, Mac mini, Mac Pro
Mobile Phone
iOS
Sorry for the delayed response. I tried doing a fresh install, and the new Clover update locked me out of the PC til now.

I have 2 GPUs installed. The RX 580 in Slot 1 and the WX7100 in Slot 2.
I tried enabling eGPU in BIOS and Slot 2 selected, no go still.

The issue prior was it would boot until Clover screen, then when the drive was selected, it would go black.
Now it's the opposite. If I change the HDMI cable after macOS has booted, there's no problem. But I can't boot with the WX7100 selected or else it's black.
I think in that case I am afraid that I will not be able to help you. I once tried to make two GTX950s work in my Hackintosh and had similar issues. After weeks of trying to overcome them, I gave up and switched to a more powerful single GPU setup. See the corresponding thread here: https://www.tonymacx86.com/threads/evga-gtx950-02g-p4-2951-kr-dual-4k-monitor-question.213638/
 
Joined
Aug 26, 2017
Messages
154
Motherboard
Z170X-UD5-TH
CPU
i7-6700K
Graphics
RX 580
Mac
iMac
Classic Mac
iMac, LC, Power Mac, Quadra
Thanks a lot, @amadeusp81’s Z170X-UD5 TH, that help me to build the USB. Then I adapt my personal config.
By the way, I'll try a clean install again, that very fast
 
Top