Contribute
Register

[SUCCESS] Z170X-UD5 TH, i7-6700K, AMD Radeon Pro WX 7100, 64GB DDR4

Joined
Sep 22, 2016
Messages
448
Motherboard
Z170X-UD5 TH-Clover
CPU
i7-6700K
Graphics
RX Vega 56
Mac
  1. Mac mini
Mobile Phone
  1. iOS
Update 18: Updated to High Sierra as follows:
1. Updated Clover to 4233
2. Downloaded macOS High Sierra Installer from App Store
3. mounted "macOS High Sierra Installer" located apfs.efi in the installer's package at /Contents/SharedSupport/BaseSystem.dmg > /Volumes/OS X Base System/usr/standalone/i386/apfs.efi and copied it to my boot volume's EFI at /EFI/CLOVER/drivers64UEFI/
4. copied FakeSMC.kext to my boot volume's EFI at /EFI/CLOVER/kexts/Other/
5. executed the macOS installer including a few reboots
6. once done, downloaded the latest Nvidia Web Driver (378.10.10.10.15.117)
7. activated SIP via Clover Configurator (CsrActiveConfig > 0x0)
8. touched the kext directories via 9. rebooted
10. installed the Nvidia Web Driver (did not restart after install!)
11. deactivated SIP via Clover Configurator (CsrActiveConfig > 0x3)
12. then rebooted
13. converted a secondary SSD to APFS (the boot volume has been converted during the installation process)
14. done (seems to be working very well so far)

Please can you explain your upgrade a bit more detailed way? Did you upgrade existing system? Or installed from scratch?
 
Joined
Sep 22, 2016
Messages
448
Motherboard
Z170X-UD5 TH-Clover
CPU
i7-6700K
Graphics
RX Vega 56
Mac
  1. Mac mini
Mobile Phone
  1. iOS
I fugured out, existing Sierra can be upgraded into High Sierra.. but those steps are very important to follow!!

6. once done, downloaded the latest Nvidia Web Driver (378.10.10.10.15.117)
7. activated SIP via Clover Configurator (CsrActiveConfig > 0x0)
8. touched the kext directories via
Code (Text):
sudo touch /Library/Extensions/ /System/Library/Extensions/
9. rebooted
10. installed the Nvidia Web Driver (did not restart after install!)

And do not forget remove kexts Lilu.kext and NvidiaGraphicsFixup.kext and then to add into Clover kexts folder on EFI partition the NVWebDriverLibValFix.kext.
 
Last edited:
Joined
Sep 22, 2016
Messages
448
Motherboard
Z170X-UD5 TH-Clover
CPU
i7-6700K
Graphics
RX Vega 56
Mac
  1. Mac mini
Mobile Phone
  1. iOS
I managed to upgrade into High Sierra from Sierra 10.12.6.

I had issue with NVIDIA Web Drivers, but solved it by using latest NvidiaGraphicsFixup.kext and patching CUDA driver.

nvidia-high-sierra.jpg
 
Joined
Sep 22, 2016
Messages
448
Motherboard
Z170X-UD5 TH-Clover
CPU
i7-6700K
Graphics
RX Vega 56
Mac
  1. Mac mini
Mobile Phone
  1. iOS
Joined
Sep 22, 2016
Messages
448
Motherboard
Z170X-UD5 TH-Clover
CPU
i7-6700K
Graphics
RX Vega 56
Mac
  1. Mac mini
Mobile Phone
  1. iOS
Joined
Feb 15, 2016
Messages
40
Motherboard
GA-170X-UD5-TH - BIOS F22g
CPU
i7-6700K
Graphics
RX 560 + HD 530
Mac
  1. iMac
  2. MacBook Pro
I fugured out, existing Sierra can be upgraded into High Sierra.. but those steps are very important to follow!!

6. once done, downloaded the latest Nvidia Web Driver (378.10.10.10.15.117)
7. activated SIP via Clover Configurator (CsrActiveConfig > 0x0)
8. touched the kext directories via
Code (Text):
sudo touch /Library/Extensions/ /System/Library/Extensions/
9. rebooted
10. installed the Nvidia Web Driver (did not restart after install!)

And do not forget remove kexts Lilu.kext and NvidiaGraphicsFixup.kext and then to add into Clover kexts folder on EFI partition the NVWebDriverLibValFix.kext.

Hey iLikeHackintosh,

Can you tell me exactly when you removed the Lilu.kext and NvidiaGraphicsFixup.kext and added the NVWebdriverLibValFix.kext.
Did you install with Lilu and NvidiaGraphicsFixup and then replaced with NVWebdriverLibValFix after install ?
Or did you install with NVWebdriverLibValFix?

Any info would be greatly appreciated.......Thanks in advance...
 
Last edited by a moderator:
Joined
Sep 22, 2016
Messages
448
Motherboard
Z170X-UD5 TH-Clover
CPU
i7-6700K
Graphics
RX Vega 56
Mac
  1. Mac mini
Mobile Phone
  1. iOS
Hey iLikeHackintosh,

Can you tell me exactly when you removed the Lilu.kext and NvidiaGraphicsFixup.kext and added the NVWebdriverLibValFix.kext.
Did you install with Lilu and NvidiaGraphicsFixup and then replaced with NVWebdriverLibValFix after install ?
Or did you install with NVWebdriverLibValFix?

Any info would be greatly appreciated.......Thanks in advance...


Hi! I was a bit hurry to install HS, so I didn't made proper homework to prepare system properly for NVIDIA Web Drivers. Seems that installing NVIDIA Web Drivers on HS requires a bit more attention. So remove all those Lilo NVWebdriverLibValFix NvidiaGraphicsFixup etc. Do not install anymore NVWebdriverLibValFix. Its built in latest NvidiaGraphicsFixup. It's recommended to move some drivers into EFI partition. So you have to make some clean up before installing NVIDIA Web Drivers. I recommend to uninstall old NVIDIA Web Drivers also before installing new ones.

Please read this post for more details: https://www.tonymacx86.com/threads/...er-on-high-sierra-black-screen-panics.234390/
 
Last edited by a moderator:
Joined
Feb 15, 2016
Messages
40
Motherboard
GA-170X-UD5-TH - BIOS F22g
CPU
i7-6700K
Graphics
RX 560 + HD 530
Mac
  1. iMac
  2. MacBook Pro
Hi! I was a bit hurry to install HS, so I didn't made proper homework to prepare system properly for NVIDIA Web Drivers. Seems that installing NVIDIA Web Drivers on HS requires a bit more attention. So remove all those Lilo NVWebdriverLibValFix NvidiaGraphicsFixup etc. Do not install anymore NVWebdriverLibValFix. Its built in latest NvidiaGraphicsFixup. It's recommended to move some drivers into EFI partition. So you have to make some clean up before installing NVIDIA Web Drivers. I recommend to uninstall old NVIDIA Web Drivers also before installing new ones.

Please read this post for more details: https://www.tonymacx86.com/threads/...er-on-high-sierra-black-screen-panics.234390/
Thanks for your reply.

Did you install HS with your video card installed in your computer or did you have to remove it?
I can't get into the install HS part. I get a hang up on start-up of installation......apple logo with a spinning wheel.
 
Joined
Sep 22, 2016
Messages
448
Motherboard
Z170X-UD5 TH-Clover
CPU
i7-6700K
Graphics
RX Vega 56
Mac
  1. Mac mini
Mobile Phone
  1. iOS
Did you install HS with your video card installed in your computer or did you have to remove it?
No, I did not remove it. Follow installation procedure. You have to use recovery procedure for first now if you got spinning wheel.
 
Top