[SUCCESS] mishaxz's Build: Core i7-3770 (not K!) - GA-H77-D3H - 16GB RAM - NVIDIA GT 640

Not open for further replies.
Sep 11, 2012
3770: MB=GA-H77-D3H 16GB RAM
GT640 (2xDVI, HDMI) 2GB Gigabyte
Classic Mac
Mobile Phone
[SUCCESS] mishaxz's Build: Core i7-3770 (not K!) - GA-H77-D3H - 16GB RAM - NVIDIA GT 640 - microATX

mishaxz's Build: Core i7-3770 (not K!) - GA-H77-D3H - 16GB RAM - NVIDIA GT 640 - microATX​

my definition of SUCCESS... works without any need for any bootloader flags... no -x, PCIRootUID or anything... and just about everything works... and actually quite easy install, once you know how to do it and what hardware to use!!

CASE Logic Concept Mercure ME03M(BK/BK)-500

not sure if you can get this in US... but it's just a case... main thing is the power supply is 500W... I wouldn't go less than 400 or 450.. but I'm no expert.

GIGABYTE GA-H77-D3H Motherboard

Intel Core i7-3770 3.4GHz/8MB (BX80637I73770) - not the K model.. maybe should have spent the extra $50 on K, who knows.. I don't play games

16GB RAM (Kingston DDR3-1600 16384MB PC3-12800 (Kit of 2x8192) HyperX (KHX1600C10D3B1K2/16G)

Optical drive Sony Optiarc SATA W / LS DVD-RW LightScribe AD-7261S-0B Black

Seagate Barracuda 7200.14 2TB 7200rpm 64MB ST2000DM001 3.5 SATA III - but soon I will make this a secondary drive and add SSD as the main drive

GIGABYTE GeForce GT-640 2GB RAM (GV-N640OC-2GI 1.0) (Dual DVI, HDMI, VGA)

DELL ULTRASHARP U2312HM Black (2 of them)


EDIMAX Edimax EB-MDC2 Bluetooth USB 2.1 Adapter

LOGITECH M705 Cordless Marathon Mouse

USB Keyboard - some ASUS.. doesn't matter.. I use only for BIOS because my bluetooth keyboards don't work with the BIOS

Genius Luxepad 9000 White Bluetooth Keyboard - wow, expensive! you can buy it cheaper at least $10 or $15 somewhere

Apple Wireless Keyboard (from 2008 or so... 3xAA Type) - not sold anymore.. but this 2xAA model looks just like it and I assume works like it too...

Logitech Speakers Z313


I had a very frustrating start... first using ASUS P8Z68-M PRO motherboard... then switched to this gigabyte one because I had assumed there were just too many problems with the ASUS.. I mean I had to boot up in -x and bunch of other flags... Also apparently it needed hacks to get HD4000 working, and I still couldn't get the HD4000 working - except in 1024x768 mode... when graphics drivers started to load then screen would power off always. But it didn't occur to me that HD4000 could be the problem, since it was supposed to work... only later when I installed Windows 7 and exact same thing happened... then I realized that yes, HD4000 doesn't always work - even on windows AND new Gigabyte motherboard!! There is some bug with CPU or something... quick google search confirmed it.

But anyhow, I liked this Gigabyte Motherboard better... no DSDT needed apparently... so what if it had no displayport, but the ASUS did... I had realized HD4000 just wasn't going to work... time for dedicated graphics...

so I tried Radeon HD5450 Silent Asus... well that didn't work either, even though I tried to follow instructions on internet for it... I decided I needed something that works Out of the Box!... easier said than done, I spent a long time searching and reading... then finally decided GT640 might work... at least for some people... on 10.8.2 and anyhow NVidia released drivers for some of it's cards... not sure that AMD does that, so even though in same price range Radeons are faster... I decided better to get a GT640 so I could have dual DVI + HDMI ports and better chance of easy install...

and guess what? It worked... plus 10cm fan is cool. Unibeast installer goes into OS X without any flags needed... I had some system freezes on first install but I think maybe I installed some kexts I shouldn't have... second install everything worked fine... QE/CI... OpenCL (I think it was OpenCL because CUDA not installed and some galaxy simulation demo I downloaded went into warp speed throughput when using the graphics card to help computation)

So I installed 10.8.2 from Unibeast... then I Installed a special kext for the network card (That I found from google search)... and multibeast I installed only:

  • UserDSDT or DSDT-Free Installation
  • VoodooHDA VT2021
  • maolj's AtherosL1cEthernet

I think I also checked GraphicsEnabler=no for good measure... not sure if that was necessary but I wanted to make sure I had native graphics support without any help from the bootloader chimera or chamelon, still confused what it's name actually is.

if you need some more help with certain things, check this helpful guide by user smi:

although I didn't follow everything there... like 4GB RAM.. I used all 16 at once... And Graphics Card I had plugged in (on HDMI to DVI Cable) since my integrated graphics are screwed up.

I used Multibeast 5.1.something (I think 5.1.2.. anyhow it doesn't matter the 5.0 version i think works too since I'm using very simple drivers, nothing new) and Unibeast Mountain Lion 1.5.3 I think (well 1.5.something.. )

Motherboard I had upgraded to latest BIOS version F9 before install. Need to unzip the .exe on Windows... use 7zip or something similar

Then I set BIOS like this before install...

and also changed it from IDE to AHCI.. and turned vt-d off for good measure, not sure if that's necessary... someone please write in comments if it is necessary.. or at least what I'm missing by having it off... I will be running VMs... Intel Virtualization Technology still enabled in bios, just vt-d disabled.

RAM for some reason running in 1333mhz mode according to About This Mac instead of 1600mhz for some strange reason.. I didn't bother to try and fix this yet... comments anybody? what settings I should change to get it to work and if it could cause instability/freezes changing this?

Hard disk because of 2TB gives strange boot errors so I fixed it with this


don't know what happens if you don't use them...

Gigabyte GT640 2GB Card (Nvidia GPU)

so, like I wrote... works great.. it seems. These things work:

  • QE/CI.. transparent menu bar, chess works, screensavers work, smooth fluid animation effects, etc.
  • OpenCL (I think, read about galaxy simulation software that I wrote about earlier... can google to find it if you want to test yourself.. I googled something like test OpenCL OS X or something)
  • Change Resolutions
  • Dual Monitors (I don't have third to test 3.. but my guess it will work)
  • Rotate Monitors
  • YouTube
  • AVI Movies

DVD Player seems to work now... Previously I wrote that it would crash (upon launch).. but now seems to work... don't know why now.. maybe from some software updates?

I didn't test CUDA (required 500mb install! and I don't need it AFAIK... but my guess it will work)

I'm very happy with this graphics card after my nightmare problems with buggy Intel HD4000 (even doesn't work on windows 7 HD4000) and Radeon HD 5450 card.


  • AUDIO Green Port Out
  • Bluetooth Keyboard.. (note: Apple Wireless Keyboard for some reason often not reconnecting after sleep and I must re-pair it.. have to look into what is going on)
  • Bluetooth Files Received from S3 phone
  • SpeedStep ( I think if I understand correctly, it works if you see different values... well i got 5 or 6 different numbers before i killed the terminal test program )
  • Sleep
  • Monitors Sleep
  • Wake
  • Shutdown
  • Restart
  • Wifi Single Band (I get about 130 Mbps - you can see yours by holding down option key when you click the wifi icon in the menubar)
  • USB 3.0 Flash Stick in USB 3.0 port
  • USB 3.0 Large File copy from WD USB 3.0 External HD... got these speeds!
  • AppStore


  • USB 2.0 Flash Stick in USB 3.0 Port (so probably any 2.0 device won't work in a 3.0 USB port)
  • WiFi DualBand 300Mbps
  • Apple Wireless Keyboard Brightness Keys


  • Hibernate (don't see why it won't work but I didn't test)
  • iMessage
  • iCloud
  • FaceTime


Apple Wireless Keyboard (3xAAA Battery 2008 type) works fine... I was using until now the Genius one... have to wait for connection sometimes upon waking... but this is probably normal. I just don't remember paying attention to it on my MBP...

neither of these bluetooth keyboards wake the computer.. but I didn't research this or look for setting... I just shake my logitech mouse.. since it is USB cordless not bluetooth, it wakes computer no problem. Ah, it seems in Bluetooth Preferences this "Allow Bluetooth Devices to wake computer is
COMPLETELY GREYED OUT"... so perhaps that's a problem with the Edimax adapter? don't know.

Screen Shot 2012-10-22 at 3.16.07 PM.png

Genius Bluetooth Keyboard quirks... connections sometime lost when I guess logging in or coming out of sleep mode of keyboard ... or maybe computer sleep mode... no big deal, it reconnects... but sometimes a few keystrokes lost while it does this... more worrying is that sometimes it will repeat keys like 3 or 4 'a' instead of one 'a'... but that's not happening often enough for it to be a deal-killer... for a cheap mac bluetooth keyboard, I think it's still ok... and typing on it I like.. not as much as the Apple but I like it... main problem no eject key... why do I need eject key? well there is a keyboard shortcut in OS X that includes the eject key in it to initiate sleep, I like that. multimedia keys work. It's small and compact for those people that like that... even more so than the apple.. they advertise it as an iOS keyboard.. but it works with macs too... There is CMD key.. no windows start key.


read above paragraphs about problem with bluetooth devices not waking computer...


ok, I love these monitors.. I'm a tall guy... 6'4" so it's great that these stands have some height in them (so they can rotate)... 3 ports... VGA, DVI, Displayport...

but there is one problem that on same brother model (the 24") apparently might not exist (google to be sure)... there is a strange texture visible on white especially... strange pattern... from the anti-glare overlay. It makes the white look a bit murkey... but I can live with it.

TPLINK TL-WN881ND - ok more than a quirk!! :(

it works, I mean it makes the card recognized and I can connect to networks... BUT it never reaches 300MBPs transmit rate like I get easily in Windows 7 with this card on this machine. At least it is not reported, I haven't been able to actually test speeds yet... but reported is maximum 130mbps under Transmit Rate (option click the wifi menubar icon to see your transmit rate)

So I guess I must try to get the 450MBPs TP-Link card that everyone says is compatible with OS out of the box...
TL-WDN4800 probably that will solve my problems...

a major quirk... doesn't bother me too much but could annoy other people. I can never find any other networks except my own wifi network... when I updated router firmware, I lost my network name... so the stock router wifi network name was displayed... but then I changed it back to my custom name and that was displayed.. but never once did I see any of the other 10 or so networks that my macbook pro picks up... even if I try to scan for them... nothing.... except my own... very strange behaviour... if anyone know why this occurs, please comment.. thanks.

Screen Shot 2012-10-22 at 2.39.04 PM.png

never see any other networks... strange...


Logitech Speakers are cheap and great for this price.. No bass control on remote thingy... but oh well, I'm sure there's a way to control that in OS X... but nice sound for computer speakers at that price.

Edimax bluetooth adapter is AS TINY AS POSSIBLE.

Case looks cool but the fan in front has blue light and i'm not sure you can turn the blue light off without turning the fan off. No big deal, but might bother some people.

This system is relatively quiet but not silent... but still way more silent than my Fall 2008 MacBook Pro with it's tiny high speed fans when it is busy with something.

I love this mouse... Logitech has a few great "luxury feeling" mice... I can't buy anything else... because it fits so well in hand and because of the amazing scroll wheel technology logitech has... slow click... fast smooth spinning, forget what it's called. batteries really maybe seem like they might according to battery indicator software - actually last a few years.

This software is useful "Display Rotation Menu"... for people who like to rotate monitor(s)
total cost: not cheap... But cheaper than apple!

and case is smaller (microATX) than Mac Pro... of course not Xeons but I don't need that. Seems to me that Apple needs something between a Mac Mini and a Mac Pro that is not an iMac... this is where that fits in for me.

I'd have to say... a couple days now running this System after it was built and no crashes :crazy: ... really stable. :thumbup: :headbang:


  • 2012-10-16 17.47.16.jpg
    2012-10-16 17.47.16.jpg
    282.2 KB · Views: 2,777
Spectacle also a great free program to help managing multiple monitors... move windows around and make them fill up left half or right half, and so on... of screen using keyboard shortcuts
I don't think you made a mistake getting the plain 3770 --- I got the 3770k more for psychological reasons than practical ones. Would I notice a drop in performance if someone sneaked in and swapped my 3770K for a 3770? Definitely not! Both chips are hellishly fast; like city dwelling greyhounds they spend most of their time wondering when they'll get to stretch their legs.

How on earth do you have such a tidy workspace? Are you in prison or do you somehow avoid owning any clutter?

Congratulations on your build, I'm jealous of those dell monitors. I bought a cheap 24" Samsung for my Hackintosh and next to my 27" iMac it looks like the crappiest monitor in the world. Milky and washed-out. Oh well
well, cables underneath ain't so tidy ) my office still needs some more furniture...

but a great thing to keep things tidy is that cpu box... the tray is great for holding all kinds of screws and other such thing and you can store usb flash drives or whatever underneath in the box.

monitors I specifically spent each about an extra $50 compared to the cheapest acceptable ones.. to get rotating ability and the higher stands.

still seems a bargain compared to when LCDs were quite new and I was buying many 15" ones for $500 and even a 19" Samsung for over a thousand.
SSD Installation

ok, well today I got my OCZ Agility 3 SATA 3 480GB SSD

what first surprised me was that 480GB is listed in Get Info as actually 480GB... I thought that maybe something specific to SSDs but then I tried it on my 2 TB drive and there was also no space loss there either. So seems in OS X formatted capacity is the same as actual unformatted capacity... which means maybe there's something I just don't understand since I don't see how no space can be lost in the formatting process... but that's not that important... just strange - to me.

So I installed it and it's working now - more or less...

here's what I did...

p.s. 2TB was the drive I was originally using for OS X... and that I cloned to the SSD.

1) Install SSD into Machine

self explanatory.. if you can't do this, forget about building a hackintosh :) I connected it to the SATA3 cable of course... not the normal SATA cable.

2) Install TRIM Patch using MultiBeast

Downloaded Multibeast... and installed the 10.8.1+ Trim Patch... I made sure to DISABLE the Trim 10.8 patch.. not sure if they would both load and such cause problems, or if the wrong one would overwrite the other.. so why not play it safe and only check the 10.8.1+ (since I'm on 10.8.2) ... reason I mention it is because if you click Trim selection, it will check both of them by default...

3) Move Excess files off the 2TB drive

Moved excess media files from the 2TB drive to a USB hd, so that the size of my 2TB used space would be less than the size of the 480GB SSD.

4) Clone 2TB drive to SSD

I Partitioned the SSD drive using Disk Utility first... then...

Used SuperDuper... I like the interface more than Carbon Copy Cloner. SuperDuper is free for this purpose. Process took about an hour for close to a million files (450GB or so), so I'd say it works fast enough :)

Screen Shot 2012-10-20 at 12.05.31 AM.png

5) Install Chimera using MultiBeast ON SSD

Downloaded Multibeast... again... ) and

6) Adjust BIOS Settings to Boot from SSD

Another tricky thing.. I suspect this might not apply to all motherboards, maybe only UEFI like my Gigabyte... what's the confusion here? well, my drives are all listed twice in the BIOS... Pn: drive name or UEFI: drive name... it won't boot for me if UEFI: option is used... use the Pn: drive name - at least for me... that was needed, to boot...

also I removed the 2TB drive from the boot order and made the SSD the first drive to boot (then CD, then USB)

7) Disk Speed Test (using **** SOFTWARE :oops: :banghead: )

Don't install Black Magic Disc Speed Test **** software... you might be tempted too... because it's in the app store and free... but DON'T.. or else you might bang your head like me at these awful rates it reports...

but turns out that's just because it uses a lot of incompressible data for it's tests and Sandforce and many other SSD controllers compress data... so use real benchmark software instead...

why is it ****? ok, there is no bug in the software... but it is misleading because they provide no warning or anything ( at least in any place I can see easily )... there are hints that this is for testing media files, obviously - if you look at the app display.... but for the uninitiated, it might never occur to us that media files would benchmark differently than other large files on SSD...

Screen Shot 2012-10-20 at 12.30.58 AM.jpg
8) Disk Speed Test (using REAL SOFTWARE! :thumbup: :headbang: )

Xbench is some great software...

I love the interface...

and more importantly, it gives normal benchmarking results!!...

My SSD Drive

Screen Shot 2012-10-20 at 3.23.55 AM.png

My 2TB 7200 RPM Drive

Screen Shot 2012-10-20 at 3.23.59 AM.png


google searches solve your problems usually... I had to do a lot of those at almost every step of the way...

but now it works. I think... only time will tell if it freezes again or not... until I installed the SSD, I never had a mouse cursor freeze (for legitimate reasons... I did have some when I turned off a monitor that I had my mouse plugged into.. but that's just stupidity on my part)

Anyhow, even though I had a fast system before the SSD... definitely much faster... there were still things that took a while, like to open system preferences when OS X was installed on the 2TB drive.. now System Preferences opens instantly. Windows 7 VM in Fusion opens much faster and suspends much faster...

Initial Stability BUG...

This is not really so bad... just strange... my SSD doesn't cause any system stability problems EXCEPT if i try to load my windows 7 VM - Fusion - immediately after starting computer and logging in...

It will freeze the system....

but if I wait just a little, then there is no problem launching the VM or doing anything else...

this is the only stability issue I noticed in last few days.

So it is not even really an annoyance since this is easy behaviour to avoid...
great setup you got there, I've got the same Mobo and I'm in between F5 bios I dumped when I got it and the F11 one that gigabyte gives lately, is it possible to dump me the F9 on media fire or elsewhere cause 2 days have passed and still I'm om KP's and only with winz.. :-/

if not the original post starter, at least on of you with h77-d3h (not the m or other model)

thank you in advance
sorry, I don't have it - but maybe ask on thread of other users of this mb on this site
sorry, I don't have it - but maybe ask on thread of other users of this mb on this site

maybe you could dump it?

save to file from inside uefi bios or if you got windows installed by using @bios save to file feature, it'll be great!

ive already searched the web, and didn't get results about it, only dead links to it that lead to the ga site that gives F11 which gives me kp's :(
well, you got the h77"m"-d3h model from the firmware page you quoted above.. could you fix the title and description for future reference, for example user above that asks for a dump thinks you have the plain one, that doesn't have an F9 bios you quote above but F11..

anyways just to be noted! ;) thank you for a great guide!
Not open for further replies.