Contribute
Register

[SUCCESS] Lion working 100% with CustoMac Mini 2011 Build

Status
Not open for further replies.
Joined
Nov 22, 2011
Messages
46
Motherboard
Customac Mini 2011
CPU
Core I3
Graphics
Geforce 9600 gt
Mac
Classic Mac
Mobile Phone
I installed the Kext from this thread. Is there anyway to recover the original Kext? This will only fix the CMOS resets, it wont make auto sleep work, correct?
 
Joined
Jul 1, 2011
Messages
31
Motherboard
GA-965P-DS3
CPU
E2160 @ 3.06Ghz
Graphics
HD 5450
Mac
Classic Mac
Mobile Phone
I too have successfully installed ML on an customac mini 2011, what a pleasant little machine!
 
Joined
Oct 20, 2010
Messages
200
Motherboard
GA-Z370M D3H v1.0 Bios F13
CPU
i5-9600K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
  3. Other
I installed the Kext from this thread. Is there anyway to recover the original Kext? This will only fix the CMOS resets, it wont make auto sleep work, correct?

Well best practice to backup all kexts you change :), but if you need i can upload original one form my macbook pro.

yes this patch prevent cmos reset and make manual sleep work. Auto sleep its different thing, my experience tell me there are 2 main things that prevent auto sleep.
1- DVD/CD Drives - Few models are 100% compatible with mac osx. You need one 100% compatible to have auto sleep (expl sony)... or just remove yours to test if its your drive problem:)
2 - almost every onboard ethernet cards fail on auto sleep - I use intel ethernet pci cards in all my hackintosh, auto sleep working on all.
 
Joined
Nov 22, 2011
Messages
46
Motherboard
Customac Mini 2011
CPU
Core I3
Graphics
Geforce 9600 gt
Mac
Classic Mac
Mobile Phone
Thanks for your help.

If possible could you update the original file so I can run the commands over it. I trust this method. In response to the CD drive, ive never had an issue with it in any version I have run, Sony Optiarc, it must be my Ethernet Driver. Im using the lnx2mac version. Maybe I switch over to the original and see how it does.
 
Joined
Oct 20, 2010
Messages
200
Motherboard
GA-Z370M D3H v1.0 Bios F13
CPU
i5-9600K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
  3. Other
Thanks for your help.

If possible could you update the original file so I can run the commands over it. I trust this method. In response to the CD drive, ive never had an issue with it in any version I have run, Sony Optiarc, it must be my Ethernet Driver. Im using the lnx2mac version. Maybe I switch over to the original and see how it does.

sure
 

Attachments

  • AppleRTC.kext.zip
    28 KB · Views: 85
Joined
Jun 26, 2012
Messages
134
Motherboard
10.8.3
CPU
Intel Core i5 2500k
Graphics
Asus GTX 550ti
Mac
Classic Mac
Mobile Phone
  1. Android
Did you update from Lion, or did you do a fresh install of Mountain Lion? I am working on My Customac mini, and your graphics are working 100% with the HD 3000?
 
Joined
Apr 24, 2010
Messages
2
Motherboard
Customac H67N-USB3
CPU
Intel Core i3-2105
Graphics
Onboard
Mac
Classic Mac
Mobile Phone
I have the H67N customac build and the installer KPs if I leave any USB devices (other than the install device) plugged in.

If I unplug the keyboard after selecting the boot device, I can get to the installation screen. If I plug in any USB devices at the install screen, it KPs.

Anyone have any ideas?

Lion works fine.

Troubleshooting
- reset the CMOS
- reset the BIOS to Optimized
- updated to F9 BIOS (from F7)
- unplugged everything (including internal USB and audio headers)
- rebuilt the USB installer from the Mac App store ML installer w/ Unibeast 1.5.1 (the app says 1.5 though)
 
Joined
Nov 22, 2011
Messages
46
Motherboard
Customac Mini 2011
CPU
Core I3
Graphics
Geforce 9600 gt
Mac
Classic Mac
Mobile Phone
freituk: Do you have a modified file? I don't think I'm entering the command correctly, because it doesn't seem to be working. However by using the realtek original driver apple driver, my hack will auto sleep, its just the resume from sleep im having issues with.
 
Joined
Oct 20, 2010
Messages
200
Motherboard
GA-Z370M D3H v1.0 Bios F13
CPU
i5-9600K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
  3. Other
freituk: Do you have a modified file? I don't think I'm entering the command correctly, because it doesn't seem to be working. However by using the realtek original driver apple driver, my hack will auto sleep, its just the resume from sleep im having issues with.
i m going upload my modified file, i think there is no difference between machines.
dont forget to rebuild cache, i use the program kext wizard.
 

Attachments

  • AppleRTC.kext.zip
    28 KB · Views: 86
Joined
Apr 21, 2012
Messages
11
Mac
Classic Mac
Mobile Phone
I got ML installed on my Mini last night. Upgraded from fully working 10.7.4. Used Multibeast 4.6.1 and Chimera 1.11.
System:
i3 2105, GA-H61N-USB3-B3 (F8 BIOS and F8 DSDT from the customac mini thread), HD 3000

Everything is working except my usb3 ports... I've installed the following to try and resolve that:
2870-DP3 kexts:
IOUSBFamily.kext
IOUSBMassStorageClass.kext

2870-PXHCDv1.0.8 kext *PXHCD.kext

Multibeast USB3 option thing...

Any ideas?
------------------------------------

Some notes from my install:
The patched AppleHDA.kext files in Multibeast don't work for me. Not sure why. Manually importing the beta 889 Patched AppleHDA.kext with Kextbeast works no problems.
AppleIntelCPUPowerManagement.kext will cause KP if your cpu is underclocked. I'm using the 10.8 patched I found in some thread here.
I'm using the AppleRTC.kext posted in this thread.
 
Status
Not open for further replies.
Top