Contribute
Register

[SUCCESS] Asus ROG Strix Z270F + i7-7700k + R9 280x

Joined
Sep 10, 2011
Messages
26
Motherboard
Asus ROG Strix Z270F
CPU
Intel i7-7700k @ 5Ghz
Graphics
AMD Radeon R9 280x
Mac
MacBook Pro
Mobile Phone
iOS
Specs
Motherboard

Asus ROG Strix Z270F

CPU

Intel i7-7700k @ 5GHz

GPU

MSI Radeon R9 280x

Memory

32GB Crucial Ballistix 2400MHz

Storage

1 x Samsung 960 EVO 500GB
2 x Samsung 850 EVO 250GB
2 x Toshiba P300 2TB

OS

macOS Sierra 10.12.3

Problems/solutions
Motherboard

Everything works out of the box except for the network card. I tried the IntelMausiEthernet.kext, but could not get it to work. Ended up using the patched AppleIntelE1000e.kext instead. Added to /L/E. I have not tried the onboard audio, as I'm using an external card, but I do believe it is working as it should.

CPU
Had to use FakeCPUID in Clover (config.plist), as described in the Kaby Lake thread here: https://www.tonymacx86.com/threads/...cpus-200-series-motherboards-in-macos.211743/

GPU
Working out of the box.

Memory
Working out of the box.

Storage
My boot volume is on the Samsung 960 EVO M.2 NVMe SSD. I had to use both the Clover patch from PikeRAlpha and the patching script by RehabMan.
https://pikeralpha.wordpress.com/2016/06/27/nvmefamily-kext-bin-patch-data/
https://github.com/RehabMan/patch-nvme

The two Samsung 850 EVO SSDs and the two Toshiba P300 HDDs are setup in a Fusion + Raid 0 configuration. https://rossfisher.me/2016/01/how-t...os-x-10-11-el-capitan-genuine-and-hackintosh/

Other
Shutdown does not work yet. The computer reboots instead of shutting down. I'm still looking into this. I've tried the "FixShutdown" feature in Clover, without success. Suggestions are very welcome.

And that is pretty much it. Everything works great, benchmarks are available in appropriate threads
https://www.tonymacx86.com/threads/post-macos-os-x-geekbench-benchmarks.146690/page-42#post-1451638
https://www.tonymacx86.com/threads/...aphics-benchmarks.147037/page-25#post-1451670
 
Last edited:
Joined
Oct 2, 2015
Messages
18
Motherboard
Asrock Fatal1ty Z270 Gaming-ITX/ac
CPU
i5-7500
Graphics
HD 630
Mac
MacBook Pro
Mobile Phone
iOS
No fix for shutdown yet?
 
Joined
Apr 15, 2016
Messages
8
Motherboard
Gigabyte GA-Z270M-D3H
CPU
I5-6500K
Graphics
NVIDIA 960 GTX
Mac
MacBook Pro
Classic Mac
128K
Mobile Phone
Android, iOS
Hi,

Do you have a guide on who you installed Sierra on your motherboard

Thanks.
 
Joined
Apr 13, 2017
Messages
19
Motherboard
z270x gaming 5
CPU
i7 7700k
Graphics
Aorus GTX 1080 ti
I have been preparing to build my first hackintosh on a similar rig Z270F + i7 7700k but with GTX 1080 ti (new drivers available) . I do want to have a dual boot with win10 on one SSD (purely for 4k gaming) and iOS on the other for everything else. As far as I am concerned there is no Wifi + bluetooth card built in so which card did you use and is it working fine? Also which external audio card are you using and did you check the onboard one??
 
Joined
Apr 2, 2017
Messages
14
Motherboard
Asus ROG Strix Z270F
CPU
Core i7-7700K @4.9GHz
Graphics
Sapphire Rx Vega 64@Eiswolf Xp Pro 240mm
Mac
MacBook Pro
Mobile Phone
iOS
I happen to have also Z270F + i7 7700k@4.8GHz +980 ti working with dual boot but via bios and OS's are on separate Nvme ssd's and have to be selected from bios boot, not the same but works well enough.
I have no wifi card as motherboard ethernet works well enough. Also onboard audio works using IntelMausiEthernet.kext. For bluetooth I have Asus BT-400 dongle.

I used these two threads to get everything working: thread1 and thread2. Good luck with your build.

Still wondering if MSI Radeon R9 280x would be better than 980 ti for FCPX. Probably have to try that at some point.
 
Joined
Apr 2, 2017
Messages
14
Motherboard
Asus ROG Strix Z270F
CPU
Core i7-7700K @4.9GHz
Graphics
Sapphire Rx Vega 64@Eiswolf Xp Pro 240mm
Mac
MacBook Pro
Mobile Phone
iOS
At least on my build audio works from all Gpu HDMI and Displayports as well as from motherboard Spdif-out(orange rear) port. If you ment headphones(greent front) or line out( green rear) they are visible also as audio options in mac OS but I cannot try them as I don't have headphones or cable to connect to those ports.
 
Joined
Apr 2, 2017
Messages
14
Motherboard
Asus ROG Strix Z270F
CPU
Core i7-7700K @4.9GHz
Graphics
Sapphire Rx Vega 64@Eiswolf Xp Pro 240mm
Mac
MacBook Pro
Mobile Phone
iOS
Found luckily headphones and plugged them to case and selected green front out from mac OS as output and they worked as well so microphone in case and line out along other 3.5mm plugs on the back of the motherboard are the only ports I have not tried on my build.
 
Joined
May 31, 2010
Messages
35
Motherboard
Gigabyte Aorus Gaming 7 Z370
CPU
i7 8700K
Graphics
Palit Geforce GTX 1080 Ti
Found luckily headphones and plugged them to case and selected green front out from mac OS as output and they worked as well so microphone in case and line out along other 3.5mm plugs on the back of the motherboard are the only ports I have not tried on my build.
Kukkis, could you share your EFI folder please?
 
Top