Contribute
Register

[Success] ASUS Prime Z370-A+i9-9900k Pro Audio Build

NorthAmTransAm

Moderator
Joined
Jul 26, 2018
Messages
1,949
Motherboard
MSI Pro Z690-A DDR4
CPU
i7-12700k
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
Wow - so I'm realizing that when I saw that Vault was still set to Secure - I was actually looking at the EFI on my 1:1 external backup disk. And EFI on my backup I don't even recognize, it's a really scaled down version. I'll have to get to the bottom of this. Probably should have disconnected the external backup disk entirely before doing this.

EDIT: Well, booted up this morning and it froze again. So we're back to square one...

EDIT 2: Going to disconnect my external and see if I get any hangs. Also should note I have Windows installed on a separate internal SATA SSD.

EDIT 3: Haha, nice try. We're still hanging within a few minutes.
Lets try disabling the Catalina(Sata) kext and ASMEDIA.kext.
 

NorthAmTransAm

Moderator
Joined
Jul 26, 2018
Messages
1,949
Motherboard
MSI Pro Z690-A DDR4
CPU
i7-12700k
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
Lets try disabling the Catalina(Sata) kext and ASMEDIA.kext.
Also worth trying, disable SATA in BIOS and see if it still locks up. I had two issues towards the end: BIOS and the USB3 Driver but they were resolved.
 
Joined
Apr 2, 2020
Messages
61
Motherboard
Asus Prime Z370 A-II
CPU
i5-9400F
Graphics
RX 570
Also worth trying, disable SATA in BIOS and see if it still locks up. I had two issues towards the end: BIOS and the USB3 Driver but they were resolved.
How do I boot if I disable SATA?

Still locking with Catalina and AsMedia disabled.
 

NorthAmTransAm

Moderator
Joined
Jul 26, 2018
Messages
1,949
Motherboard
MSI Pro Z690-A DDR4
CPU
i7-12700k
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
How do I boot if I disable SATA?

Still locking with Catalina and AsMedia disabled.
Oh I see, I assumed you were on an NVMe Drive. Are you using Thunderbolt by chance?
 

NorthAmTransAm

Moderator
Joined
Jul 26, 2018
Messages
1,949
Motherboard
MSI Pro Z690-A DDR4
CPU
i7-12700k
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
Can you debug and send the report?
 
Joined
Apr 2, 2020
Messages
61
Motherboard
Asus Prime Z370 A-II
CPU
i5-9400F
Graphics
RX 570
First see if 085 works in Monterey. I don’t have this machine so I can’t test.

I'm unable to install Monterey, it "installs" then reboots right back into Big Sur.

I'm very close to sunsetting this Hack and walking away. Too many hours and I can't find a single person who has a similar build and is keeping their machine updated. Just for kicks I tried using the just-released version of OC today and built an EFI from scratch. Still hanging after a few minutes.

EDIT: Loaded Optimized defaults and followed @tech1eguy 's BIOS settings. Some virtualization technology setting was changed and now we're 20 minutes in without a hang. I wish I wrote down what it was exactly.
 

Attachments

  • opencore-2022-11-12-205926.txt
    256 KB · Views: 5
  • EFI.zip
    4 MB · Views: 10
Last edited:
Top