Contribute
Register

[Success] ASUS Prime Z370-A+i9-9900k Pro Audio Build

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
20,475
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
One moment, sorting out why OpenCore Configurator won't allow drag and drop in Ventura. @CaseySJ have you encountered this?
I always use copy-and-paste. Are you dragging a file or dragging one or more individual fields?

Also, what "OCC errors" did you encounter? Drag-and-drop is not an error! ;)
 
Last edited:

Feartech

Moderator
Joined
Aug 3, 2013
Messages
29,010
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
@Feartech I used OCC as a plist editor to correct some OCC errors, how about that? Also, I made a RAM Disk to work off of because OCC only allows removable drives to have access? Probably a misunderstanding on my part.

@ryanbach51 give this a go. There has no thunderbolt additions and Apple VTD is disabled, just fyi.
That's funny... using software that caused a bug to fix a bug :)
 

NorthAmTransAm

Moderator
Joined
Jul 26, 2018
Messages
1,949
Motherboard
MSI Pro Z690-A DDR4
CPU
i7-12700k
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
I always use copy-and-paste. Are you dragging a file or dragging one or more individual fields?

Also, what "OCC errors" did you encounter? Drag-and-drop is not an error! ;)
Ha, I suffer from failure-to-elaborate. It's hereditary. It's a permissions thing where it doesn't have access to files on the desktop and I cant seem to give it to the app. It defaults to allowing access to removable drives however. Copy and Paste eluded me for some reason, doh!

To be clear I tried dragging single files and multiple. I ended up creating a RAM Disk to mimic a removable drive but I could have copy and pasted.

That's funny... using software that caused a bug to fix a bug :)
I like their plist editor lots! Sometimes they're slow on the update to get the schema right. I wish Dortania took over it.
 
Joined
Apr 2, 2020
Messages
61
Motherboard
Asus Prime Z370 A-II
CPU
i5-9400F
Graphics
RX 570
@Feartech I used OCC as a plist editor to correct some OCC errors, how about that? Also, I made a RAM Disk to work off of because OCC only allows removable drives to have access? Probably a misunderstanding on my part.

@ryanbach51 give this a go. There has no thunderbolt additions and Apple VTD is disabled, just fyi.

OC: Configuration requires vault, but no vault provided!

Vault is correctly set to Optional on your EFI so I don't know why I'm getting this error.
 

NorthAmTransAm

Moderator
Joined
Jul 26, 2018
Messages
1,949
Motherboard
MSI Pro Z690-A DDR4
CPU
i7-12700k
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
OC: Configuration requires vault, but no vault provided!

Vault is correctly set to Optional on your EFI so I don't know why I'm getting this error.

Before I go digging too far, did you clear NVRAM after changing Vault to Optional?

Also, please enable AuthRestart and AllowSetDefault on that same tab (Misc/Security).
 
Joined
Apr 2, 2020
Messages
61
Motherboard
Asus Prime Z370 A-II
CPU
i5-9400F
Graphics
RX 570
Before I go digging too far, did you clear NVRAM after changing Vault to Optional?

Also, please enable AuthRestart and AllowSetDefault on that same tab (Misc/Security).
Yes, have enabled both and reset the NVRAM a few times, same error.
 

NorthAmTransAm

Moderator
Joined
Jul 26, 2018
Messages
1,949
Motherboard
MSI Pro Z690-A DDR4
CPU
i7-12700k
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
Yes, have enabled both and reset the NVRAM a few times, same error.
It's a conflicting setting and I'm trying to remember which quirk it is. Can you enable SetupVirtualMap in the meantime?

@CaseySJ I remember coming across this once. Anything ring a bell?
 
Last edited:
Joined
Apr 2, 2020
Messages
61
Motherboard
Asus Prime Z370 A-II
CPU
i5-9400F
Graphics
RX 570
It's a conflicting setting and I'm trying to remember which quirk it is. Can you enable SetupVirtualMap in the meantime?

@CaseySJ I remember coming across this once. Anything ring a bell?

Ok I have it booted. I swear I had that SOB set to Optional but when I went back to change SetupVirtualMap "Secure" was staring me in the face. We're about 5 minutes in and no hangs yet. Will report back tomorrow.
 

NorthAmTransAm

Moderator
Joined
Jul 26, 2018
Messages
1,949
Motherboard
MSI Pro Z690-A DDR4
CPU
i7-12700k
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
Ok I have it booted. I swear I had that SOB set to Optional but when I went back to change SetupVirtualMap "Secure" was staring me in the face. We're about 5 minutes in and no hangs yet. Will report back tomorrow.
Sweet, I miss this build.
 
Joined
Apr 2, 2020
Messages
61
Motherboard
Asus Prime Z370 A-II
CPU
i5-9400F
Graphics
RX 570
Sweet, I miss this build.

Wow - so I'm realizing that when I saw that Vault was still set to Secure - I was actually looking at the EFI on my 1:1 external backup disk. And EFI on my backup I don't even recognize, it's a really scaled down version. I'll have to get to the bottom of this. Probably should have disconnected the external backup disk entirely before doing this.

EDIT: Well, booted up this morning and it froze again. So we're back to square one...

EDIT 2: Going to disconnect my external and see if I get any hangs. Also should note I have Windows installed on a separate internal SATA SSD.

EDIT 3: Haha, nice try. We're still hanging within a few minutes.
 
Last edited:
Top