Contribute
Register

[Success] ASUS Prime Z370-A+i9-9900k Pro Audio Build

NorthAmTransAm

Moderator
Joined
Jul 26, 2018
Messages
1,226
Motherboard
Asus Z370-A Prime II
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
@NorthAmTransAm

I will try to unplug the power supply for 15 seconds.
at this time i have disabled ssdt and rename.
my initial goal is to see it at least in PCI LIST and not in ioreg.
If it appears in the PCI LIST then it activates quietly

I believe the only way to get this card to show up without the SSDT and Patches is to do the procedure and to boot with a Thunderbolt Device on. Otherwise it is very likely the card will not be seen at all.

If I were you, I'd enable the SSDT and Patches first and follow the procedure.
 
Joined
Mar 22, 2019
Messages
24
Motherboard
Gigabyte Z370m D3H
CPU
I7 8700
Graphics
Gtx 1050 ti
@NorthAmTransAm WOOOOOOORK!!!!!!!!
but my question now is:
Does this step of the power supply have to be done every time?
 

NorthAmTransAm

Moderator
Joined
Jul 26, 2018
Messages
1,226
Motherboard
Asus Z370-A Prime II
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
@NorthAmTransAm WOOOOOOORK!!!!!!!!
but my question now is:
Does this step of the power supply have to be done every time?
NOPE! So long as there was a proper shutdown. If not then it's likely you'll need to repeat this procedure.

Note 1: You don't need to have a device on at boot, assuming the last shut down was fine.

Note 2: This is actually Thunderbolt Extended Mode which is the absolute goal of having Thunderbolt on Hackintosh. For more info please read here (note that we don't need to flash our card because Alpine Ridge works with simple patches).
 
Last edited:
Joined
Mar 22, 2019
Messages
24
Motherboard
Gigabyte Z370m D3H
CPU
I7 8700
Graphics
Gtx 1050 ti
@northbabyboy after reboot the pcie TB is ON! But the Apollo Twin X not is detected.
I use Mojave, i try to install the drivers and after reboot not detected :(
 
Joined
Mar 22, 2019
Messages
24
Motherboard
Gigabyte Z370m D3H
CPU
I7 8700
Graphics
Gtx 1050 ti
I use SMBIOS MacPro 1,1.
 

NorthAmTransAm

Moderator
Joined
Jul 26, 2018
Messages
1,226
Motherboard
Asus Z370-A Prime II
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I use SMBIOS MacPro 1,1.
Can you please open IOReg and go to File>Save As and send me a copy?

Was there a specific reason you switched SMBIOS? I'd try signing out of iCloud and going back to 19,1.
 
Joined
Mar 22, 2019
Messages
24
Motherboard
Gigabyte Z370m D3H
CPU
I7 8700
Graphics
Gtx 1050 ti
now repeating the procedure to unplug the power cord has been recognized.
it works I just have to understand if it remains stable! I am attaching EFI and ioreg
@NorthAmTransAm
but at each shutdown the card is not recognized and I have to repeat the procedure with the power supply cable
 

Attachments

  • Archivio (16).zip
    32.5 MB · Views: 13
Top