Contribute
Register

[SOLVED] Unclean shutdown/restart, possibly due to com.apple.driver.AppleIntelSKLGraphicsFramebuffer

Joined
Sep 15, 2018
Messages
3
Motherboard
Dell Optiplex 7040 SFF Motherboard
CPU
i5-6500
Graphics
HD 530
I'm running OS X 10.13.6. Graphics seem to be accelerating alright, just have an issue with unclean shutdowns/restarts. It seems like there's a kernel panic on either shutdown/restart or on boot, I'm not able to tell when it happens.

Whenever I boot with EFI (regular non-EFI boot doesn't have this problem), I get an error "You shut down your computer because of a problem." Attached is the full report, but the most interesting part leading me to think it's a graphics issue is below:

Kernel Extensions in backtrace:
com.apple.driver.AppleIntelSKLGraphicsFramebuffer(10.3.6)[F09DEB66-D769-37DA-B03C-F662B2F9FE80]@0xffffff7f887e1000->0xffffff7f889b5fff
One curious thing is that the report has the same "System uptime in nanoseconds" every report, but the timestamp gets reported. I'm not sure why, but attempted to clear nvram to see if that was some kinda report stuck in NVRAM, but it comes back every time with a new timestamp.

There's also a separate EFI issue, where I can't use EFI-only boot mode, I have to be in "legacy" boot mode with option EFI, then from the boot menu select the EFI boot loader.

Not sure where else to go from here, though I have attempted to modify my DVMT through an EFI shell (0x350 : 0x1 to 0x3). That didn't affect the KPs.
 

Attachments

Joined
Sep 15, 2018
Messages
3
Motherboard
Dell Optiplex 7040 SFF Motherboard
CPU
i5-6500
Graphics
HD 530
UPDATE: Well, spending all night, and less than an hour after posting it looks tentatively fixed.

The only change from the above CLOVER.ZIP was that I updated from OsxAptioFix2Drv.efi to OsxAptioFix3Drv.efi. Kernel Panics on start are gone, and I'm able to save to NVRAM and have it work across boots.

Now it's time to work on iMessage...

EDIT: iMessage works good as well
 
Last edited:
Joined
Sep 28, 2018
Messages
10
Motherboard
ASUS PRIME H370-A
CPU
i7-8700
Graphics
RX 570
Mac
iMac, MacBook Pro, Mac Pro
Mobile Phone
iOS
The only change from the above CLOVER.ZIP was that I updated from OsxAptioFix2Drv.efi to OsxAptioFix3Drv.efi.
Something like this worked for me too, while my system wasn't able to install MacOs Mojave (freezes at first restart / 2 min).
For my Hardware: I used "OsxAptioFixDrv-64.efi" in the "Drivers64UEFI"-folder (not v2, v3 or old AptioMemoryFix) and it's working great for now.
 
Top