Contribute
Register

[Solved] Unable to get QE/CI (hardware acceleration) working on Lenovo Yoga 920 (OpenCore 6.3)

Joined
Nov 28, 2015
Messages
147
Motherboard
Lenovo Yoga 920 - OpenCore
CPU
i7-8550U
Graphics
HD620, 3840x2160
As the title suggests, I am unable to get the GPU detected in Big Sur 11.1. I have tried basically every combination of APPL,ig-platform-id and device-id configurations listed in:


As well as some in the Coffee Lake guide, but this is a Kaby Lake R system.

Please note, the current values I took from this same laptop running Catalina fine with full QE/CI. I'm not sure WHY it's not working in Big Sur.

Here's what I see in Catalina with working QE/CI:

Screen Shot 2020-12-20 at 8.26.05 PM.png


Here's what I see in Big Sur:
Screen Shot 2020-12-20 at 8.37.58 PM.png

Screen Shot 2020-12-20 at 8.41.33 PM.png


Thanks for any help.
 

Attachments

  • EFI.zip
    25.5 MB · Views: 56
Last edited:
Joined
Mar 22, 2020
Messages
20
Motherboard
Yoga 920-13IKB
CPU
i7-8550u
Graphics
UHD620
I think you'll need to setup your SMBIOS... MacbookPro15,2 on the yoga920 (here)
btw, is the linked guide the one you used on the 920?
I wasn't able to boot wen I tried it a month or so ago... Any tips/comments?

I'll jump with you on this machine soon,
 
Joined
Nov 28, 2015
Messages
147
Motherboard
Lenovo Yoga 920 - OpenCore
CPU
i7-8550U
Graphics
HD620, 3840x2160
I think you'll need to setup your SMBIOS... MacbookPro15,2 on the yoga920 (here)
btw, is the linked guide the one you used on the 920?
I wasn't able to boot wen I tried it a month or so ago... Any tips/comments?

I'll jump with you on this machine soon,
Thanks. I already did, but I believe I had a kernel parameter that may have been interfering here.

I have been able to get the appropriate SMBIOS to load now. Still unable to get hardware acceleration working though.
Screen Shot 2020-12-20 at 10.03.26 PM.png

Screen Shot 2020-12-20 at 10.03.32 PM.png
 

Attachments

  • EFI.zip
    6.9 MB · Views: 21
Joined
Nov 28, 2015
Messages
147
Motherboard
Lenovo Yoga 920 - OpenCore
CPU
i7-8550U
Graphics
HD620, 3840x2160
To answer your question, yes--mostly. I had to play around with the SSDTs. I haven't had luck booting with SSDT-AWAC/RTC0, as described in the Coffee Lake guide. Looking at the SSDT platform chart is a bit confusing as our laptops technically, perhaps, fall more under the Kaby Lake platform than Coffee Lake? I'm not entirely sure, but it seems the Kaby Lake guide applies more to this system.

I will look into my SSDTs again, as I'm sure SSDT-XOSI is configured wrong as well.
 
Joined
Nov 28, 2015
Messages
147
Motherboard
Lenovo Yoga 920 - OpenCore
CPU
i7-8550U
Graphics
HD620, 3840x2160
How can I mark this solved?

I realized that I needed a few patches for my screen--seeing as it is 4K. Also I used:

APPL,ig-platform-id 00001B59

device-id 12590000

I found these in this guide:

Here's my EFI for anyone else who wants it.
 

Attachments

  • EFI.zip
    6.9 MB · Views: 60
Top