Contribute
Register

[solved] HP Probook 450-G4-i7 / intel620 - No HDMI or VGA Output, or HDMI reboot

Joined
Sep 23, 2011
Messages
58
Motherboard
HP Probook 450 G4 (C/UEFI)
CPU
i7-7500U
Graphics
HD 620
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. Android
[SOLVED]
:headbang::headbang::headbang:

The problem was:

- SMBIOS misconfigured. Changed to MacBookPro14,1
- Rehabman Patches for Native Kaby Lake vs. SkyLake spoofing
- And to fix HDMI reset, there are several disabled patches regarding HDMI that I had to enable.

Additionally,

- Set CLOVER Resolution to 1920x1080 to avoid apple logo stretch at boot
- Set Console font to avoid garbled verbose mode

Please find attached my config.plist. with the final changes.
 

Attachments

  • config.plist
    43.4 KB · Views: 144
Last edited:
Joined
Sep 23, 2011
Messages
58
Motherboard
HP Probook 450 G4 (C/UEFI)
CPU
i7-7500U
Graphics
HD 620
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. Android
... deleted, problem solved ...
 
Last edited:
Joined
Sep 23, 2011
Messages
58
Motherboard
HP Probook 450 G4 (C/UEFI)
CPU
i7-7500U
Graphics
HD 620
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. Android
My SMBIOS was at MacBookPro11,1, that AFAIK seems a totally unfortunate choice, because architecture and graphics do not match.

I changed SMBIOS to MacBookPro14,3 and things have apparently improved (although I still have to confirm, because the flickering is not immediate but after an indeterminate period of use)

I have some questions:

1) With the new setting, the VGA port and the HDMI port don't work anymore

HDMI was untested with previous config, but VGA did work.

I-ve seen there's a couple binary patches to the Intel Gfx driver that look related to this, if I disable one about HDMI port 7 and another about replacing somethinf for the family 591B0000, the computer resets if I plug a HDMI monitor.

Also have changed ig_platform_id to the following values:

591E0000 59610000 59230000 59260000 591b0000

... but apparently nothing changes, and the string displayed in äbout this mac" is always the same (don't know if it should be)

UPDATE: My config was very messy, solved applying correct patches for KabyLake + smbios + hdmi

2) Is MacBookPro14,3 the ideal choice for this laptop?

Laptop has I7/7500U that is KabyLake/U, 2 cores and IntelHD 620 gfx

- MBP11,1: I7/4558U Haswell/Iris5200
- MBP11,2: I7/4750HQ Haswell/Iris5200
- MBP11,3: I7/4870HQ Haswell/Iris5200/QuadCore
- MBP11,4: I7/4770HQ Crystal Well/???/QuadCore
- MBP11,5: I7/4870HQ Haswell/QuadCore/Iris5200
- MBP13,3: I7/6920HQ SkyLake/QuadCore/HD530
- MBP14,1: I5/7360U KabyLake-U/QuadCore/IntelIrisPlus 640
- MBP14,2: I5/7267U KabyLake-U/QuadCore/IntelIrisPlus 650
- MBP14,3: I7/7700HQ KabyLake-H/QuadCore/IntelHD 630


Other people use MBP14,1 (i5) for laptops equipped with this processor. So what is better, to match the CPU main type (i5/i7), or the sub-architecture (KabyLake/U vs KabyLake/H) .

UPDATE: MBP14,1 works perfect for this laptop.




Thanks in advance to everybody for their time.
 
Last edited:
Joined
Sep 23, 2011
Messages
58
Motherboard
HP Probook 450 G4 (C/UEFI)
CPU
i7-7500U
Graphics
HD 620
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. Android
IntelGraphicsFixup is already included in WhateverGreen, you should remove it.
in config.plist i think you should inject intel, and set ig-platform-id to 0x591b0000
A similar laptop with i7 hd620:
https://www.tonymacx86.com/threads/asus-ux430ua-kaby-lake-i7-7500u-intel-hd-graphics-620.225847/

Hey thanks for your suggestions!, I tried a bunch of platform ids for Intel Kaby Lake and 6XX I found linked from those articles, but apparently nothing changes, The only thing that affects the behaviour is disabling binary patches to the GFX driver about HDMI, then the computer restarts if I plug a cable. The VGA port is always dead :(
 
Top