Contribute
Register

[solved] DELL Inspiron 7560 HDMI issue

Status
Not open for further replies.
Joined
May 13, 2011
Messages
543
Motherboard
DELL Inspiron 7560-1.3.0-CLOVER
CPU
i7 7500U
Graphics
HD 620 / GTX 940MX, 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Brightness keys are covered in the main brightness guide, linked from the FAQ.
http://www.tonymacx86.com/el-capita...faq-read-first-laptop-frequent-questions.html

I don't know what you mean by "low fan speed fix".
Hi RehabMan, thanks for ur guide again.

NVIDIA GPU had totally disabled, also I fixed sleep issue by patching DSDT.
(Using USB3 _PRW 0x6D Skylake to fix.)

Now I'm still focus on fixing Brightness key.
I want to set these keys to Fn+F11 and Fn+F12, which match the original DELL 7560 settings.
I tried to use ACPIDebug.kext, already installed at /L/E, also patched DSDT with debug function.
(DSDT Debug Methods + Instrument EC Queries.)
But I can't get any output from system.log when pressing Fn+F11 or Fn+F12.

Also tried BRT6 patch from guide, but it doesn't work.
WN09 SSDT patch doesn't work, and I got side effect when using WN09
("~" change to another word I never see before. Delete WN09 SSDT will back to normal.)

Here is my new PR file.
 

Attachments

  • debug_2643.zip
    2.5 MB · Views: 82
Joined
Dec 13, 2015
Messages
92
Motherboard
Inspiron 7460
CPU
CPU Core i5 7200U
Graphics
Intel HD Graphics 620 + GeForce Nvidia 940MX
Mobile Phone
  1. iOS
Hi RehabMan, thanks for ur guide again.

NVIDIA GPU had totally disabled, also I fixed sleep issue by patching DSDT.
(Using USB3 _PRW 0x6D Skylake to fix.)

Now I'm still focus on fixing Brightness key.
I want to set these keys to Fn+F11 and Fn+F12, which match the original DELL 7560 settings.
I tried to use ACPIDebug.kext, already installed at /L/E, also patched DSDT with debug function.
(DSDT Debug Methods + Instrument EC Queries.)
But I can't get any output from system.log when pressing Fn+F11 or Fn+F12.

Also tried BRT6 patch from guide, but it doesn't work.
WN09 SSDT patch doesn't work, and I got side effect when using WN09
("~" change to another word I never see before. Delete WN09 SSDT will back to normal.)

Here is my new PR file.

Open DSDT
Set OSIS to linux (credit VBO)

Code:
into_all method code_regex If\s+\([\\]?_OSI\s+\(\"Linux\"\)\) replace_matched begin If(LOr(_OSI("Darwin"),_OSI("Linux"))) end;

into_all method code_regex If\s+\([\\]?_OSI\s+\(LINX\)\) replace_matched begin If(LOr(_OSI("Darwin"),_OSI(LINX))) end;

Brightness Patch (F11 and F12)

Code:
into method label SMEE replace_content
begin
        Local0 = Arg0\n
        Local0 = GENS (0x11, Zero, Zero)\n
        If ((\_SB.OSID () >= 0x20))\n
        {\n
            If ((Local0 & 0x04))\n
            {\n
                // Brightness up\n
                Notify(\_SB.PCI0.LPCB.PS2K, 0x0206)\n
                Notify(\_SB.PCI0.LPCB.PS2K, 0x0286)\n
                EV5 (One, Zero)\n
            }\n
            If ((Local0 & 0x02))\n
            {\n
                // Brightness down\n
               Notify(\_SB.PCI0.LPCB.PS2K, 0x0205)\n
               Notify(\_SB.PCI0.LPCB.PS2K, 0x0285)\n
               EV5 (0x02, Zero)\n
            }\n
        }\n
        If ((Local0 & 0x08))\n
        {\n
            Local0 = GENS (0x1D, Zero, Zero)\n
            EV16 (Local0, Zero)\n
        }\n
end;
 
Joined
May 13, 2011
Messages
543
Motherboard
DELL Inspiron 7560-1.3.0-CLOVER
CPU
i7 7500U
Graphics
HD 620 / GTX 940MX, 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Open DSDT
Set OSIS to linux (credit VBO)

Code:
into_all method code_regex If\s+\([\\]?_OSI\s+\(\"Linux\"\)\) replace_matched begin If(LOr(_OSI("Darwin"),_OSI("Linux"))) end;

into_all method code_regex If\s+\([\\]?_OSI\s+\(LINX\)\) replace_matched begin If(LOr(_OSI("Darwin"),_OSI(LINX))) end;

Brightness Patch (F11 and F12)

Code:
into method label SMEE replace_content
begin
        Local0 = Arg0\n
        Local0 = GENS (0x11, Zero, Zero)\n
        If ((\_SB.OSID () >= 0x20))\n
        {\n
            If ((Local0 & 0x04))\n
            {\n
                // Brightness up\n
                Notify(\_SB.PCI0.LPCB.PS2K, 0x0206)\n
                Notify(\_SB.PCI0.LPCB.PS2K, 0x0286)\n
                EV5 (One, Zero)\n
            }\n
            If ((Local0 & 0x02))\n
            {\n
                // Brightness down\n
               Notify(\_SB.PCI0.LPCB.PS2K, 0x0205)\n
               Notify(\_SB.PCI0.LPCB.PS2K, 0x0285)\n
               EV5 (0x02, Zero)\n
            }\n
        }\n
        If ((Local0 & 0x08))\n
        {\n
            Local0 = GENS (0x1D, Zero, Zero)\n
            EV16 (Local0, Zero)\n
        }\n
end;
Really appreciate!

After use your patch above, now brightness key worked!
Now this laptop are very close to "white" one.

And I have few question want to ask:
1. Is your 7460 can up the fan speed automatically in heavy CPU usage?
I ran a Geekbench 4 but seems like CPU temp is not enough, and Idk if ioreg will write or not.
So I'm not sure if CPU fan is working or just stay at silent node?

2. For battery, I can show battery percentage with using ACPIBatteryManager.kext
But it doesn't re-new the status on the task bar. I need to look at System Preference > Power Saver to get current percentage.
Is your 7460 have a same problems, too?

For BIOS, although I think patch DVMT size into BIOS is better. But as others say, it's too risky.
Now just waiting for DW1560 arrive.
 
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,702
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Really appreciate!

After use your patch above, now brightness key worked!
Now this laptop are very close to "white" one.

And I have few question want to ask:
1. Is your 7460 can up the fan speed automatically in heavy CPU usage?
I ran a Geekbench 4 but seems like CPU temp is not enough, and Idk if ioreg will write or not.
So I'm not sure if CPU fan is working or just stay at silent node?

2. For battery, I can show battery percentage with using ACPIBatteryManager.kext
But it doesn't re-new the status on the task bar. I need to look at System Preference > Power Saver to get current percentage.
Is your 7460 have a same problems, too?

For BIOS, although I think patch DVMT size into BIOS is better. But as others say, it's too risky.
Now just waiting for DW1560 arrive.

Your kextcache output proves kexts are not installed correctly.
All kexts you need must be installed to the system volume.
Read post #2 of the Clover guide for details:
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/
 
Joined
May 13, 2011
Messages
543
Motherboard
DELL Inspiron 7560-1.3.0-CLOVER
CPU
i7 7500U
Graphics
HD 620 / GTX 940MX, 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Your kextcache output proves kexts are not installed correctly.
All kexts you need must be installed to the system volume.
Read post #2 of the Clover guide for details:
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/
Now all kexts I need has installed into /L/E
(I read few guides and they said install kext into /S/L/E was not recommend since 10.11+)
Cleaned up kexts at /EFI/CLOVER/kexts/others.

Since cagalindo has fixed key issue, I already removed debug code and ACPIDebug.kext from my configuration.

Update:
For question 1 & 2 above, we got the conclusion.
1. CPU fan speed up during CPU stress test, so the CPU fan not always stay in low speed.
So this test has solved my doubt that CPU fan may not speed up during CPU stressing

2. Battery status now keep correct currency shows at task bar. It may means need to install kext into system to let them totally work.

I think this topic can turn to "solved" already.

Thanks for RehabMan & cagalindo help!
 

Attachments

  • debug_28705.zip
    1.6 MB · Views: 92
Last edited:

Feartech

Moderator
Joined
Aug 3, 2013
Messages
23,734
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Now all kexts I need has installed into /L/E
(I read few guides and they said install kext into /S/L/E was not recommend since 10.11+)
Cleaned up kexts at /EFI/CLOVER/kexts/others.

Since cagalindo has fixed key issue, I already removed debug code and ACPIDebug.kext from my configuration.

Update:
For question 1 & 2 above, we got the conclusion.
1. CPU fan speed up during CPU stress test, so the CPU fan not always stay in low speed.
So this test has solved my doubt that CPU fan may not speed up during CPU stressing

2. Battery status now keep correct currency shows at task bar. It may means need to install kext into system to let them totally work.

I think this topic can turn to "solved" already.

Thanks for RehabMan & cagalindo help!
you are missing essential kexts in clover/kexts/other, this will cause you issues on the next macos update
 
Joined
May 13, 2011
Messages
543
Motherboard
DELL Inspiron 7560-1.3.0-CLOVER
CPU
i7 7500U
Graphics
HD 620 / GTX 940MX, 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
you are missing essential kexts in clover/kexts/other, this will cause you issues on the next macos update
Sorry, little confused.
I forgot it will cause conflict or not if installed same kexts both EFI and /L/E ?

Fortunately I keep these files in the install USB.
I'll copy them back to EFI and re-upload PR.
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
23,734
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Sorry, little confused.
I forgot it will cause conflict or not if installed same kexts both EFI and /L/E ?
as long as config.plist says Inkectkexts -> Detect you will be fine

only put essential kexts in clover/kexts/other, FakeSMC, VoodooPS2Controller, SATA-100-series-unsupported, RealtekRTL8111.kext and maybe USBInjectAll
 
Joined
May 13, 2011
Messages
543
Motherboard
DELL Inspiron 7560-1.3.0-CLOVER
CPU
i7 7500U
Graphics
HD 620 / GTX 940MX, 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
as long as config.plist says Inkectkexts -> Detect you will be fine

only put essential kexts in clover/kexts/other, FakeSMC, VoodooPS2Controller, SATA-100-series-unsupported, RealtekRTL8111.kext and maybe USBInjectAll
Roger that, I'll put these kexts below:

FakeSMC
VoodooPS2Controller
SATA-100-series-unsupported
RealtekRTL8111
USBInjectAll
Lilu (For safety)
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,702
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Roger that, I'll put these kexts below:

FakeSMC
VoodooPS2Controller
SATA-100-series-unsupported
RealtekRTL8111
USBInjectAll
Lilu (For safety)

Lilu.kext does nothing by itself. Don't include unless you also need some Lilu-based plugin (such as IntelGraphicsFixup.kext or other Lilu-based kext).
 
Status
Not open for further replies.
Top