Contribute
Register

Sapphire Radeon RX 560 PULSE 4GB GDDR5 no sleep

Joined
Aug 10, 2013
Messages
31
Motherboard
Asus X99-A/USB3.1
CPU
I7 5820K
Graphics
RX 560
Mac
iMac, Mac Pro
Mobile Phone
Android
I replaced my gtx 1050 with Sapphire Radeon RX 560 PULSE 4GB GDDR5 for Mojave but sleep is not working. Everything is just fine in 10.13.6.
I tried RadeonDeInit in clover and also Lilu and Whatevergreen. Few seconds after sleep pc restarts, I see desktop for few seconds and the reboot. I use one hdmi and one DVi monitor. They both work before sleep. CSM disabled in bios. Tried smbios: Imac pro 1.1, Imac 16.2 and 18.2, Macpro 6.1. Card id is 0x67ff.
I don't know much about Ati because I always used Nvidia.
Maybe someone can help, thanks!
 
Last edited:
Joined
May 22, 2011
Messages
1,022
Motherboard
ASUS TUF Z390 Plus Gaming
CPU
i9-9900K
Graphics
RX 560
Mac
iMac, MacBook Pro
Mobile Phone
iOS
I replaced my gtx 1050 with Sapphire Radeon RX 560 PULSE 4GB GDDR5 for Mojave but sleep is not working. Everything is just fine in 10.13.6.
I tried RadeonDeInit in clover and also Lilu and Whatevergreen. Few seconds after sleep pc restarts, I see desktop for few seconds and the reboot. I use one hdmi and one DVi monitor. They both work before sleep. CSM disabled in bios. Tried smbios: Imac pro 1.1, Imac 16.2 and 18.2, Macpro 6.1. Card id is 0x67ff.
I don't know much about Ati because I always used Nvidia.
Maybe someone can help, thanks!
Did you toggle off PowerNap under Energy Saver on the System Preferences?
 
Joined
Aug 10, 2013
Messages
31
Motherboard
Asus X99-A/USB3.1
CPU
I7 5820K
Graphics
RX 560
Mac
iMac, Mac Pro
Mobile Phone
Android
PowerNap was always off.
 
Joined
Jul 29, 2010
Messages
42
Motherboard
GA-Z170N-Gaming 5 Mini-ITX
CPU
i7
Graphics
RX 560
Mac
iMac, MacBook Pro
Classic Mac
iMac, PowerBook
Mobile Phone
iOS
Hello Buttadeus,
I had the same problem for Mojave. Swapped GTX 970 for a RX 560 and then sleep/wake was not working anymore.

I solved the problem deleting the com.apple.PowerManagement files in /Library/Preferences/, see this post.

Now there is a little difference from before, the computer wake up only if I press the power button. While before I had just to move the mouse or type in the keyboard.

Regards
John
 
Last edited:
Joined
Apr 1, 2010
Messages
180
Motherboard
ASUS Prime Z390-P
CPU
i9-9900K
Graphics
RX 5700 XT
Mac
iMac, MacBook Pro, Mac mini
Mobile Phone
iOS
I am still having issues but I am using darkwake=0 and this command in terminal. sudo pmset -a standby 0

So my results are that I can sleep if I select it from the menu but system sleep does not work.
 
Joined
Jul 1, 2018
Messages
398
Motherboard
GIGABYTE Z370N
CPU
i7-8700
Graphics
RX 560
Mac
MacBook
Mobile Phone
iOS
Sleep depends on USB injection, BIOS setting, pmset settings, PM settings, darkwake. GPU? No. You have one of the most compatible GPU.
 
Joined
Aug 10, 2013
Messages
31
Motherboard
Asus X99-A/USB3.1
CPU
I7 5820K
Graphics
RX 560
Mac
iMac, Mac Pro
Mobile Phone
Android
Hello Buttadeus,
I had the same problem for Mojave. Swapped GTX 970 for a RX 560 and then sleep/wake was not working anymore.

I solved the problem deleting the com.apple.PowerManagement files in /Library/Preferences/, see this post.

Now there is a little difference from before, the computer wake up only if I press the power button. While before I had just to move the mouse or type in the keyboard.

Regards
John
Did that but the same. Coud you please tell me your clover settings regarding Graphics card?

I am still having issues but I am using darkwake=0 and this command in terminal. sudo pmset -a standby 0

So my results are that I can sleep if I select it from the menu but system sleep does not work.
I will try that, too.

Sleep depends on USB injection, BIOS setting, pmset settings, PM settings, darkwake. GPU? No. You have one of the most compatible GPU.
What's the use of what you said?
 
Joined
Jul 1, 2018
Messages
398
Motherboard
GIGABYTE Z370N
CPU
i7-8700
Graphics
RX 560
Mac
MacBook
Mobile Phone
iOS
What's the use of what you said?
You are wondering why your computer can't sleep. I told you what you need for proper sleep.

Again:
  • custom SSDT for USB
  • some BIOS setting like Wake on lan=off
  • proper pmset setting
  • proper Power Managment settings
  • proper darkwake option
  • proper SMBIOS
  • properly injected kexts
Do you have all of this? I have no idea because you didn't provide any information.

Now you are trying random options to fix your problem. It doesn't work like that.
 
Last edited:
Joined
Aug 10, 2013
Messages
31
Motherboard
Asus X99-A/USB3.1
CPU
I7 5820K
Graphics
RX 560
Mac
iMac, Mac Pro
Mobile Phone
Android
You said I don't need those things: "Sleep depends on USB injection, BIOS setting, pmset settings, PM settings, darkwake. GPU? No.".
I am not wondering, I just want to fix it.
How could I know if I have all of this? That's why I asked. You are just telling how smart you are and how stupid I am. Is how you learned?
 
Joined
Jul 1, 2018
Messages
398
Motherboard
GIGABYTE Z370N
CPU
i7-8700
Graphics
RX 560
Mac
MacBook
Mobile Phone
iOS
You said I don't need those things: "Sleep depends on USB injection, BIOS setting, pmset settings, PM settings, darkwake. GPU? No.".
I am not wondering, I just want to fix it.
How could I know if I have all of this? That's why I asked. You are just telling how smart you are and how stupid I am. Is how Did you learn?
As I mentioned before, you didn’t provide any system information.

You should start here https://www.tonymacx86.com/threads/tool-generate-proper-problem-reporting-files.235953/
 
Top