Contribute
Register

Razer Blade 15 - High Sierra 10.13.6 - Success(-)

Status
Not open for further replies.
Joined
Dec 7, 2011
Messages
545
Motherboard
Razer Blade 15 - Clover
CPU
i7-8750H
Graphics
UHD 630/GTX 1060 - 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
no, is PM961 ssd drive,MZVLW512HMJP-00000.

Is there any situation where the situation above or the prohibition symbol?



add -v,

Report an error:
Using reloc block:no,hibernate wake: no
++++++++++++++++++++++++++++++

MZVLW512HMJP-00000 is the stock PM961 drive. It is not compatible with OSX, you will not be able to make your laptop into a Hackintosh until you upgrade to a different NVMe SSD like the Samsung 970 Evo or Pro.
 
Joined
Dec 7, 2011
Messages
545
Motherboard
Razer Blade 15 - Clover
CPU
i7-8750H
Graphics
UHD 630/GTX 1060 - 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Well I finally had time to sit down (literally all night long) and write up a detailed install guide for this laptop. With it is needed files and all that fun stuff.
For those of you who have yet to install OSX on this laptop and want to, this guide has literally everything that we've been working on in the comments all in one post.

So for whoever wants to use it, here it is:
https://www.tonymacx86.com/threads/...all-guide-high-sierra-10-13-6-17g2208.264017/
 
Joined
Oct 31, 2013
Messages
77
Motherboard
Razer Blade 15, 2019
CPU
i7-8750H
Graphics
UHD 630, GTX 2070
Mac
  1. iMac
Mobile Phone
  1. iOS
Well I finally had time to sit down (literally all night long) and write up a detailed install guide for this laptop. With it is needed files and all that fun stuff.
For those of you who have yet to install OSX on this laptop and want to, this guide has literally everything that we've been working on in the comments all in one post.

So for whoever wants to use it, here it is:
https://www.tonymacx86.com/threads/...all-guide-high-sierra-10-13-6-17g2208.264017/

Amazing! thanks a lot!
 
Joined
Jan 20, 2012
Messages
2
CPU
i7-4790K
Graphics
GTX 970
Hi Vettz, I’ve been following this post for a while and got most things up and running on Mojave (no brightness controls yet, and waiting for my replacement WiFi card to arrive). One thing I’ve noticed it I randomly no longer have the black screen for 3 minutes issue, no matter how many times I reboot it’s gone. Just wondering if there’s anything I can provide that might help figure it out.
 
Joined
Dec 7, 2011
Messages
545
Motherboard
Razer Blade 15 - Clover
CPU
i7-8750H
Graphics
UHD 630/GTX 1060 - 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Hi Vettz, I’ve been following this post for a while and got most things up and running on Mojave (no brightness controls yet, and waiting for my replacement WiFi card to arrive). One thing I’ve noticed it I randomly no longer have the black screen for 3 minutes issue, no matter how many times I reboot it’s gone. Just wondering if there’s anything I can provide that might help figure it out.

If you don't have brightness controls implemented that means your display is not configured 100% properly and because of this the bug that causes the 3 minutes of no backlight on first boot is not present. The bug will only be present when brightness controls are implemented properly and OSX loads the drivers and other files needed for brightness control.
So pretty much OSX thinks that your current display is an external display of some sort and one that it does not control the brightness of, so that bug is not there.

If you were to implement your screen setup/brightness controls properly, the bug would then show itself.
 
Joined
Oct 31, 2018
Messages
32
Motherboard
Razer Blade 2017
CPU
i7-7700HQ
Graphics
GTX 1060 - UHD 630
Mobile Phone
  1. Android
  2. iOS
yes but can't make that damn trackpad works :mad: I can make it move but then the mouse cursor won't stop moving until I click
My third time posting the same thing I get ignored every time :lol: ... Does iMessage / FaceTime work for anyone/
 
Joined
Dec 7, 2011
Messages
545
Motherboard
Razer Blade 15 - Clover
CPU
i7-8750H
Graphics
UHD 630/GTX 1060 - 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
yes but can't make that damn trackpad works :mad: I can make it move but then the mouse cursor won't stop moving until I click

Hard to help you when you don't post any specific details about the set up you're using to make the trackpad work as well as no problem reporting files.

The trackpad is fully functional on this laptop, minus some issues with the touch screen version as some stated a few pages back. But it requires DSDT editing and modifying Voodoo2IC kext to make it happen.
 
Joined
Oct 31, 2018
Messages
32
Motherboard
Razer Blade 2017
CPU
i7-7700HQ
Graphics
GTX 1060 - UHD 630
Mobile Phone
  1. Android
  2. iOS
Hard to help you when you don't post any specific details about the set up you're using to make the trackpad work as well as no problem reporting files.

The trackpad is fully functional on this laptop, minus some issues with the touch screen version as some stated a few pages back. But it requires DSDT editing and modifying Voodoo2IC kext to make it happen.


Thank you, I've fixed it using this patch.. I've a question do you have also multi touch gestures? like scrolling, etc.. I've only trackpad and clicks, gestures doesn't work for me

Please try the attached kext, built from here:
https://github.com/MacForceOne/VoodooI2C/tree/patch-1

That issue you have could be solved by using interrupts instead of polling, but until such support would be stable and merged to upstream, it can be solved with a filter of repeated reports :)
 
Joined
Dec 7, 2011
Messages
545
Motherboard
Razer Blade 15 - Clover
CPU
i7-8750H
Graphics
UHD 630/GTX 1060 - 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Thank you, I've fixed it using this patch.. I've a question do you have also multi touch gestures? like scrolling, etc.. I've only trackpad and clicks, gestures doesn't work for me
That patch is 2 years old, it's outdated.

You need the most recent VoodooI2C + VoodooI2CHID + VoodooPS2Controller kexts. The VoodooI2C needs to be modified to read the trackpad. I attached both kexts at the bottom of this post with the already modified VoodooI2C.
But in order to get them to work properly you need to patch your own DSDT with this patch:
Code:
into method label _STA parent_label GPI0 replace_content begin

Return (0x0F)


end;


into_all method label _CRS parent_label TPD0 replace_content begin


ConcatenateResTemplate (SBFB, SBFI)


end;

That is the only way you're going to get the trackpad working with pretty much 99% functionality. The only thing that doesn't work is palm rejection.

Also, if you were to ever update the VoodooI2C kext it needs to be modified by changing: IOKitPersonalities > VoodooI2CPCIController > IONameMatch add a field with a string value of pci8086,a368.

P.S. You need to upload Problem Report Files in the future to help us help you. See this link on how to generate them: https://www.tonymacx86.com/threads/tool-generate-proper-problem-reporting-files.235953/
 

Attachments

  • Trackpad Kexts.zip
    260.7 KB · Views: 43
Joined
Oct 31, 2018
Messages
32
Motherboard
Razer Blade 2017
CPU
i7-7700HQ
Graphics
GTX 1060 - UHD 630
Mobile Phone
  1. Android
  2. iOS
That patch is 2 years old, it's outdated.

You need the most recent VoodooI2C + VoodooI2CHID + VoodooPS2Controller kexts. The VoodooI2C needs to be modified to read the trackpad. I attached both kexts at the bottom of this post with the already modified VoodooI2C.
But in order to get them to work properly you need to patch your own DSDT with this patch:
Code:
into method label _STA parent_label GPI0 replace_content begin

Return (0x0F)


end;


into_all method label _CRS parent_label TPD0 replace_content begin


ConcatenateResTemplate (SBFB, SBFI)


end;

That is the only way you're going to get the trackpad working with pretty much 99% functionality. The only thing that doesn't work is palm rejection.

Also, if you were to ever update the VoodooI2C kext it needs to be modified by changing: IOKitPersonalities > VoodooI2CPCIController > IONameMatch add a field with a string value of pci8086,a368.

P.S. You need to upload Problem Report Files in the future to help us help you. See this link on how to generate them: https://www.tonymacx86.com/threads/tool-generate-proper-problem-reporting-files.235953/

Thank you, same issue, did all you said, I don't know what's wrong, no gestures and when I move the cursor it doesn't stop to move until I do a click. Attached there's debug file
 

Attachments

  • debug_1027.zip
    5.9 MB · Views: 34
Last edited:
Status
Not open for further replies.
Top