Contribute
Register

Radeon VII not working properly~~

Joined
Jul 11, 2019
Messages
14
Motherboard
MSI Z390i MEG AC
CPU
i7-8700
Graphics
Redeon VII
Just fresh installed a Mojave 10.14.5 Hackintosh with 8700 + Z390 + Radeon VII, boot fine, looks fine, but the Radeon VII is not fully working. LuxMark say no Open CL device selected or available. Unigine Heaven won't run before graphic card missing Open GL or something. All in all, t
I know the card supposed to be OOB card, but I have no clue what's wrong with it.
I don't know if anyone can help to have a look at my EFI or not.
Tried to following the way to enable the iGPU, to find the match Platform ID, to enable and/or disable this and that, etc. Now I am desperate~~ LOL
Please, is there anyone can help~~~
 

Attachments

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
20,553
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
HD 4600
Mac
MacBook Pro, Mac mini
Classic Mac
Power Mac
Mobile Phone
iOS
IntelGraphicsFixup.kext is deprecated - Now part of WhateverGreen.kext.

XHCI-200-series-injector.kext, XHCI-300-series-injector.kext and XHCI-x99-injector.kext are all superseded by XHCI-unsupported.kext - (Click download repository).

AptioMemoryFix-64.efi, OsxAptioFix2Drv-free2000.efi, OsxAptioFix3Drv-64.efi and OsxAptioFixDrv-64.efi all do the same job and are mutually exclusive - Pick one and delete the rest. Try with OsxAptioFix2Drv-free2000.efi.

You don't need boot arguments nv_disable=1 or kext-dev-mode=1.

Suggest you remove Fake ID for IntelGFX and ig-platform-id to let Lilu.kext and WhateverGreen.kext handle it.

NvidiaWeb should not be enabled - You are not using the Nvidia web drivers.
 
Joined
Jul 11, 2019
Messages
14
Motherboard
MSI Z390i MEG AC
CPU
i7-8700
Graphics
Redeon VII
IntelGraphicsFixup.kext is deprecated - Now part of WhateverGreen.kext.

XHCI-200-series-injector.kext, XHCI-300-series-injector.kext and XHCI-x99-injector.kext are all superseded by XHCI-unsupported.kext - (Click download repository).

AptioMemoryFix-64.efi, OsxAptioFix2Drv-free2000.efi, OsxAptioFix3Drv-64.efi and OsxAptioFixDrv-64.efi all do the same job and are mutually exclusive - Pick one and delete the rest. Try with OsxAptioFix2Drv-free2000.efi.

You don't need boot arguments nv_disable=1 or kext-dev-mode=1.

Suggest you remove Fake ID for IntelGFX and ig-platform-id to let Lilu.kext and WhateverGreen.kext handle it.

NvidiaWeb should not be enabled - You are not using the Nvidia web drivers.
WOW! Thank you for your fast reply!!
Just one thing before I restart my system:
by XHCI-unsupported.kext - (Click download repository).
the link is to download USBInjectAll, is that correct? just to double check~~~
 
Joined
Jul 11, 2019
Messages
14
Motherboard
MSI Z390i MEG AC
CPU
i7-8700
Graphics
Redeon VII
IntelGraphicsFixup.kext is deprecated - Now part of WhateverGreen.kext.

XHCI-200-series-injector.kext, XHCI-300-series-injector.kext and XHCI-x99-injector.kext are all superseded by XHCI-unsupported.kext - (Click download repository).

AptioMemoryFix-64.efi, OsxAptioFix2Drv-free2000.efi, OsxAptioFix3Drv-64.efi and OsxAptioFixDrv-64.efi all do the same job and are mutually exclusive - Pick one and delete the rest. Try with OsxAptioFix2Drv-free2000.efi.

You don't need boot arguments nv_disable=1 or kext-dev-mode=1.

Suggest you remove Fake ID for IntelGFX and ig-platform-id to let Lilu.kext and WhateverGreen.kext handle it.

NvidiaWeb should not be enabled - You are not using the Nvidia web drivers.
thank you again for your help.

But after I tried your advice, it still makes no different.

Any other suggestion from you?

Much appreciated!
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
20,553
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
HD 4600
Mac
MacBook Pro, Mac mini
Classic Mac
Power Mac
Mobile Phone
iOS
Top