Contribute
Register

Problem with sleep via lid close on Sony

Joined
May 17, 2015
Messages
55
Motherboard
Sony SVF14A15SN
CPU
i5-3337U
Graphics
HD4000/GT735M
Mac
Classic Mac
Mobile Phone

Buddy, Sleep is not working properly. If making it sleep via closing the lid then there's no display on waking it up.

I applied your patch to fix sleep issues from your repo but there was no effect.
 

Attachments

  • RehabMan.zip
    408.9 KB · Views: 35

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,465
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Joined
May 17, 2015
Messages
55
Motherboard
Sony SVF14A15SN
CPU
i5-3337U
Graphics
HD4000/GT735M
Mac
Classic Mac
Mobile Phone

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,465
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
[Guide] Disabling discrete graphics in dual-GPU laptops

Brightness Controls are working, not sure what do you mean by they are not implemented..?

ACPIBacklight.kext is not installed. Without patching AppleBacklight.kext (or building an injector for your display), the correct range of backlight control is not available.

Recommend you install ACPIBacklight.kext... It is in the guide.
 
Joined
May 17, 2015
Messages
55
Motherboard
Sony SVF14A15SN
CPU
i5-3337U
Graphics
HD4000/GT735M
Mac
Classic Mac
Mobile Phone
[Guide] Disabling discrete graphics in dual-GPU laptops

ACPIBacklight.kext is not installed. Without patching AppleBacklight.kext (or building an injector for your display), the correct range of backlight control is not available.

Recommend you install ACPIBacklight.kext... It is in the guide.

Sleep via closing the lid is still not working fine. The display just appears for a second and then goes away, when the lid is opened. Then I need to close the lid again and then reopen it, only then I get the display.

When I set the brightness level to 0, then there is no backlight.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,465
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
[Guide] Disabling discrete graphics in dual-GPU laptops

Sleep via closing the lid is still not working fine. The display just appears for a second and then goes away, when the lid is opened. Then I need to close the lid again and then reopen it, only then I get the display.

Test the following scenarios...

Test #0:
- lid is open
- test sleep with Apple->Sleep
- wake laptop

Test #1:
- close lid
- immediately open lid

Test #2:
- close lid
- allow enough time for laptop to sleep
- open lid

Test #3:
- lid is open
- Apple->Sleep
- close lid
- immediately open lid

Test #4:
- lid is open
- Apple->Sleep
- allow laptop to sleep
- close lid
- wake laptop with lid open

Report results.

Also, you should verify that your DSDT is patched correctly to allow _PTS and _WAK to execute completely. You can use ACPIDebug for this: https://github.com/RehabMan/OS-X-ACPI-Debug. There is a patch "Instrument _PTS/_WAK" that can be used to add the necessary debug code. Report results from system.log.

When I set the brightness level to 0, then there is no backlight.

That's good, because it is correct behavior for OS X.
 
Joined
May 17, 2015
Messages
55
Motherboard
Sony SVF14A15SN
CPU
i5-3337U
Graphics
HD4000/GT735M
Mac
Classic Mac
Mobile Phone
[Guide] Disabling discrete graphics in dual-GPU laptops

Test the following scenarios...

Test #0:
- lid is open
- test sleep with Apple->Sleep
- wake laptop

Test #1:
- close lid
- immediately open lid

Test #2:
- close lid
- allow enough time for laptop to sleep
- open lid

Test #3:
- lid is open
- Apple->Sleep
- close lid
- immediately open lid

Test #4:
- lid is open
- Apple->Sleep
- allow laptop to sleep
- close lid
- wake laptop with lid open

Report results.


It is getting failed in Test-2. I have to close the lid again and then reopen it to get the display.

Also, you should verify that your DSDT is patched correctly to allow _PTS and _WAK to execute completely. You can use ACPIDebug for this: https://github.com/RehabMan/OS-X-ACPI-Debug. There is a patch "Instrument _PTS/_WAK" that can be used to add the necessary debug code. Report results from system.log.

I have attached the system.log
 

Attachments

  • system.log.zip
    138.8 KB · Views: 37

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,465
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
[Guide] Disabling discrete graphics in dual-GPU laptops

It is getting failed in Test-2. I have to close the lid again and then reopen it to get the display.

What about the results from Test #3 and #4?

I have attached the system.log

No evidence that you applied "Instrument _WAK/_PTS" patch to your DSDT. Apply that patch and then sleep/wake the laptop. Search for 'acpidebug' in system.log.
 
Joined
May 17, 2015
Messages
55
Motherboard
Sony SVF14A15SN
CPU
i5-3337U
Graphics
HD4000/GT735M
Mac
Classic Mac
Mobile Phone
[Guide] Disabling discrete graphics in dual-GPU laptops

What about the results from Test #3 and #4?

Test 3 and Test 4 were fine.


No evidence that you applied "Instrument _WAK/_PTS" patch to your DSDT. Apply that patch and then sleep/wake the laptop. Search for 'acpidebug' in system.log.

I got the display after waking up in test 2 but the display is turning off again and again after 1 minute.
 

Attachments

  • system.log.zip
    180.2 KB · Views: 41

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,465
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
[Guide] Disabling discrete graphics in dual-GPU laptops

Test 3 and Test 4 were fine.

So it is something that happens only with lid initiated sleep.

I got the display after waking up in test 2 but the display is turning off again and again after 1 minute.

ACPIDebug shows _PTS and _WAK executing successfully. Analyse DSDT code to see what either _PTS or _WAK is doing differently in the case of lid initiated sleep. Note it could also be something done in the LID object itself.
 
Top