Contribute
Register

Portable Desktop Hackintosh

Status
Not open for further replies.
Joined
Dec 12, 2012
Messages
44
Motherboard
ASRock H170M-ITX/DL LGA 1151
CPU
Intel Core i3-6100 3M 3.7 GHz Socket LGA 1151
Graphics
NVIDIA GTX 1050 Ti 4GB
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
This is a small Hackintosh build not as small as the NUC. However it sports a full Discrete GPU and a dual core with 4 threads or whatever fits obviously/

My Build:
CPU: Intel Core i3-6100 3M 3.7 GHz Socket LGA 1151
RAM: G.SKILL NT Series 8GB 288-Pin DDR4 SDRAM DDR4 2133 Model:F4-2133C15S-8GNT
MotherBoard: ASRock H170M-ITX/DL LGA 1151
GPU: NVIDIA GTX 1050 Ti 4GB PHOENIX Fan Edition
PowerSupply: SilverStone ST45SF SFX Form Factor PowerSupply
Case: AZZA CSAZ-103 Black SECC Mini-ITX Tower
SSD: Mushkin Enhanced ECO2 2.5" 240GB
WIFI/BT: Azurewave aw-ce123h

If anyone would like a guide I will Post one just comment here if anyone is interested in it. :)
 
Last edited:
Joined
May 18, 2017
Messages
1
This is a small Hackintosh build not as small as the NUC. However it sports a full Discrete GPU and a dual core with 4 threads or whatever fits obviously/

My Build:
CPU: Intel Core i3-6100 3M 3.7 GHz Socket LGA 1151
RAM: G.SKILL NT Series 8GB 288-Pin DDR4 SDRAM DDR4 2133 Model:F4-2133C15S-8GNT
MotherBoard: ASRock H170M-ITX/DL LGA 1151
GPU: NVIDIA GTX 1050 Ti 4GB PHOENIX Fan Edition
PowerSupply: SilverStone ST45SF SFX Form Factor PowerSupply
Case: AZZA CSAZ-103 Black SECC Mini-ITX Tower
SSD: Mushkin Enhanced ECO2 2.5" 240GB

If anyone would like a guide I will Post one just comment here if anyone is interested in it. :)

I would love a guide! Have nearly the same parts list and I'm stuck trying to get Sierra to boot. Progress bar stuck halfway under Apple logo

Verbose mode output ends on

IOConsoleUsers: gIOScreenLockState 3, hs 0, bs 0, now 8, sm 0x0
 
Joined
Jun 4, 2016
Messages
95
Motherboard
ASRock H97M-ITX/AC
CPU
i3-4170
Graphics
HD4400
Mac
  1. MacBook Pro
Would be great if you could post a guide covering your experiences with the ASRock H170M-ITX/DL motherboard. I'm about to embark on a build using the components listed below and would really appreciate an understanding of the steps that you went through and the various problems that you encountered.

Motherboard: ASRock H170M-ITX/AC LGA 1151
Processor: Core i5 6500
Memory: Ballistix Sport LT 8GB Single DDR4 DIMM
Hard Drive: HGST Ultrastar 7K4000 3TB
Case: Thermaltake Core V1

I'm assuming that there isn't too much difference between the DL and AC versions of the motherboard. Any hints or tips would be greatly appreciated.
 
Last edited:
Joined
Dec 12, 2012
Messages
44
Motherboard
ASRock H170M-ITX/DL LGA 1151
CPU
Intel Core i3-6100 3M 3.7 GHz Socket LGA 1151
Graphics
NVIDIA GTX 1050 Ti 4GB
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
I would love a guide! Have nearly the same parts list and I'm stuck trying to get Sierra to boot. Progress bar stuck halfway under Apple logo

Verbose mode output ends on

IOConsoleUsers: gIOScreenLockState 3, hs 0, bs 0, now 8, sm 0x0


Have you tried installing FakeSMC with and without plugins to the installer?
 
Joined
Dec 12, 2012
Messages
44
Motherboard
ASRock H170M-ITX/DL LGA 1151
CPU
Intel Core i3-6100 3M 3.7 GHz Socket LGA 1151
Graphics
NVIDIA GTX 1050 Ti 4GB
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
I would love a guide! Have nearly the same parts list and I'm stuck trying to get Sierra to boot. Progress bar stuck halfway under Apple logo

Verbose mode output ends on

IOConsoleUsers: gIOScreenLockState 3, hs 0, bs 0, now 8, sm 0x0

Also what are you complete specs :)
 
Joined
Dec 12, 2012
Messages
44
Motherboard
ASRock H170M-ITX/DL LGA 1151
CPU
Intel Core i3-6100 3M 3.7 GHz Socket LGA 1151
Graphics
NVIDIA GTX 1050 Ti 4GB
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Have you tried installing FakeSMC with and without plugins to the installer?


also if that doesnt work try nv_disable=1 to get into installer and first boot to setup the system
and if that doesnt work we will work through it together but the specs will help most
 
Joined
Jun 4, 2016
Messages
95
Motherboard
ASRock H97M-ITX/AC
CPU
i3-4170
Graphics
HD4400
Mac
  1. MacBook Pro
I would love a guide! Have nearly the same parts list and I'm stuck trying to get Sierra to boot. Progress bar stuck halfway under Apple logo

Verbose mode output ends on

IOConsoleUsers: gIOScreenLockState 3, hs 0, bs 0, now 8, sm 0x0

I just got a build up and running today that uses the H170M itx/ac board which I assume is more or less similar to yours. The spec for the build is:

ASRock H170M itx/ac
i5 6500 processor
Integrated graphics - HD530
8 GB Memory (1 x 8 GB Ballistix Sport LT)
3 TB hard drive
Thermaltake Core V1 case.

Only real issue I had with the build was the initial install from the USB stick. However cmn699 quickly sorted that out by advising that I add FixOwnership to the Plist using Clover Configurator. Post install using MultiBeast went without a hitch - see this link.
https://www.tonymacx86.com/threads/cant-install-sierra-from-usb.224383/#post-1523808
https://www.tonymacx86.com/threads/cant-install-sierra-from-usb.224383/#post-1523808

I'm not at the new machine at present however I will post a copy of the Plist in case it might be of help to you.

Kudos to cnm699 for responding so quickly
 
Joined
Dec 12, 2012
Messages
44
Motherboard
ASRock H170M-ITX/DL LGA 1151
CPU
Intel Core i3-6100 3M 3.7 GHz Socket LGA 1151
Graphics
NVIDIA GTX 1050 Ti 4GB
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
I just got a build up and running today that uses the H170M itx/ac board which I assume is more or less similar to yours. The spec for the build is:

ASRock H170M itx/ac
i5 6500 processor
Integrated graphics - HD530
8 GB Memory (1 x 8 GB Ballistix Sport LT)
3 TB hard drive
Thermaltake Core V1 case.

Only real issue I had with the build was the initial install from the USB stick. However cmn699 quickly sorted that out by advising that I add FixOwnership to the Plist using Clover Configurator. Post install using MultiBeast went without a hitch - see this link.
https://www.tonymacx86.com/threads/cant-install-sierra-from-usb.224383/#post-1523808

I'm not at the new machine at present however I will post a copy of the Plist in case it might be of help to you.

Kudos to cnm699 for responding so quickly


What do you need help with per say lol
 
Status
Not open for further replies.
Top