Contribute
Register

PCI-e mSATA raid controller not detected

Joined
Nov 2, 2012
Messages
72
Motherboard
ASUS X299 PRIME DELUXE II
CPU
i9-9900X
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
this is a RAID controller that makes it possible to pair a M.2 disk with physical HDD and creating a HyperDuo array. It has been working flawlessly for years until now. The reason is that i updated my Opencore to the latest version 0.9.6 along with all kext files and then i updated the OS to Sonoma.
After updating i was unable to boot without freeze so i had to make some alternations to my Config file, delete som kext files and then i was forced to create a new USB map file. So now my system is running stable again. But few things are still needed. Like my airport card no longer works and this PCI-e card.

I am not sure where i should solve the problem, is it in the BIOS, Kext, drivers or something else?

All suggestions are welcome.

I am running a Asus X299 Deluxe II Mobo, 10core i9 11900K, Vega 64 GPU, 128GB 2133mhz ram.
Here is my EFI file for you who want to discover it.
 

Attachments

  • EFI.zip
    54.6 MB · Views: 16
I can only assume that Sonoma dropped support for the kext(s) used by the Marvell 88SE9230 PCI SATA III RAID card and that is why your Startech Raid card isn't working in Sonoma.

I looked on the Drivers/specification page for the card and it says support in macOS stopped with Mojave 10.14.x.

So I should ask which version of macOS you upgraded from when you installed Sonoma?

WIFI/BT:
If you have a Broadcom Wifi/BT that worked in Ventura then you are out of luck as far as Sonoma, as Apple dropped a number of previously working Broadcom Wifi/BT cards when they introduced Sonoma. The BT module will work assuming the USB port it is connected to is active in your USBPorts.kext.

You can use OpenCore Legacy Patcher (OCLP) to get your Broadcom WiFi working again, but you need to partially disable SIP, disable AMFI and run some specific Root Patches for the Broadcom card. See the link below for more information. Make sure you check the Hackintosh section.


You may need to revert to using Ventura or an earlier version of macOS on a separate drive, until a better Broadcom Fix is available for the WiFi. You would then be able to see which kext(s) are being used by the RAID card, so you would know if they were still present in Sonoma, or if they can be added to your /EFI/OC/Kexts folder and config.plist to reenable the RAID card.
 
Hi.. sorry for not replying but i did not receive notifications that there had been any activity.

i updated from Ventura version so at least it worked beyond Mojave.

Its sad that so many things have been dropped but i can live without wifi, since i use tethered ethernet and bluetooth driver is working at the moment.. My only major issue is that my PCI card is not detected :(
I will have to make some test to se if i can get it to work again.

One question, should i solely focus on Kext files or can something be done through DeviceProperties that might help?
 
should i solely focus on Kext files or can something be done through DeviceProperties that might help?
Depends on whether there is a kext available in Sonoma that provides support for another similar Marvell RAID card.

If there is, then a fake Device ID might work.

If not, then you need to use a kext from Ventura that worked with the RAID card, i.e. try adding the kext to your /EFI/OC/Kexts folder and an entry for the kext in your config.plist.

If you try either option, make sure you use a spare USB pen drive to test your revised OC setup, don't go editing or revising your working OC setup without knowing if the edit works.
 
Back
Top