Contribute
Register

OC 0.7.0 OCS: Missing key Flavour, context <Tools>!

Feartech

Moderator
Joined
Aug 3, 2013
Messages
23,271
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
will do but did I add the Flavour bit correctly to the plist? As I'm still getting the validation error, I am not sure
you seemed to have added some extra spaces for some reason in the Tools section

best to edit with plistEditPro and re saving it properly

save and close and then re run the ocvalidate on it
 
Joined
May 29, 2012
Messages
466
Motherboard
Gigabyte Z390 Gaming X
CPU
i9-9900K
Graphics
Vega 56
Mac
  1. iMac
Classic Mac
  1. LC
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Here's what I don't get. What is the u in there for anyway ? Isn't the word pronounced flav(or) ? Makes no sense. Just like when jony ive says Alu min ium. when there is only one i in Aluminum. ;)

After I moved from Canada (British English) to US (American English) it took me a long time to drop my "u's" from various words. There are some words that are spelled the same but pronounced differently, like "capillary." CA-pil-lar-y (American) vs ca-PIL-lar-y (British). We can always tell the Canadians in the room when we pronounce it like that.

And we can always tell who are the Americans when they say "why y'all speak weird?"

And I occasionally will throw in an "eh?" here and there.
 
Joined
Dec 10, 2010
Messages
692
Motherboard
Gigabyte Z390 Aorus Elite
CPU
i9-9900K
Graphics
RX 580
Mobile Phone
  1. iOS
will do but did I add the Flavour bit correctly to the plist? As I'm still getting the validation error, I am not sure
Read this: [HOW TO] OpenCore 0.6.9 > 0.7.0 differences

If you study this, you will discover that Flavours works if Picker Attributes=144. In your config.plist I see 17. And you have 2 UEFI Shell tools, the one that has Flavour property has Enabled=False and the one without Flavour is enabled.

Yo say "OCS: Missing key Flavour, context <Tools>!" error but I cannot find info on how to solve this issue. I think you have looked for changes from 0.6.9 to 0.7.0 with little effort.
 
Last edited:
Top