Contribute
Register

Nvidia GTX 1080 + LG Ultrafine 5K full 5K@60hz Success!

Status
Not open for further replies.
Joined
Jun 10, 2015
Messages
37
Motherboard
Z87Pro
CPU
i7 4770k
Graphics
nvidia gtx 770
Mac
Classic Mac
Mobile Phone
The newest Nvidia webdriver 387.10.10.10.30.106 solves all lag issues.
Anyone knows a way to get the LG 5k working with this new driver?

UPDATE: i just tried connecting the screen again today, and it seems to work (sometimes)
 
Last edited:
Joined
Mar 27, 2018
Messages
26
Motherboard
Gigabyte Z370 Aorus Gaming WIFI
CPU
i7- 8700K
Graphics
RX 570
Mac
  1. iMac
Should I delete the original NvidiaGraphicsFixup.kext and lilu.text in the extension folder?
Why does the boot flag need to disable audiofix for this patched NvidiaGraphicsFixup.kext?
 
Last edited:
Joined
Mar 27, 2018
Messages
26
Motherboard
Gigabyte Z370 Aorus Gaming WIFI
CPU
i7- 8700K
Graphics
RX 570
Mac
  1. iMac
One thing that doesn't seem to work: booting MacOS shows a progressbar on the LG 5K, and when its at 50%, all displays go black :(
So i have to boot without LG 5k, and then connect it

UPDATE
another issue i'm seeing is UI stutter / lag, it might be a problem with the NVIDIA driver on 10.13.3
http://www.insanelymac.com/forum/to...for-macos-high-sierra-update-01252018/page-63
Do you still have to boot without lg 5k connected and then plug in lg 5k to have it work? Thanks.
I have to do this to have 5k resolution and the brightness control is gone. When I used the regular lilu.kext and NvidiaGraphicsFixup.kext, the brightness control is there.
 
Joined
Mar 27, 2018
Messages
26
Motherboard
Gigabyte Z370 Aorus Gaming WIFI
CPU
i7- 8700K
Graphics
RX 570
Mac
  1. iMac
To me the method partially solved the problem. I have to use only one display cable to connect 1080 ti to thunderbolt pcie after it boots into system I will plugin the other display cable between the 1080ti and the pcie card to get 5k. And I can not get other functions such as usb, brightness control, camera and speaker.
 
Joined
Mar 27, 2018
Messages
26
Motherboard
Gigabyte Z370 Aorus Gaming WIFI
CPU
i7- 8700K
Graphics
RX 570
Mac
  1. iMac
I found all the boot flag doesn't make any difference. without or without these flags, the only way to get 5k is booting with single display port connected, after booting into the system, connect the other display port to get 5k.
 
Last edited:
Joined
Mar 27, 2018
Messages
26
Motherboard
Gigabyte Z370 Aorus Gaming WIFI
CPU
i7- 8700K
Graphics
RX 570
Mac
  1. iMac
The newest Nvidia webdriver 387.10.10.10.30.106 solves all lag issues.
Anyone knows a way to get the LG 5k working with this new driver?

UPDATE: i just tried connecting the screen again today, and it seems to work (sometimes)
I have the 25.106 nvwebdriver, it doesn't boot into macOS with two display ports connected.
 
Last edited:
Joined
Feb 9, 2012
Messages
305
Motherboard
Gigabyte X299 Desgnare EX
CPU
i9-9900x
Graphics
W5700
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Hi, this patched kexts are working in 10.13.5 as well? I am thinking to buy Nvidia card like Titan Xp but I am afraid of the monitor will not working well with it. Anybody can confirm this? Please-
 
Joined
Jun 10, 2015
Messages
37
Motherboard
Z87Pro
CPU
i7 4770k
Graphics
nvidia gtx 770
Mac
Classic Mac
Mobile Phone
It seems like it doesn't work yet on 10.13.5.
I tried upgrading to 10.13.5 yesterday, and I couldn't get the LG5k to work as a second display.
The issues i noticed: the hackintosh frooze, and the LG5k backlight doesn't activate at all, it just stays black.
In macos logs I found a bunch of errors like "unable to find display pipe for IOFB service".

(I've reverted to 10.13.4 with a time machine backup for now)
 
Joined
Feb 9, 2012
Messages
305
Motherboard
Gigabyte X299 Desgnare EX
CPU
i9-9900x
Graphics
W5700
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Thank you for sharing the information, my AMD card is working well with the Monitor in 10.13.5 now. So I will keep this card instead of getting Nvidia. Actually, it is much better than 10.13.4, no delay monitor on at all. But still struggling with after sleep/wake (non-USB functions after sleep)
 
Status
Not open for further replies.
Top