Contribute
Register

No 4k 60Hz

Status
Not open for further replies.
Joined
Nov 14, 2016
Messages
16
Motherboard
GA-Z170N-Gaming 5
CPU
i7-6700K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
Hello there!
I'm stuck at a very strange problem. I have installed the High Sierra Beta (Public 1) and everything works fine now except one strange issue: I can't get my RX580 to output 4k at 60hz on a specific monitor (Monitor A). I've tested the same settings on a different monitor (Monitor B) and everything works there. In addition to that I've tested Monitor A with my 2015 MacBook Pro and apparently 4k 60Hz works without any issues.
I've already installed SwitchResX on my hackintosh, but it didn't solve the problem. (I only got 1080p HiDPI at 30Hz.)
Is it safe to run the mac pixel clock patch v2 (I've read on GitHub that the signatures on 10.13 are the same as 10.12.5. But not sure about that) or run this command I've found on this forum?
Code:
# Run the following command in order to patch IOKit in order to disable CheckTimingWithRange
sudo perl -i.bak -pe 's|\xB8\x01\x00\x00\x00\xF6\xC1\x01\x0F\x85|\x33\xC0\x90\x90\x90\x90\x90\x90\x90\xE9|sg' /System/Library/Frameworks/IOKit.framework/Versions/Current/IOKit
sudo codesign -f -s - /System/Library/Frameworks/IOKit.framework/Versions/Current/IOKit

Any help is much appreciated!
 
Joined
Dec 14, 2016
Messages
356
Motherboard
Asus Prime z370 A-II
CPU
i9-9900K
Graphics
Radeon VII
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
Hello there!
I'm stuck at a very strange problem. I have installed the High Sierra Beta (Public 1) and everything works fine now except one strange issue: I can't get my RX580 to output 4k at 60hz on a specific monitor (Monitor A). I've tested the same settings on a different monitor (Monitor B) and everything works there. In addition to that I've tested Monitor A with my 2015 MacBook Pro and apparently 4k 60Hz works without any issues.
I've already installed SwitchResX on my hackintosh, but it didn't solve the problem. (I only got 1080p HiDPI at 30Hz.)
Is it safe to run the mac pixel clock patch v2 (I've read on GitHub that the signatures on 10.13 are the same as 10.12.5. But not sure about that) or run this command I've found on this forum?
Code:
# Run the following command in order to patch IOKit in order to disable CheckTimingWithRange
sudo perl -i.bak -pe 's|\xB8\x01\x00\x00\x00\xF6\xC1\x01\x0F\x85|\x33\xC0\x90\x90\x90\x90\x90\x90\x90\xE9|sg' /System/Library/Frameworks/IOKit.framework/Versions/Current/IOKit
sudo codesign -f -s - /System/Library/Frameworks/IOKit.framework/Versions/Current/IOKit

Any help is much appreciated!

Did you find a solution for this? Have the same issue
 
Joined
Nov 18, 2015
Messages
45
Motherboard
z77x-ud3h
CPU
i7 3770k
Graphics
RX 480
Mobile Phone
  1. iOS
Hello there!
I'm stuck at a very strange problem. I have installed the High Sierra Beta (Public 1) and everything works fine now except one strange issue: I can't get my RX580 to output 4k at 60hz on a specific monitor (Monitor A). I've tested the same settings on a different monitor (Monitor B) and everything works there. In addition to that I've tested Monitor A with my 2015 MacBook Pro and apparently 4k 60Hz works without any issues.
I've already installed SwitchResX on my hackintosh, but it didn't solve the problem. (I only got 1080p HiDPI at 30Hz.)
Is it safe to run the mac pixel clock patch v2 (I've read on GitHub that the signatures on 10.13 are the same as 10.12.5. But not sure about that) or run this command I've found on this forum?
Code:
# Run the following command in order to patch IOKit in order to disable CheckTimingWithRange
sudo perl -i.bak -pe 's|\xB8\x01\x00\x00\x00\xF6\xC1\x01\x0F\x85|\x33\xC0\x90\x90\x90\x90\x90\x90\x90\xE9|sg' /System/Library/Frameworks/IOKit.framework/Versions/Current/IOKit
sudo codesign -f -s - /System/Library/Frameworks/IOKit.framework/Versions/Current/IOKit

Any help is much appreciated!
HDMI or dp? In sierra my monitor didn't run at 60hz, only with dp it ran 4K at 60hz. dp is running at 4K 60hz now in High Sierra also. Haven't tested hdmi, will check that and find out
 
Status
Not open for further replies.
Top