Contribute
Register

Mojave install panic on Dell XPS 9570 with Samsung MZVLB512HAJQ (PM981)

Status
Not open for further replies.
Joined
Nov 10, 2013
Messages
22
Motherboard
Dell XPS 9570
CPU
i7-8750H
Graphics
UHD 630 / GTX 1050 Ti
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
Hi there,

I have a Dell XPS 9570 with a Samsung MZVLB512HAJQ (PM981). I'm using the Unibeast method to boot into the installer (the pristine Clover method doesn't even get to the graphical installer). Using Unibeast, Disk Utility successfully recognises my SSD which I can format. After proceeding with with the install process, the system reboots "randomly" (guess a panic). Having checked the logs during install, the last entry I see is "Can't find system audio level" altho I don't think it's actually the problem. (Tried with disabling audio completely in the BIOS/UEFI). As I'm not familiar with the order of things during install, I did a google search and seen that others have managed to pass that entry where diskmanagementd seems to be the next thing they see.

This is why I think the problem is with the SSD I have. I've seen that there are ways to get PM981 to work but I don't know whether I'd need a kext under Mojave, or if so which (IONVMEeFamily.kext or which) or to use @RehabMan's patch-nvme method

My Clover directories' contents attached. Any help would be appreciated, thank you.
 

Attachments

  • Screenshot 2018-12-26 at 20.13.29.png
    Screenshot 2018-12-26 at 20.13.29.png
    178.6 KB · Views: 313
  • Screenshot 2018-12-26 at 20.13.56.png
    Screenshot 2018-12-26 at 20.13.56.png
    138.5 KB · Views: 262
Joined
Nov 10, 2013
Messages
22
Motherboard
Dell XPS 9570
CPU
i7-8750H
Graphics
UHD 630 / GTX 1050 Ti
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
Yes, I am aware of that, thank you. I know of the APFS conversion for example, others have documented the expected rebooting process as well. The system "dies" randomly after some time, even though it seems to be idle. (For example if you don't click the "install" button that starts the process, or when you keep Disk Utility idle).
 
Joined
Nov 10, 2013
Messages
22
Motherboard
Dell XPS 9570
CPU
i7-8750H
Graphics
UHD 630 / GTX 1050 Ti
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
PM981 is not compatible with OS X install. You need to change it. I recommend you samsung 960 mm2.

I ended up replacing PM981 with a Samsung 970 EVO (NVMe M.2 500GB) drive. Install was smooth, rebooted twice as expected. macOS Mojave 14.2 installed, looking good so far.
 
Joined
May 29, 2020
Messages
5
Motherboard
Dell Precision 5520
CPU
7820HQ
Graphics
HD 630 / M1200
Mobile Phone
  1. Android
Hi there,
Have the same ssd PM981 1TB on my DELL Precision 5520.
On first step it reboots and show "Boot on Mac" as expected but it stuck on 15mn remaining and reboots every time at this stage.
I think it the SSD.
The only solution is to change it ??
There hav'nt a patch or some tweaks to pass this ??
 
Joined
Nov 10, 2013
Messages
22
Motherboard
Dell XPS 9570
CPU
i7-8750H
Graphics
UHD 630 / GTX 1050 Ti
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
Hi there,
Have the same ssd PM981 1TB on my DELL Precision 5520.
On first step it reboots and show "Boot on Mac" as expected but it stuck on 15mn remaining and reboots every time at this stage.
I think it the SSD.
The only solution is to change it ??
There hav'nt a patch or some tweaks to pass this ??

PM981 uses a controller that is known to be buggy. You may be able to try the NVMe fix kext, (PM981 has been fixed with NVMeFix ver. 1.0.2 there is still plenty of kernel panics issues). Read this for more info:
 
Joined
May 29, 2020
Messages
5
Motherboard
Dell Precision 5520
CPU
7820HQ
Graphics
HD 630 / M1200
Mobile Phone
  1. Android
PM981 uses a controller that is known to be buggy. You may be able to try the NVMe fix kext, (PM981 has been fixed with NVMeFix ver. 1.0.2 there is still plenty of kernel panics issues). Read this for more info:

I try for a week I always fall back on the remaining 15 minutes and restart. Hopefully that will solve my problem. I will keep you posted
thanks for your quick response.
 
Joined
May 29, 2020
Messages
5
Motherboard
Dell Precision 5520
CPU
7820HQ
Graphics
HD 630 / M1200
Mobile Phone
  1. Android
Hi... There i retried with the NMVefix.kext for fresh install but no luck:thumbdown
According to this Tuto the solution is to make a backup of a working hackintosh and restore it to the PM981 and add Hackr.... KEXT+ edited SSD.AML to got it work for those interested look Here.
For me i'll buy a full compatible SSD more easy way i think.
Thank's again @liquid986
 
Status
Not open for further replies.
Top