Contribute
Register

macOS 10.15.3 Update

Joined
Oct 8, 2011
Messages
39
Motherboard
Gigabyte Z270MX Gaming 5
CPU
i7-7700K
Graphics
Vega 56
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hi, maybe a noob question; do you copy your kexts to the new folder or reinstall them and delete the old ones ?
Kind regards, Michiel

When adding Kexts to /EFI/CLOVER/Kexts/Other, I just mount my EFI partition, and copy them into the "Other" folder manually.

For this upgrade, I deleted all Hacintosh related kexts from /Library/Extension, and rebuilt cache as instructed in Stork's post.
 
Joined
May 29, 2019
Messages
8
Motherboard
Z77MX-D3H
CPU
i5-3570K OC @ 4.4MHz
Graphics
RX 570
Mobile Phone
  1. Android
Updated via system preferences. Running smooth. No problems.
Z77mxd3h
i5 3570k
Sapphire Pulse RX 570 4GB
8GB DDR3
Update took 3 restarts and ±20min
Fullscreen_2020-01-30_20_12.png
 
Last edited:
Joined
Feb 26, 2016
Messages
25
Motherboard
MSI Z87-G45 GAMING
CPU
i7-4770K
Graphics
Radeon VII
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
Hello,

Capture d’écran 2020-01-30 à 20.03.57.png


Update via system preferences.
Blind update until last reboot... even with agdpmod=pikera

All seems to be ok.

Blender with radeon pro render run very very fast in viewport without artefacts :thumbup:!!!
 
Joined
Jul 9, 2018
Messages
57
Motherboard
Gigabyte x58 USB3
CPU
i7-960
Graphics
GT 430
Mobile Phone
  1. Other
I did as instructed, I updated my kexts and moved my /L/E/ folder kexts to EFI/clover/kexts/others, and then
updated my HP 8300 to 10.15.3. It was a smooth update with no issues at all. It took me about 10 to 20 min and done! :)

Screen Shot 2020-01-30 at 10.23.34 PM.png
 
Last edited:

Feartech

Moderator
Joined
Aug 3, 2013
Messages
21,499
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
I did as instructed, I updated my kexts and moved my /L/E/ folder kexts to EFI/clover/kexts/others, and then
updated my HP 8300 to 10.15.3. It was a smooth update with no issues at all. It took me about 10 to 20 min and done! :)

View attachment 447526
star trek :)
 
Joined
Apr 5, 2012
Messages
117
Motherboard
MSI Z270 Gaming Pro Carbon
CPU
i5-7600
Graphics
RX 570
Mobile Phone
  1. Android
Backed up my 10.15.2 installation - of course. Checked my /L/E folder and found a duplicate FakeSCM kext (deleted), a deprecated internet kext (deleted), and an old IntelMausiEthernet kext (deleted). (I was impressed with myself as I had labeled these kexts when I installed them with a red dot so that I could easily find them later.) Put new IntelMausiEthernet kext in /EFI/Clover/Kexts/Other, updated FakeSMC, Lilu and WateverGreen kexts that were already there. Restarted and tested O.K.

Installed Clover 5103, restarted and tested O.K. Tried replacing FakeSMC with VirtualSMC, rebooted and boot failed. Restarted from my backup and restored FakeSMC. Tested and all was well again.

Ran update from System Preferences and after several restarts and waiting... waiting... waiting... success! Overall a pretty easy update. Someday I may try again with VirtualSMC, but I might just wait for my next Hackintosh build (in the planning stage) as I am a bit busy at the moment.
 
Joined
Mar 3, 2011
Messages
111
Motherboard
ASUS H270 Plus
CPU
i5-7600K
Graphics
AMD RX 570 4 GB
When you use VirtualSMC, you have two files: an .kext and an .efi Driver. Same as Fakesmc (whoch has beside the .kext ) also an SMCHelper.efi driver. Please use always only one bundle (.kext+ efi) never mix them and remove aways both (.kext + .efi) if you switch to other SMC method.
 
Joined
Nov 30, 2019
Messages
2
Motherboard
MSI Z77A-G41
CPU
i5-3570K
Graphics
RX 560
Updated through System Preferences and installed 3 reboots without any problem.
z77a-g41 - i5-3570K - Radeon RX 560
Catalina.png
 
Last edited:
Top