Contribute
Register

iTunes Protected Video Black Screen Solution (HDCP)

Joined
May 11, 2011
Messages
575
Motherboard
MSI B360 A-Pro
CPU
i5-8400
Graphics
UHD 630 + RX 580
Mobile Phone
iOS
Joined
Oct 30, 2011
Messages
883
Motherboard
GA-Z170X-UD5 TH
CPU
i7 6700K
Graphics
RX 580
Mac
MacBook Air, MacBook Pro
Mobile Phone
iOS
I am encountering the black screen when trying to play purchased TV shows in iTunes (I'm speaking of my CustoMac Pro build in my signature below). I tried taking all the steps in post #1 of this thread and still get the black screen.

Are those instructions still valid?
 

ammulder

Moderator
Joined
Sep 1, 2014
Messages
3,466
Motherboard
GA-H87N-WIFI
CPU
i7-4790S
Graphics
GT 740
Mac
MacBook Pro, Mac mini
Mobile Phone
iOS
So I've got a Sapphire Pulse RX 580 in 10.14.2 and I've got HEVC/H264 acceleration working (with iGPU enabled), but iTunes streaming is not working. I saw an earlier comment that you can only have one or the other. Is that still the case?
 
Joined
Dec 14, 2016
Messages
309
Motherboard
Asus Prime z370 A-II
CPU
i9-9900K
Graphics
Radeon VII
Mac
MacBook Pro, Mac Pro
Mobile Phone
iOS
@ammulder it’s still a bit hit-or-miss but I was finally able to get hardware acceleration and DRM iTunes playback working at the same time. In my case, this guide helped— my IGPU and AMD card were not configured correctly. Note that DRM only works for downloaded content. I haven’t seen a streaming solution yet...but I think we’re getting closer.
 

ammulder

Moderator
Joined
Sep 1, 2014
Messages
3,466
Motherboard
GA-H87N-WIFI
CPU
i7-4790S
Graphics
GT 740
Mac
MacBook Pro, Mac mini
Mobile Phone
iOS
Sorry, just to confirm, downloaded iTunes movies play for me -- just streaming doesn't. So I have HEVC, H264, iTunes downloaded movies, but NOT iTunes streaming movies.
 
Joined
Dec 14, 2016
Messages
309
Motherboard
Asus Prime z370 A-II
CPU
i9-9900K
Graphics
Radeon VII
Mac
MacBook Pro, Mac Pro
Mobile Phone
iOS
Got it. Same issue. I can only get streaming to work by disabling IGPU. Been playing with this for over a year and haven't found the solution. My best guess is that it has to do with the Shiki value and which decoder processes the live stream.

I finally bought a big hard drive and just downloaded everything. It was faster than trying to constantly reconfigure and test my system (often breaking something else in the process). But would love to find the answer.
 
Joined
Feb 10, 2012
Messages
58
Motherboard
GB Z370-HD3P
CPU
i5 9600K
Graphics
RX 580
Mac
MacBook Pro
Classic Mac
512K
Mobile Phone
iOS
So I've got a Sapphire Pulse RX 580 in 10.14.2 and I've got HEVC/H264 acceleration working (with iGPU enabled), but iTunes streaming is not working. I saw an earlier comment that you can only have one or the other. Is that still the case?
Same card here. Do you mind sharing your setup?
 
Joined
Jan 21, 2019
Messages
2
Motherboard
GIGABYTE GAH110MA 1151 MATX
CPU
i5 6500
Graphics
Quadro k4000 and (Intel HD 530 not enabled)
Mac
iMac
Mobile Phone
iOS
I just finished my first build and run into this problem too. I have the same issue described for iTunes and being unable to stream Netflix or Hulu on safari. I currently run Mojave.
 
Joined
Jan 1, 2019
Messages
1
Motherboard
Asus P-370
CPU
Core i7-8800k
Graphics
Geforce 1080
Hi, I've got a nVidia GTX 1080, and all is working fine with my Hackintosh (High Sierra 10.6.13).

The only noticed issue is that I can't play any iTunes movie/video...

I read that is might be because it does not properly recognize my GPU/screen... Stuff about HDCP protection ?

Can anybody explain how to make this work ? I've already put these files in my EFI/CLOVER/kexts/Other folder :
  1. dummy141.kext
  2. Lilu.kext
  3. Lilu.kext.dSYM
  4. Shiki.kext
  5. Shiki.kext.dSYM
  6. WhateverGreen.kext
  7. WhateverGreen.kext.dSYM
  8. WhateverName.app
Thanks in advance for your help !

Regards,

Antoine
 
Top