Contribute
Register

ITunes on Lion 10.7.2 - Causing Mouse to Stutter/Lag

Status
Not open for further replies.
Joined
Jan 9, 2011
Messages
190
Motherboard
Asus Sabertooth X79
CPU
i7-3960
Graphics
NVIDIA GeForce GTX 1060 3GB
Mac
  1. MacBook Pro
  2. Mac Pro
Anyone else having any funny mouse behavior when iTunes is running on Lion?

I am running 10.7.2 with iTunes 10.5.1 and when ITunes is running, the mouse sticks/freezes every few seconds and it happens all the time that iTunes is running. The moment I kill iTunes it stops doing that.

I am running a Unibeast install and the only drivers I loaded was the Audio for my board and the Network driver. I never loaded a driver for my 9800gt as it was detected perfectly by Lion.

Anyone have any ideas what could be causing this?? It's really annoying and makes iTunes unusable.
 
Joined
Jan 9, 2011
Messages
190
Motherboard
Asus Sabertooth X79
CPU
i7-3960
Graphics
NVIDIA GeForce GTX 1060 3GB
Mac
  1. MacBook Pro
  2. Mac Pro
No uninstalling or changing Itunes versions fixed this but I eventually found the fix.

The problem is related to the kext "AppleUpstreamUserClient.kxt" I only found this out after a LOT of Googling.

The trick is to rename the kext and repair permissions and voila, no more skipping mouse.

To rename:
----------------

cd /System/Library/Extensions/
sudo mv AppleUpstreamUserClient.kext AppleUpstreamUserClient.kext.old
 
Joined
May 22, 2011
Messages
12
Mac
Classic Mac
Mobile Phone
Solved! Thank you!

This fixes the mouse stutter/jump every couple seconds I was having in OS X 10.7.2.
 
Joined
Dec 25, 2010
Messages
81
Motherboard
x58 ud3r
CPU
i7 950
Graphics
Nvidia GTX 670
Mac
Classic Mac
Mobile Phone
How do you uninstall iTunes? when I try it says it is needed for OSX to work. My issue is every time I try to run iTunes I get a KP. Removing the AppleUpstreamUserClient.kext din't solve my issue.
 
Joined
Dec 25, 2010
Messages
81
Motherboard
x58 ud3r
CPU
i7 950
Graphics
Nvidia GTX 670
Mac
Classic Mac
Mobile Phone
After removing the AppleUpstreamUserClient.kext I was able to install the latest version of iTunes. So far everything is working fine with no KP.
 
Joined
Jan 9, 2011
Messages
190
Motherboard
Asus Sabertooth X79
CPU
i7-3960
Graphics
NVIDIA GeForce GTX 1060 3GB
Mac
  1. MacBook Pro
  2. Mac Pro
gbsnplr said:
After removing the AppleUpstreamUserClient.kext I was able to install the latest version of iTunes. So far everything is working fine with no KP.

Great, glad you got it working. That AppleUpstreamUserClient.kext is a problematic kext of note. Be sure to remove/rename it again every time you update the OS.
 
Joined
Apr 20, 2012
Messages
99
Motherboard
Dell Latitude E6530
CPU
i5-3320M
Graphics
HD 4000
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Works for me :headbang: :headbang:
thanks guys :thumbup:
 
Joined
Dec 29, 2010
Messages
2
Motherboard
Mountain Lion
CPU
Core i7
Graphics
ATI Radeon 6850
Mac
Classic Mac
Mobile Phone
Finally
Works for me too
thanks a lot

Mac OS X 10.7.4
iTunes 10.6
Asus P7h55M LX
Video GeForce 550Ti
 
Status
Not open for further replies.
Top