Contribute
Register

Is a 771 xeon on 775 mobo compatible with hackintosh ?

Joined
Aug 10, 2016
Messages
1
Hello,

I'm a noob at hackintosh but recently I wanted to do CAM on mac softwares so I inquired to build a hackintosh with parts I already have. Here are my actual specs :

Motherboard : ASUS P5KPL/1600 (Socket 775)
CPU : Intel Core 2 Duo E6550 2.33 GHz
RAM : 4 GB DDR2
GPU : ASUS GeForce 8600GT
OS : OS X El Capitan

I plan to buy a Xeon E5440 which is much better that my Core 2 Duo but requires a mod on the cpu and flashed bios because it's a socket 771 CPU. Will the Hackintosh run with this CPU ?
 
Joined
Jun 8, 2013
Messages
4
Motherboard
P5Q-EM
CPU
Xeon L5420 4-cores
Graphics
GeForce 8400 GS (GT218)
Mac
  1. MacBook
  2. MacBook Air
Mobile Phone
  1. iOS
Hi,

Just converted my old p5q-em board to work with a used xeon L5420 using the strip. (LGA 771 to 775 Adapter (MOD) - Run faster Xeon CPUs in a Core 2 ...) Added the microcode as per the instructions on the site. I got rid of the BIOS POST warning about the CPU not "unleashed"...

With my trusty GeForce 8400 GS (works with simple clover Nvidia injection), my new setup (using latest clover with fakesmc) boots both vanilla macOS sierra install disk and my regular Yosemite install. Problem is, the boot console (boot-args=-v) freezes a bit after fakeSMC and appleRTC (changes from boot to boot). No graphics come on, but the system is alive underneath!

I can ssh into it and see using htop that the WindowServer process is taking 100% of one core. I tried different clover options around SSDT dropping, C2 C4 enabling, the native vs nvidiaWeb drivers to no avail.

I will try to fool around with BIOS settings for VT-d and speed step, etc. Will report back.
 
Joined
Jun 9, 2013
Messages
10,781
Motherboard
Gigabyte GA-H77N-WIFI
CPU
i7-3770
Graphics
HD 4000
Mac
  1. MacBook
  2. Mac mini
Mobile Phone
  1. Android
Hello,

I'm a noob at hackintosh but recently I wanted to do CAM on mac softwares so I inquired to build a hackintosh with parts I already have. Here are my actual specs :

Motherboard : ASUS P5KPL/1600 (Socket 775)
CPU : Intel Core 2 Duo E6550 2.33 GHz
RAM : 4 GB DDR2
GPU : ASUS GeForce 8600GT
OS : OS X El Capitan

I plan to buy a Xeon E5440 which is much better that my Core 2 Duo but requires a mod on the cpu and flashed bios because it's a socket 771 CPU. Will the Hackintosh run with this CPU ?

Not with stock BIOS no. Will required a modded BIOS with different CPU Microcode. You will find guides on Google showing you how to do it.
 
Joined
Jun 8, 2013
Messages
4
Motherboard
P5Q-EM
CPU
Xeon L5420 4-cores
Graphics
GeForce 8400 GS (GT218)
Mac
  1. MacBook
  2. MacBook Air
Mobile Phone
  1. iOS
SUCCESS!!!!

I left all of the CPU features enabled in the bios (VT-d, speedstep, etc.). The thing that fixed my video freeze problem was npci=0x3000 added to the clover boot arguments!

At aboot 20$ Canadian, it's like I have doubled the CPU count in my rig.

FYI, I used the MMTool.exe from the above guide. I ran the tool inside Wineskin winery on my mac, no need to install or use windoes. Pretty much any wine method should work (playonmac, straight cmd line wine installed from "brew install wine"). Just format a usb stick with MBR and a msdos partition, copy the new BIOS.rom file to it, in the BIOS, use ezflash 2 menu, burn, voilà!

With SSE4.1, I am now looking forward to Sierra update...

Good luck!
 

Attachments

  • L5420 on Yosemite.png
    L5420 on Yosemite.png
    62.8 KB · Views: 957
Joined
Dec 28, 2013
Messages
3
Mac
Classic Mac
Mobile Phone
SUCCESS!!!!

I left all of the CPU features enabled in the bios (VT-d, speedstep, etc.). The thing that fixed my video freeze problem was npci=0x3000 added to the clover boot arguments!

At aboot 20$ Canadian, it's like I have doubled the CPU count in my rig.

FYI, I used the MMTool.exe from the above guide. I ran the tool inside Wineskin winery on my mac, no need to install or use windoes. Pretty much any wine method should work (playonmac, straight cmd line wine installed from "brew install wine"). Just format a usb stick with MBR and a msdos partition, copy the new BIOS.rom file to it, in the BIOS, use ezflash 2 menu, burn, voilà!

With SSE4.1, I am now looking forward to Sierra update...

Good luck!

Dude! I am so glad I found this comment. Just done the 771 mod and couldn't figure out why I saw no video. Thank you so much npci=0x3000 did the trick. Saved me a ton of headaches.
 
Top