Contribute
Register

Intel NUC8i7HVK ALC700 dumps.

toleda

Moderator
Joined
May 20, 2010
Messages
24,236
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
512K, LC, Power Mac
Mobile Phone
iOS
found the only problem comes from Windows, re-installed, got the audio-jack working after Windows
Windows/Sound or Realtek driver?
Attach Windows supported audio devices screenshot
Cold boot (shutdown, pull power, hold power button in for 30 seconds, restore power)
Restart macOS
Reply with new IOReg and Terminal output
 
Joined
Jan 4, 2019
Messages
34
Motherboard
Nuc8i7hnk
CPU
i7-8705G
Graphics
Vega M GL 20
Mac
MacBook Pro
Mobile Phone
iOS
Windows/Sound or Realtek driver?
Attach Windows supported audio devices screenshot
Confirmed, Audio Jack front & rear works right after installing Windows, even without any external driver installed.
Front headphone jack can only act as LineOut, no difference or any Line In function when connecting to L+R+Mic connector.


Somehow, Realtek driver provided by Intel & the version I used to install are either NOT able to install at all, with error in driver installation phase during installation of the Realtek driver set.
after some googling, there is no clue so far. error -0001, seemed like a "Generic Error".


4 Images are attached
Device manager: explanation: top to bot, 1 Speaker & 2 Microphones
Device manager.jpeg
ACPI tree View in Device Manager:
ACPI view.jpeg

Settings: Input, 2 microphones already, without any external connection.
Input setting.jpeg
Settings: Output connected with either rear or front, only one speaker device here.
output setting.jpeg


Cold boot (shutdown, pull power, hold power button in for 30 seconds, restore power)
Restart macOS
Reply with new IOReg and Terminal output
attached with IOReg & output
 

Attachments

toleda

Moderator
Joined
May 20, 2010
Messages
24,236
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
512K, LC, Power Mac
Mobile Phone
iOS
Confirmed, Audio Jack front & rear works right after installing Windows
Disagree, Device Manager does not show front audio port working; no headphone mic or speaker. Device Manager does not show Optical on rear audio port. By the way, Tweaktown says the NUC has 4 microphones on the front panel panel.

Attach Control Panel/Hardware and Sound/Sound/Playback and Recording screenshots
May have to right click for Show Disconnected Devices
 
Joined
Jan 4, 2019
Messages
34
Motherboard
Nuc8i7hnk
CPU
i7-8705G
Graphics
Vega M GL 20
Mac
MacBook Pro
Mobile Phone
iOS
Disagree, Device Manager does not show front audio port working; no headphone mic or speaker. Device Manager does not show Optical on rear audio port. By the way, Tweaktown says the NUC has 4 microphones on the front panel panel.

Attach Control Panel/Hardware and Sound/Sound/Playback and Recording screenshots
May have to right click for Show Disconnected Devices
Well, first answering the question:

Playback: Same setup, 6 HDMI, Only 1 Speaker (item 2nd). How it acts, is either plug in front or back, there's ONLY ONE jack outputs audio, and front audio jack has higher priority. And it's not telling me "whether front or rear is plugged", but only a "plugged in or not" indicator.
Playback.PNG

Record: How it works, is only 2 microphones. according to the test to these microphones, I'll have a conclusion attached below. And by inserting a L+R+Mic earphone, no audio-in showed up here.
Record.PNG

Tweaktown says the NUC has 4 microphones on the front panel panel.
This is showed in #59, page 6, and I did some actual testing:
IMG_3343.jpeg
By blocking the hole of each microphone pieces and monitoring from output, I found that that's actually Mic1(Mic-L,Mic-R),Mic2(Mic-L,Mic-R). A layout like this:
IMG_3311.jpeg
The number mic1 / mic2 is not relevant with the node or anything "hardware perspective".

SPDIF seemed not working right after the Windows installation, but no drivers can be installed since Realtek driver fails itself from #82. I don't know why.
Somehow, Realtek driver provided by Intel & the version I used to install are either NOT able to install at all, with error in driver installation phase during installation of the Realtek driver set.
after some googling, there is no clue so far. error -0001, seemed like a "Generic Error".
I'm sure the "Show disabled / Not connected device" are both selected.

Additionally:

Disagree, Device Manager does not show front audio port working; no headphone mic or speaker.
I am attaching some Device Manager with different scenario:
No Jack is plugged:
Rear jack out.PNG
Front Jack's plugged
front jack in.PNG
Rear jack's plugged:
Rear jack in.PNG
Both jacks' plugged, only front has sound:
Both in, only Front sound.PNG

The sound output switching between each scenarios when I do these plugging & unplugging thing is instant.
 
Last edited:

toleda

Moderator
Joined
May 20, 2010
Messages
24,236
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
512K, LC, Power Mac
Mobile Phone
iOS
Playback: Same setup, 6 HDMI, Only 1 Speaker
NUC8i7HVK/ALC700 does not support the audio devices noted:
Intel® NUC Kit NUC8i7HVK
394366

Intel fail
Google: NUC8i7HVK audio problems
Windows: no analog audio, no TOSLINK, no HDMI audio; no solution, 9 months
Likely, macOS/HDMI audio working
 
Joined
Jan 4, 2019
Messages
34
Motherboard
Nuc8i7hnk
CPU
i7-8705G
Graphics
Vega M GL 20
Mac
MacBook Pro
Mobile Phone
iOS
NUC8i7HVK/ALC700 does not support the audio devices noted:
Intel® NUC Kit NUC8i7HVK
View attachment 394366
Intel fail
Google: NUC8i7HVK audio problems
Windows: no analog audio, no TOSLINK, no HDMI audio; no solution, 9 months
Likely, macOS/HDMI audio working
Yes, and I think that’s the end now.
As long as HDMI audio and VoodooHDA for rear jack is working now, there’s no need to rush for the AppleALC until Intel solve this problem and it’s quite not stable during the process (Realtek failed too). I’m staying tuned into the BIOS Updates.

Sincerely, Thank you.
Intel fails ;)
 

toleda

Moderator
Joined
May 20, 2010
Messages
24,236
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
512K, LC, Power Mac
Mobile Phone
iOS
Bad news.
Google: NUC8i7HVK audio problems
Serious audio problems, no NUC HDMI, SPDIF, Line out audio
Codec dump shows the codec is not configured to support the available audio devices in Windows or Linux; L + R + mic (F) or L + R (R)
The current macOS solution only supports HDMI and SPDIF digital audio
User lmshsqlc has a front line out working with Voodoo
Check for latest BIOS, attach codec dump
Otherwise, contact Intel
 
Joined
Jan 4, 2019
Messages
34
Motherboard
Nuc8i7hnk
CPU
i7-8705G
Graphics
Vega M GL 20
Mac
MacBook Pro
Mobile Phone
iOS
Bad news.
Google: NUC8i7HVK audio problems
Serious audio problems, no NUC HDMI, SPDIF, Line out audio
Codec dump shows the codec is not configured to support the available audio devices in Windows or Linux; L + R + mic (F) or L + R (R)
The current macOS solution only supports HDMI and SPDIF digital audio
User lmshsqlc has a front line out working with Voodoo
Check for latest BIOS, attach codec dump
Otherwise, contact Intel
Correction: the VoodooHDA working Jack is rear jack.

There's no BIOS update relevant to Audio problems since the beginning of the problem reported in Google. And however, some problems constantly happen in this model NUC8I7HNK. I don't know if there're any other model using ALC700, dump and configure on their device should be well appreciated to the codec I think.

And update:
VoodooHDA 2.9.1 is STOPPING hackintosh from booting in macOS 10.14.4



Now I'm deaf without bluetooth headphone lol
awaiting for VoodooHDA.

And an interesting discovery:
the clover bootloader has a boot sound feature, and can detect the outputs
It detected the 6 HDMI outputs and rear jack as well as the front jack, which they're marked as "Realtek"
Once I turned on the test sound, rear is output normally, but when I selected front jack(not even test output), it freezed.
well I don't know whether we should continue or not.
But I'll write it down for people coming after can see this.
 
Last edited:
Top