Contribute
Register

[initial success] Skull Canyon NUC

Status
Not open for further replies.
Joined
Aug 20, 2010
Messages
100
Motherboard
Z370N
CPU
i7-8700K
Graphics
RX 580
just got 10.11.5 installed on a Skull Canyon NUC and wanted to share notes in case anyone was trying with their new NUCs as well.

- Clover 3526
- used BIOS and most config settings from skylake NUC guide
- "Couldn't allocate runtime area" memory errors prevented booting - aptio fix 1 and 2 and lowmem didnt work (OsxAptioFix2Drv worked once, the first time, but never again)
- had to use a modified aptiofix with the -2000 fix created by users with x99 boards with mem map issues caused by PCI devices.
thanks to users nick woodhams and h4v in SourceForge tickets discussion for Clover. I asked h4v if I could share his modified aptiofix here. EDIT: thx h4v, attached the file here and here is the link to the sourceforge ticket:
https://sourceforge.net/p/cloverefiboot/tickets/125/#c28a/ae73
- also removed all kexts to lower memory requirements just in case - only fakesmc
- success! but after that stuck at 'still waiting for root device'
- unplugged all USBs and tried each port, only the yellow plug in front worked
tried "cpus=1" just in case but didn't seem to matter


So got OSX installed and the system seems to be working fine so far. Havent done much further testing yet, plan on doing SSDT for cpu and seeing if any other patches needed, will update this thread with any news. Any other Skull Canyon NUC early adopters please join in until we can get a proper guide going! :)

Update 1: looks like theres still some boot issues as I was unable to boot again... but a few hours later was able to get in. installed ethernet kexts and did some Geekbench runs. Everything working great so far... besides the random booting.... :-D

NOTE: Geekbench scores are WITHOUT turbo boost. still haven't had time to try to get a proper SSDT for the cpu yet.
 

Attachments

  • skullcanyonnuc.png
    skullcanyonnuc.png
    143.4 KB · Views: 514
  • OsxAptioFix2Drv-free2000.efi.zip
    8.5 KB · Views: 65
Last edited:
Joined
Nov 30, 2015
Messages
17
Motherboard
NUC7i7
CPU
i7-7567U
Graphics
Iris Plus 650
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Thanks for the info, _mikey! I'm currently saving my pennies for the Skull Canyon NUC but your initial success has encouraged me to, ah, bend the rules ASAP. I hope to join you soon!
 
Joined
Nov 26, 2012
Messages
91
Motherboard
Intel NUC6I7KYK Skull Canyon
CPU
Intel® Core™ i7 6770HQ
Graphics
Intel Iris Pro Graphics 580
Mac
  1. MacBook Pro
Classic Mac
  1. iMac
Mobile Phone
  1. iOS
Well, I jumped in yesterday being partly successful. I got through the installation somehow and ran MultiBeast and got the Edimax AC-1200 working as well for WIFI. Now I'm not sure what's next. I think there should be some more tweaks to be done for a fully working system. I can only boot with ignore caches and kexts for now. Also it only seems to recognize half of my 16GB RAM (single slot because I intend to install another 16 later). Couldn't get Bluetooth working either yet. I left the internal one on in the BIOS and also plugged in a belkin USB BT dongle that uses a Broadcom chip. I think I'll disable the on-board BT and see if the Belkin works then. Also I downloaded Clover Configurator but didn't do anything with it yet because I'm not sure what to try. Also I have no idea about SSDT and if I need to do something with it...
Anyways, here's what I selected in MultiBeast:
Quick Start > UEFI Boot Mode
Drivers > Misc > FakeSMC v6.18-313-g671f31c.1707
Drivers > Misc > FakeSMC HWMonitor Application v6.18-313-g671f31c.1707
Drivers > Network > Intel > IntelMausiEthernet v2.1.0d3
Drivers > USB > 3rd Party USB 3.0
Bootloaders > Clover v2.3k r3423 UEFI Boot Mode
Customize > System Definitions > iMac > iMac 17,1

Anything wrong with that? What about audio? Voodoo?
Any guidance much appreciated!
 
Last edited:
Joined
Nov 26, 2012
Messages
91
Motherboard
Intel NUC6I7KYK Skull Canyon
CPU
Intel® Core™ i7 6770HQ
Graphics
Intel Iris Pro Graphics 580
Mac
  1. MacBook Pro
Classic Mac
  1. iMac
Mobile Phone
  1. iOS
Updated clover in clover configurator and I can boot normally. Also got bluetooth working with the belkin and 16GB Ram showing up correctly. It says 3.91 GHz i7, though, which is weird. And there are some graphical glitches here and there. Haven't done anything in clover configurator other than updating clover yet. Will try more things tomorrow. But it's nice to see some progress :). Crossing fingers for a proper guide to appear around here soon.
 
Joined
Aug 20, 2010
Messages
100
Motherboard
Z370N
CPU
i7-8700K
Graphics
RX 580
cool! glad to see someone else jump in.

1) you dont have the memory issues on boot? I get them sometimes, even with the aptiodrv 2000 fix. I found that holding down the power for 6 seconds (from the spec sheet) to do a hard shutoff seems to help it boot the next time.

2) dont think you need that USB kext, my usb3 ports all work OOB. My only kexts are ethernet and fakeSMC

3) latest clover should detect RAM just fine. set Trust = true in your config file, and dont set any RAM specs

4) not sure about audio, i plugged in a USB dongle. Skylake nucs dont have an HDMI audio patch yet either so I think we have to wait.

5) for graphics, i injected one of the id's for the iris 580, I used 0x1930005 and it seems to work fine, no glitches (a minor glitch right after boot but thats it). Also, latest Clover will show proper name for all newest intel graphics including our 580 (GT4 i think) in About This Mac

6) yes we need a SSDT, my CPU doesnt turbo. max 2.6. I tried to run pikerAlpha's ssdtPRGen but it didnt seem to work... i didnt see 6770HQ in the code so we might need to feed it specs manually... don't know for sure, havent had much time to play with the nuc lately.
 
Joined
Nov 26, 2012
Messages
91
Motherboard
Intel NUC6I7KYK Skull Canyon
CPU
Intel® Core™ i7 6770HQ
Graphics
Intel Iris Pro Graphics 580
Mac
  1. MacBook Pro
Classic Mac
  1. iMac
Mobile Phone
  1. iOS
So I tried a couple of things. I bought a windows 10 license and tried to install it to a partition of the same drive. I ended up wiping the mac install accidentally with some windows utility and had a terrible experience trying to get windows to install at all. It took about 20 tries until I finally got through the install without getting stuck. And then the nuc would keep locking up completely randomly no matter which drivers I added. I gave up on the windows partition for now and reformatted the drive to hfs+ for a new try with unibeast. Before installing I updated the BIOS to the latest version and set it back to the recommended settings for hackintoshing. Then I found RehabMan posted a new nuc guide which I tried to follow to the letter, although I had already installed with unibeast. It went pretty well but there also pikerAlpha's ssdtPRGen didn't work for me and I have yet to edit config.plist and SMBIOS. But things look pretty good so far. And I can boot normally now.
 
Joined
Feb 3, 2011
Messages
3
Mac
Classic Mac
Mobile Phone
I try to pass through initial installation screen but the video will go black and never comes back. Can anyone of you do a step-by-step write up for the Skull Canyon. Appreciate it.
 
Joined
Nov 26, 2012
Messages
91
Motherboard
Intel NUC6I7KYK Skull Canyon
CPU
Intel® Core™ i7 6770HQ
Graphics
Intel Iris Pro Graphics 580
Mac
  1. MacBook Pro
Classic Mac
  1. iMac
Mobile Phone
  1. iOS
I try to pass through initial installation screen but the video will go black and never comes back. Can anyone of you do a step-by-step write up for the Skull Canyon. Appreciate it.
Sounds like you should change something in the bios and or try some boot flags.
 
Joined
Mar 26, 2011
Messages
77
Any updates on working guides for the Skull Canyon?
My parts will arrive next week, and can't wait to install El Capitan on this tiny beast.
 
Status
Not open for further replies.
Top