Contribute
Register

How to fix Aquantia 10 Gb Ethernet for Big Sur

Joined
Mar 19, 2021
Messages
10
Motherboard
Asus x570 Tuf Gaming-Pro (Wifi)
CPU
Ryzen 7 5800x
Graphics
Rx 570
Mac
  1. Mac Pro
Mobile Phone
  1. Android
Hi all. Im new to hackintosh and as my first hackintosh i purchased the wrong MB. Anyway I went out and bought this card Asus XG-C100F card. I have the patch in but it still is not working. I am using my cell phone for internet. Can someone offer assistance please.
 

Attachments

  • Screen Shot 2021-05-17 at 1.59.18 PM.png
    Screen Shot 2021-05-17 at 1.59.18 PM.png
    438.7 KB · Views: 72
  • Screen Shot 2021-05-17 at 2.00.45 PM.png
    Screen Shot 2021-05-17 at 2.00.45 PM.png
    164.7 KB · Views: 71
  • Screen Shot 2021-05-17 at 2.00.16 PM.png
    Screen Shot 2021-05-17 at 2.00.16 PM.png
    105.7 KB · Views: 71
Joined
Mar 19, 2021
Messages
10
Motherboard
Asus x570 Tuf Gaming-Pro (Wifi)
CPU
Ryzen 7 5800x
Graphics
Rx 570
Mac
  1. Mac Pro
Mobile Phone
  1. Android
0x00b1. Looks like it in the first pic. Is this correct?
 
Joined
Mar 19, 2021
Messages
10
Motherboard
Asus x570 Tuf Gaming-Pro (Wifi)
CPU
Ryzen 7 5800x
Graphics
Rx 570
Mac
  1. Mac Pro
Mobile Phone
  1. Android
Yeah absolute correct most of the people with the 100F have 0x00b1, that ID isn't default in the Aquantia kext, therefore is doesn't load the kext.
Thank you for the response. I guess I'll need to change the Device ID to 0x07b1?
 
Joined
Mar 19, 2021
Messages
10
Motherboard
Asus x570 Tuf Gaming-Pro (Wifi)
CPU
Ryzen 7 5800x
Graphics
Rx 570
Mac
  1. Mac Pro
Mobile Phone
  1. Android
I have it running now, but is long a dirty, and I have no idea if it durable because the patches and the SSDT aren't mine. I contact the developers and let you know
Ok sounds good. The patches are different than the one posted?
 
Joined
Oct 28, 2011
Messages
27
Motherboard
Z370 Aorus Gaming 5, F15b
CPU
i5-9600KF
Graphics
Radeon RX 580
Mac
  1. iMac
Mobile Phone
  1. Android
First OC-> ACPI put the SSDT-AQUANTIA.aml in it.
Add an entry in config.plist [Root] -> ACPI ->Add -> SSDT-AQUANTIA.aml (enabled yes )
( to load the driver)


Add an first entry [Root] -> Kernel -> Patch -> com.apple.driver.AppleEthernetAquantiaAqtion Find 81F9B107 0000
Replace 81F9B100 0000
(for the deviceID)

after that

Add an second entry [Root] -> Kernel -> Patch -> com.apple.driver.AppleEthernetAquantiaAqtion Find 0F84C002 0000
Replace 660F1F44 0000
(I have no clue because everybody does)

maybe a nvram clear (nvram -c)

Give it a try
 

Attachments

  • SSDT-AQUANTIA.aml
    578 bytes · Views: 64
Top