Contribute
Register

HID Proxy on Apple Adapters

Joined
Oct 16, 2020
Messages
120
Motherboard
Thinkpad T440P
CPU
i7-4710MQ
Graphics
HD 4600
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Hello everyone, this thread is regarding HID Proxy mode on genuine apple wifi adapters like BCM94360CS, BCM943602CS, and BCM94360CS2, there is also some other cards but i havnt tested them so i can't comment.

the below are my findings using a Lenovo ThinkPad T440P

BCM94360CS and BCM94360CS2 are 2x2 and 3x3 versions of the same card, they both support bluetooth 4.0 and have working HID proxy

the BCM943602CS is different, its only found in MacBookPro11,4 and MacBookPro11,5 and does not support standard HID proxy, or atleast in a way thats compatible with my T440P

also wanted to say the BCM94360CS and BCM943602CS are both 3x3 cards and require 1 antenna from the WWAN/LTE card, which will essentially make use of WWAN/LTE not possible or broken.

 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
25,246
Motherboard
Lenovo ThinkStation p700
CPU
2 X Xeon E5-2620 V3
Graphics
RX 560
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
 
Joined
Oct 16, 2020
Messages
120
Motherboard
Thinkpad T440P
CPU
i7-4710MQ
Graphics
HD 4600
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
yes, i understand, post is not regarding laptops, but wifi cards, which work in desktop, and laptop computers. therefor this post is appropriate, the same HID proxy issue will exist on desktop AFAIK or untill someone can show working HID proxy in BIOS/UEFI on BCM943602CS.
 
Last edited:
Joined
May 11, 2021
Messages
2
Motherboard
mother
CPU
intel core i7
Graphics
gtx 1080
Thank you so much for the video. This is what I need right now. I couldn't find a solution to my problem, but your video is like salvation. I liked that you showed everything quite briefly, but there was enough information. Why do you use this particular BCM94360CS board? I just set it up for myself proxies for chrome. And I'm new to this business, so I need all the help I can get. I try to configure these servers, but I can't. I don't know what the problem is. But I will try to set up a router for a proxy-based on your video. Thank you again for your help, and good luck!
 
Last edited:
Top