Contribute
Register

[Help] White Line after Lock

Status
Not open for further replies.
Joined
May 30, 2016
Messages
6
Motherboard
Ironman_SK
CPU
Intel i3-7100 Kaby Lake
Graphics
Intel HD 620
Mac
  1. Mac mini
Mobile Phone
  1. Android
Acer Aspire 35-575-33bm
i3-7100
Intel HD 620
1920x1080x24
MacOS High Sierra (with HFS+)

I've not been able to fix this problem yet, and it seems nobody else even has it to begin with (much searching has turned up empty). In a nutshell, my graphics work fine; Intel HD 620 is working with FakePCIID and a device patch in Clover. The problem is, whenever my device goes to the lock screen (from sleep or closing the lid), a white line just a single pixel tall appears on across the bottom of the screen, with no way to get rid of it. The actual screen resolution is unaffected, but the white line never goes away until I reboot. So far I've just been living with it, but it's something that I'm wanting to fix.

If anybody needs it, my clover folder is included (excluding HFSPlus.efi). Anybody have any idea what might be causing this?
 

Attachments

  • CLOVER.zip
    10.5 MB · Views: 36

Feartech

Moderator
Joined
Aug 3, 2013
Messages
23,354
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Acer Aspire 35-575-33bm
i3-7100
Intel HD 620
1920x1080x24
MacOS High Sierra (with HFS+)

I've not been able to fix this problem yet, and it seems nobody else even has it to begin with (much searching has turned up empty). In a nutshell, my graphics work fine; Intel HD 620 is working with FakePCIID and a device patch in Clover. The problem is, whenever my device goes to the lock screen (from sleep or closing the lid), a white line just a single pixel tall appears on across the bottom of the screen, with no way to get rid of it. The actual screen resolution is unaffected, but the white line never goes away until I reboot. So far I've just been living with it, but it's something that I'm wanting to fix.

If anybody needs it, my clover folder is included (excluding HFSPlus.efi). Anybody have any idea what might be causing this?
moved to laptop support
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,728
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Acer Aspire 35-575-33bm
i3-7100
Intel HD 620
1920x1080x24
MacOS High Sierra (with HFS+)

I've not been able to fix this problem yet, and it seems nobody else even has it to begin with (much searching has turned up empty). In a nutshell, my graphics work fine; Intel HD 620 is working with FakePCIID and a device patch in Clover. The problem is, whenever my device goes to the lock screen (from sleep or closing the lid), a white line just a single pixel tall appears on across the bottom of the screen, with no way to get rid of it. The actual screen resolution is unaffected, but the white line never goes away until I reboot. So far I've just been living with it, but it's something that I'm wanting to fix.

If anybody needs it, my clover folder is included (excluding HFSPlus.efi). Anybody have any idea what might be causing this?

"Problem Reporting" files are incomplete/wrong.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
 
Joined
Nov 12, 2017
Messages
2
I do also have this "white line" problem with my Acer Swift3
which is the newest Kaby Kake R platform,
graphic card is Intel UHD 620 0x59160000

I have success driven my UHD 620 with the native driver inside 10.13(by use modified FakePCIID_Intel_GPUXXX.kext),
but after I close the screen or goto sleep and turn it on, white line will appear to the bottom of my screen,
and if i move a window under this line, screen will flash... I'll upload my ioreg file next time...
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,728
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I do also have this "white line" problem with my Acer Swift3
which is the newest Kaby Kake R platform,
graphic card is Intel UHD 620 0x59160000

I have success driven my UHD 620 with the native driver inside 10.13(by use modified FakePCIID_Intel_GPUXXX.kext),
but after I close the screen or goto sleep and turn it on, white line will appear to the bottom of my screen,
and if i move a window under this line, screen will flash... I'll upload my ioreg file next time...

No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
 
Joined
Nov 12, 2017
Messages
2
Here is my ioreg dumped file
 

Attachments

  • Kavana-Swift.zip
    660.4 KB · Views: 32
Status
Not open for further replies.
Top