Contribute
Register

HD530 High Sierra, Quick sync enable?? possible??

Joined
Feb 9, 2012
Messages
298
Motherboard
Razer Blade Stealth
CPU
i7-8565U
Graphics
UHD 620, 1920 x 1080
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Hi,

I wonder there is possible way to enable HD530 Quick Sync.

I can see HD530 enabled in my system but it is black out when I connect to any monitor.

Please let me know.

Thanks!
 
Joined
Oct 26, 2013
Messages
1,021
Motherboard
MSI B250M PRO-VHD
CPU
i3-7100
Graphics
RX 570
Hi,

I wonder there is possible way to enable HD530 Quick Sync.

I can see HD530 enabled in my system but it is black out when I connect to any monitor.

Please let me know.

Thanks!
Yes, IQSV work very well with AMD GPU by using empty frame ig-platform-id, tested with Pentium base HD510/HD530/HD610 + HD5570/HD6450/HD7750/RX460, from 10.12.6, 10.13.0 beta 1 to 10.13.1 beta 1.

Currently have not success with NV GPU yet, failed with NV GT630/GT730 (Kepler base).

See below link
https://www.applelife.ru/threads/zavod-intel-quick-sync-video.817923/
 
Joined
Feb 9, 2012
Messages
298
Motherboard
Razer Blade Stealth
CPU
i7-8565U
Graphics
UHD 620, 1920 x 1080
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Yes, IQSV work very well with AMD GPU by using empty frame ig-platform-id, tested with Pentium base HD510/HD530/HD610 + HD5570/HD6450/HD7750/RX460, from 10.12.6, 10.13.0 beta 1 to 10.13.1 beta 1.

Currently have not success with NV GPU yet, failed with NV GT630/GT730 (Kepler base).

See below link
https://www.applelife.ru/threads/zavod-intel-quick-sync-video.817923/

Hey~

Thank you for your kind reply.

My Apple TV is able to be connected by HD530 and work well.

How I can know this IQSV working correctly?
 
Joined
Oct 26, 2013
Messages
1,021
Motherboard
MSI B250M PRO-VHD
CPU
i3-7100
Graphics
RX 570
Hey~

Thank you for your kind reply.

My Apple TV is able to be connected by HD530 and work well.

How I can know this IQSV working correctly?
Run VDADecoderCheckerSierra.

My terminal output is "offine Gen9", yours output should be "online Gen9" or only show
Hardware acceleration is fully supported

GVA info: Successfully connected to the Intel plugin, offline Gen9
Hardware acceleration is fully supported
 

Attachments

Last edited:
Joined
Feb 9, 2012
Messages
298
Motherboard
Razer Blade Stealth
CPU
i7-8565U
Graphics
UHD 620, 1920 x 1080
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Run VDADecoderCheckerSierra.

My terminal output is "offine Gen9", yours output should be "online Gen9" or only show
Hardware acceleration is fully supported

GVA info: Successfully connected to the Intel plugin, offline Gen9
Hardware acceleration is fully supported
Last login: Wed Oct 4 11:06:22 on console

Climbs-MacBook-Pro:~ hyunjong$ /Users/hyunjong/Downloads/VDADecoderCheckerSierra ; exit;

IOVARendererID property not found

VDADecoderCreate failed. err: -12473

An error was returned by the decoder layer. This may happen for example because of bitstream/data errors during a decode operation. This error may also be returned from VDADecoderCreate when hardware decoder resources are available on the system but currently in use by another process.

VDADecoderCreate failed. err: -12473

logout

Saving session...

...copying shared history...

...saving history...truncating history files...

...completed.


[Process completed]
 
Joined
Oct 26, 2013
Messages
1,021
Motherboard
MSI B250M PRO-VHD
CPU
i3-7100
Graphics
RX 570
An error was returned by the decoder layer. This may happen for example because of bitstream/data errors during a decode operation. This error may also be returned from VDADecoderCreate when hardware decoder resources are available on the system but currently in use by another process.

VDADecoderCreate failed. err: -12473
Hardware decoder does not work.

Seems to be IQSV video decoding surely not work with IGPU HD5xx/HD6xx + Nvidia GPU configuration. IQSV decode will work on Haswell/ Broadwell IGPU + Nvidia GPU configuration, will test it with Haswell G1840 + GT1 + NV GT730.

See bellow link for detail
https://www.applelife.ru/threads/zavod-intel-quick-sync-video.817923/page-68.

Attached png is Pentium G4400 + HD510 + HD6450, QuickTime video export (IQSV encoding).
 

Attachments

Joined
Oct 26, 2013
Messages
1,021
Motherboard
MSI B250M PRO-VHD
CPU
i3-7100
Graphics
RX 570
I can see HD530 enabled in my system but it is black out when I connect to any monitor.
Almost sure, IQSV is not support HD5xx/6xx + Nvidia GPU. It surely work with Haswell GT1/GT2 + Nvidia GPU, may be older IGPU also work.

Tested ok with Celeron G1840 + GT1 + NV GT730, passed VDADecoder check and HW decoder work correctly with QuickTime, iTune, IINA, VLC.

upload_2017-10-5_17-8-53.png
 

Attachments

Joined
May 22, 2011
Messages
133
Motherboard
ASUS ROG MAXIMUS VIII GENE LGA 1151 Intel Z170
CPU
Intel i7 6700
Graphics
MSI GTX 1070 Gaming X
Mobile Phone
iOS
Have almost successful Quicksync with HD 530 + Pascal GPU, going to test it in High Sierra too now, will write the procedure then.

Screen Shot 2017-10-04 at 11.13.06 PM.png
 
Joined
May 22, 2011
Messages
133
Motherboard
ASUS ROG MAXIMUS VIII GENE LGA 1151 Intel Z170
CPU
Intel i7 6700
Graphics
MSI GTX 1070 Gaming X
Mobile Phone
iOS
@buyjoey I have posted here, see if this method works for you:

So the latest Lilu 1.2.0 and its Plugins- Shiki & NvidiaGraphicsFixup allow Skylake/Kabylake + Pascal GPU get almost full acceleration, I tested with High bitrate mp4 video in Quicktime & desktop screen recording via QT. Both resulted in low cpu usage and using intel iGPU for decode/encode. According to Lilu developer, I should be getting a successful VDAchecker message, but I get this:
Code:
GVA info: Successfully connected to the Intel plugin, offline Gen9
AVDCreateGPUAccelerator: Error loading GPU renderer
VDADecoderCreate failed. err: -12473
An error was returned by the decoder layer. This may happen for example because of bitstream/data errors during a decode operation. This error may also be returned from VDADecoderCreate when hardware decoder resources are available on the system but currently in use by another process.
VDADecoderCreate failed. err: -12473
You guys can check that too if you getting proper HW decoding outside Quicktime. I am attaching a zip file with the latest kext as these were only available in source code, so I compiled them. Do remember to add shikigva=4 as custom boot flag in config.plist. Have Inject Intel=True and a connecter-less ig-platform id is used, for my HD 530, I had to use "0x19120001" and enabled it in BIOS as multi monitor with >=64mb DVMT preallocate memory.

Here are my results:

DECODING:

View attachment 283551

ENCODING:

View attachment 283552

Youtube in safari still shows VTDecoderXPCService, which I believe is used for CPU SW acceleration rather than HW. But usage is quite low there.
 
Top