Contribute
Register

[Guide] Lenovo Z50-70/Z40-70/G50-70/G40-70 using Clover UEFI

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,075
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
forgot about bootmgfw.efi rename that and now I'm able to load and boot from my HDD OSX. but lost Windows10 volume selector on clover screen at boot time
You should NOT be renaming bootmgfw.efi.
As per guide you should be using efibootmgr in Linux to add a UEFI entry for Clover and setting it as priority.

And if you did the rename, you probably did it wrong. Must be bootmgfw-orig.efi (no other name will work as other names are not recognized by Clover).
 
Joined
Mar 3, 2015
Messages
33
Motherboard
Lenovo Z50-70
CPU
i5-4510U
Graphics
GeForce 820M
Mobile Phone
Android, iOS
You should NOT be renaming bootmgfw.efi.
As per guide you should be using efibootmgr in Linux to add a UEFI entry for Clover and setting it as priority.

And if you did the rename, you probably did it wrong. Must be bootmgfw-orig.efi (no other name will work as other names are not recognized by Clover).

Yes I've renamed to "bootmgfw-orig.efi". but still windows volume selector not appear at clover screen. What should I attach here?
for more guidance? just clover directory of EFI or something else?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,075
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Yes I've renamed to "bootmgfw-orig.efi". but still windows volume selector not appear at clover screen. What should I attach here?
for more guidance? just clover directory of EFI or something else?
Attach EFI folder (without EFI/APPLE, without EFI/Clover/themes).
 
Joined
Nov 6, 2015
Messages
154
Mac
MacBook Air, MacBook Pro, Mac mini
Mobile Phone
iOS
Hi guys, anyone from you already updated to Mojave with this build? Would like to know your experience.
 
Joined
Jan 12, 2012
Messages
12
Motherboard
Gigabyte Z68XP-UD3, 32 GB, dual, 1066, 1200, 1300, 1333, 1600, 1800, 1866, 2133 MHz, DDR3, 1.5 V, In
CPU
Intel Core i7 BX80623I72600K - Procesador ( 3,4 GHz, caché de 8MB, zócalo LGA1155)
Graphics
Gigabyte GV-R687OC-1GD
Mac
MacBook Pro, Mac Pro
Classic Mac
iMac
Mobile Phone
Other
Hi there.

I have installed Mojave into my z50-70 from scratch.
I tried installed it with Win10 at he same HD before without success. But at the moment I used the hard drive with only 1 partitions all went smooth.

I had to add ApplePS2SmartTouchPad.kext using Kext_Utility.app.v2.6.6 as far as the touchpad was crazy. After this all is right. Keyboard is ok but some figures are missing. Not important things. Its weird but I have to press two times CAPLOCKS to change upper/low case and shift key is not working at all. Any ideas??

Mayor problem now is sound. Tried different method but nothing working... any ideas?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,075
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I had to add ApplePS2SmartTouchPad.kext using Kext_Utility.app.v2.6.6 as far as the touchpad was crazy. After this all is right. Keyboard is ok but some figures are missing. Not important things. Its weird but I have to press two times CAPLOCKS to change upper/low case and shift key is not working at all. Any ideas??
You should contact the author with the issues you have with the closed source (APSL violating) kext.

Mayor problem now is sound. Tried different method but nothing working... any ideas?
No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.
 
Joined
Jan 12, 2012
Messages
12
Motherboard
Gigabyte Z68XP-UD3, 32 GB, dual, 1066, 1200, 1300, 1333, 1600, 1800, 1866, 2133 MHz, DDR3, 1.5 V, In
CPU
Intel Core i7 BX80623I72600K - Procesador ( 3,4 GHz, caché de 8MB, zócalo LGA1155)
Graphics
Gigabyte GV-R687OC-1GD
Mac
MacBook Pro, Mac Pro
Classic Mac
iMac
Mobile Phone
Other
Hi RehabMan.

I used the black.dragon74's scripts to genere a bugs report. First time, sorry I'm not sure if this is the right text file to show:

Report generated using gen_debug ver4.3.1

ACPIPLAT LOG :-
14 2 0xffffff7f81ece000 0x9c000 0x9c000 com.apple.driver.AppleACPIPlatform (6.1) 4423FFAE-7525-3F74-9E9D-E87EF1D43627 <13 12 11 7 6 5 4 3 1>
END ACPIPLAT LOG.


APPLEINTELCPU LOG:-
END APPLEINTELCPU LOG.


APPLE LPC LOG:-
98 0 0xffffff7f81f8f000 0x3000 0x3000 com.apple.driver.AppleLPC (3.1) 2D0491D1-D130-346C-BCA3-BBC8A745FD00 <94 12 5 4 3>
END APPLE LPC LOG.


APPLE HDA LOG:-
108 0 0xffffff7f81d28000 0x1d000 0x1d000 com.apple.driver.AppleHDAController (282.10) 1E3D72E3-0918-39C4-B0E7-4561D7915236 <107 106 90 12 7 6 5 4 3 1>
END APPLE HDA LOG.


LS FOR APPLEHDA :-
ls: /System/Library/Extensions/AppleHDA.kext/Contents/Resources/*.zml*: No such file or directory
END LS FOR APPLEHDA.


PMSET DUMP :-
System-wide power settings:
Currently in use:
hibernatemode 3
lidwake 1
womp 1
networkoversleep 0
sleep 10 (sleep prevented by mds)
Sleep On Power Button 1
ttyskeepawake 1
hibernatefile /var/vm/sleepimage
disksleep 10
displaysleep 10
END DUMP FOR PMSET


PMSET ASSERTIONS DUMP :-
2018-12-02 22:21:53 +0100
Assertion status system-wide:
BackgroundTask 1
ApplePushServiceTask 0
UserIsActive 1
PreventUserIdleDisplaySleep 0
PreventSystemSleep 0
ExternalMedia 1
PreventUserIdleSystemSleep 0
NetworkClientActive 0
Listed by owning process:
pid 93(hidd): [0x0000002700098010] 00:00:09 UserIsActive named: "com.apple.iohideventsystem.queue.tickle.4294967902.3"
Timeout will fire in 591 secs Action=TimeoutActionRelease
pid 52(powerd): [0x0000001400088000] 00:01:17 ExternalMedia named: "com.apple.powermanagement.externalmediamounted"
pid 62(mds): [0x00000016000b8007] 00:01:15 BackgroundTask named: "com.apple.metadata.mds.power"
Kernel Assertions: 0x104=USB,MAGICWAKE
id=500 level=255 0x4=USB mod=01/01/1970, 01:00 description=com.apple.usb.externaldevice.1d100000 owner=IOUSBHostDevice
id=502 level=255 0x4=USB mod=01/01/1970, 01:00 description=com.apple.usb.externaldevice.14200000 owner=Flash Disk
id=503 level=255 0x4=USB mod=01/01/1970, 01:00 description=com.apple.usb.externaldevice.14400000 owner=USB2.0-CRW
id=504 level=255 0x4=USB mod=01/01/1970, 01:00 description=com.apple.usb.externaldevice.14500000 owner=Lenovo EasyCamera
id=505 level=255 0x100=MAGICWAKE mod=01/01/1970, 01:00 description=en0 owner=en0
Idle sleep preventers: IODisplayWrangler
System sleep preventers: .Display_boot
END DUMP FOR PMSET ASSERTIONS.


DUMP FOR TRIM STATUS :-
END DUMP FOR TRIM STATUS.
 
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,075
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hi RehabMan.

I used the black.dragon74's scripts to genere a bugs report. First time, sorry I'm not sure if this is the right text file to show:

Report generated using gen_debug ver4.3.1

ACPIPLAT LOG :-
14 2 0xffffff7f81ece000 0x9c000 0x9c000 com.apple.driver.AppleACPIPlatform (6.1) 4423FFAE-7525-3F74-9E9D-E87EF1D43627 <13 12 11 7 6 5 4 3 1>
END ACPIPLAT LOG.


APPLEINTELCPU LOG:-
END APPLEINTELCPU LOG.


APPLE LPC LOG:-
98 0 0xffffff7f81f8f000 0x3000 0x3000 com.apple.driver.AppleLPC (3.1) 2D0491D1-D130-346C-BCA3-BBC8A745FD00 <94 12 5 4 3>
END APPLE LPC LOG.


APPLE HDA LOG:-
108 0 0xffffff7f81d28000 0x1d000 0x1d000 com.apple.driver.AppleHDAController (282.10) 1E3D72E3-0918-39C4-B0E7-4561D7915236 <107 106 90 12 7 6 5 4 3 1>
END APPLE HDA LOG.


LS FOR APPLEHDA :-
ls: /System/Library/Extensions/AppleHDA.kext/Contents/Resources/*.zml*: No such file or directory
END LS FOR APPLEHDA.


PMSET DUMP :-
System-wide power settings:
Currently in use:
hibernatemode 3
lidwake 1
womp 1
networkoversleep 0
sleep 10 (sleep prevented by mds)
Sleep On Power Button 1
ttyskeepawake 1
hibernatefile /var/vm/sleepimage
disksleep 10
displaysleep 10
END DUMP FOR PMSET


PMSET ASSERTIONS DUMP :-
2018-12-02 22:21:53 +0100
Assertion status system-wide:
BackgroundTask 1
ApplePushServiceTask 0
UserIsActive 1
PreventUserIdleDisplaySleep 0
PreventSystemSleep 0
ExternalMedia 1
PreventUserIdleSystemSleep 0
NetworkClientActive 0
Listed by owning process:
pid 93(hidd): [0x0000002700098010] 00:00:09 UserIsActive named: "com.apple.iohideventsystem.queue.tickle.4294967902.3"
Timeout will fire in 591 secs Action=TimeoutActionRelease
pid 52(powerd): [0x0000001400088000] 00:01:17 ExternalMedia named: "com.apple.powermanagement.externalmediamounted"
pid 62(mds): [0x00000016000b8007] 00:01:15 BackgroundTask named: "com.apple.metadata.mds.power"
Kernel Assertions: 0x104=USB,MAGICWAKE
id=500 level=255 0x4=USB mod=01/01/1970, 01:00 description=com.apple.usb.externaldevice.1d100000 owner=IOUSBHostDevice
id=502 level=255 0x4=USB mod=01/01/1970, 01:00 description=com.apple.usb.externaldevice.14200000 owner=Flash Disk
id=503 level=255 0x4=USB mod=01/01/1970, 01:00 description=com.apple.usb.externaldevice.14400000 owner=USB2.0-CRW
id=504 level=255 0x4=USB mod=01/01/1970, 01:00 description=com.apple.usb.externaldevice.14500000 owner=Lenovo EasyCamera
id=505 level=255 0x100=MAGICWAKE mod=01/01/1970, 01:00 description=en0 owner=en0
Idle sleep preventers: IODisplayWrangler
System sleep preventers: .Display_boot
END DUMP FOR PMSET ASSERTIONS.


DUMP FOR TRIM STATUS :-
END DUMP FOR TRIM STATUS.
You must upload the resulting ZIP.
 
Joined
Jan 12, 2012
Messages
12
Motherboard
Gigabyte Z68XP-UD3, 32 GB, dual, 1066, 1200, 1300, 1333, 1600, 1800, 1866, 2133 MHz, DDR3, 1.5 V, In
CPU
Intel Core i7 BX80623I72600K - Procesador ( 3,4 GHz, caché de 8MB, zócalo LGA1155)
Graphics
Gigabyte GV-R687OC-1GD
Mac
MacBook Pro, Mac Pro
Classic Mac
iMac
Mobile Phone
Other
Done!!!
 

Attachments

Top