Contribute
Register

[Guide] Lenovo Z50-70/Z40-70/G50-70/G40-70 using Clover UEFI

the-braveknight

Moderator
Joined
Nov 24, 2015
Messages
1,244
Motherboard
Lenovo Legion Y520 (Clover)
CPU
i7-7700HQ
Graphics
HD 630 (1920x1080) + Nvidia GTX 1060
Mac
MacBook Air
Mobile Phone
iOS
is there any solution for elan trackpad?
For now, you’re stuck with ApplePS2SmartTouchPad.kext, you can use google to look for it.
 
Last edited:
Joined
Mar 18, 2011
Messages
441
Motherboard
HP ProBook 4530s
CPU
2.20 GHz Intel Core i7-2720QM
Graphics
Intel HD Graphics 3000
Mobile Phone
Hello. I am thinking about updating my G50 to Mohave. Any advice? Should I update Clover first and the config.plist as well? Any other suggestion?
 
Joined
Mar 3, 2015
Messages
33
Motherboard
Lenovo Z50-70
CPU
i5-4510U
Graphics
GeForce 820M
Mobile Phone
Android, iOS
I've tried to install Mojave on my Z50-70 which has ELAN trackpad.
Successfully boot from USB and tried to install, but after that system restarted and then I tried to boot from USB and install from HDD, but only Apple symbol appear nothing more then that, no any progress bar
Here I'm attaching clover.zip file without theme directory. And Also photo of verbose mode of booting
Please help me.
 

Attachments

Last edited:
Joined
Dec 31, 2017
Messages
7
I've tried to install Mojave on my Z50-70 which has ELAN trackpad.
Successfully boot from USB and tried to install, but after that system restarted and then I tried to boot from USB and install from HDD, but only Apple symbol appear nothing more then that, no any progress bar
Here I'm attaching clover.zip file without theme directory. And Also photo of verbose mode of booting
Please help me.
Oh, that happens to me literally every time I boot now. I have to boot off the preboot volume, have it fail, and then boot off the normal volume. Very annoying.

The install was tricky, as you only have a short time to choose the correct clover volume after the first reboot. Keep choosing the boot mac os install volume until it disappears.
 
Joined
Mar 3, 2015
Messages
33
Motherboard
Lenovo Z50-70
CPU
i5-4510U
Graphics
GeForce 820M
Mobile Phone
Android, iOS
Oh, that happens to me literally every time I boot now. I have to boot off the preboot volume, have it fail, and then boot off the normal volume. Very annoying.

The install was tricky, as you only have a short time to choose the correct clover volume after the first reboot. Keep choosing the boot mac os install volume until it disappears.
Yes, Now it is not appearing in choose section, What should I do next?
I tried to boot from and load from USB but it is installing again. While partition for my mac has already OS installed.
 
Joined
Dec 31, 2017
Messages
7
If you're doing the direct upgrade, just boot off your regular clover partition after the second reboot. It should then complete the install.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,101
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I've tried to install Mojave on my Z50-70 which has ELAN trackpad.
Successfully boot from USB and tried to install, but after that system restarted and then I tried to boot from USB and install from HDD, but only Apple symbol appear nothing more then that, no any progress bar
Here I'm attaching clover.zip file without theme directory. And Also photo of verbose mode of booting
Please help me.
No Aptio fixes in your drivers64UEFI.
Refer to the guide:
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/
 
Joined
Mar 3, 2015
Messages
33
Motherboard
Lenovo Z50-70
CPU
i5-4510U
Graphics
GeForce 820M
Mobile Phone
Android, iOS
Thanks,
I've added that and also added APFS files.
able to install and do post installation.
but unable to boot from HDD clover now. I've windows 10 installed on another partition. always that windows starts no clover appear. When try to boot from USB and load from installed OS only progress bar shows for 15-20 mins, no account login screen appears.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,101
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
but unable to boot from HDD clover now. I've windows 10 installed on another partition. always that windows starts no clover appear.
Read post #2 of the guide regarding use of efibootmgr:
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/

When try to boot from USB and load from installed OS only progress bar shows for 15-20 mins, no account login screen appears.
If you expect help with this scenario, you must attach problem reporting files that represent the attempt (verbose boot photo and EFI/Clover that causes it). We cannot begin to guess what you're actually doing nor what the actual result is.
 
Joined
Mar 3, 2015
Messages
33
Motherboard
Lenovo Z50-70
CPU
i5-4510U
Graphics
GeForce 820M
Mobile Phone
Android, iOS
Last edited by a moderator:
Top