Contribute
Register

[Guide] Lenovo T440s Clover UEFI

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,075
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Possibly not... I never got to flash the BIOS because the WinPE USB stick I tried to use would not boot.

I pulled the stick out, then wanted to reboot back to OSX, but then the boot-looping started.

As I was saying, if I remove FakePCIID_Intel_HD_Graphics.kext, it boots, albeit with no graphics acceleration.

PS.. in the initial post, and other posts here, the procedure talks about the specific FakePCIID_HD4600_HD4400.kext

Is that still available? I cannot find it. I could only find FakePCIID_Intel_HD_Graphics.kext.

Could that be the issue?
No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
 
Joined
Oct 19, 2010
Messages
68
Motherboard
Gigabyte Z370 AORUS Gaming 5
CPU
i5-8400
Graphics
RX 580
Mac
MacBook, MacBook Pro
Classic Mac
Classic
Mobile Phone
Android, iOS
No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Hi Rehabman... I've got to go away interstate for my work for a week, I'll get file outputs together then.
I might also try to do this again from scratch.

I'm just perplexed why graphics got screwed up, and I'm not sure why, and whatever I do, I can't get acceleration working.
I've got so many versions of config.plist now I can't remember which was what. I guess the take home message from that is, once the system does work smooth, back up the Clover folder.

Anyhow, just back to one of my other questions... the guide in Post#1 talks about a specific kext called:
FakePCIID_HD4600_HD4400.kext
In your repository, I could only find
FakePCIID_Intel_HD_Graphics.kext

Would that for some reason be a factor?
Is FakePCIID_HD4600_HD4400.kext still available for download?

Appreciate your comments so far.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,075
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hi Rehabman... I've got to go away interstate for my work for a week, I'll get file outputs together then.
I might also try to do this again from scratch.

I'm just perplexed why graphics got screwed up, and I'm not sure why, and whatever I do, I can't get acceleration working.
I've got so many versions of config.plist now I can't remember which was what. I guess the take home message from that is, once the system does work smooth, back up the Clover folder.

Anyhow, just back to one of my other questions... the guide in Post#1 talks about a specific kext called:
FakePCIID_HD4600_HD4400.kext
In your repository, I could only find
FakePCIID_Intel_HD_Graphics.kext

Would that for some reason be a factor?
Is FakePCIID_HD4600_HD4400.kext still available for download?

Appreciate your comments so far.
FakePCIID_HD4600_HD4400.kext is deprecated.
Replaced by FakePCIIID_Intel_HD_Graphics.kext.
 
Joined
Sep 5, 2011
Messages
454
Motherboard
Lenovo T440s
CPU
i5-4200u
Graphics
HD4400
for a VGA port to work, you would have to patch the framebuffers to change the personality of a port from DV/HDMI to VGA.
tluck - sorry for replying so late, but I was wondering if you were able to successfully map the Fn keys to the keyboard on the Lenovo T series laptops (I'm using a T440s, but I know you have a T460 which should be using a very similar keyboard).

Would you mind pointing me in the right direction? I figured out which methods are being called in the EC device but I do not know how to edit them to perform different functions.
 
Joined
Jul 28, 2012
Messages
43
Motherboard
Lenovo S30 4351 "Socrates" Rev. 2.0 Product Name: 43518G3
CPU
Xeon E5-1650
Graphics
EVGA GTX1050ti
Mac
iMac, MacBook Air, Mac mini
Classic Mac
PowerBook
Mobile Phone
Android, iOS
@Ludacrisvp - I have a T440 as well. I've been trying to get the BIOS modded by one of the moderators over at bios-mods.com, but no matter what I do he keeps telling me that I have a bad BIOS dump. I've tried a TL866 programmer and two difference CH341 SPI programmers (the green one and then the black one) and so many different versions of the software.

Do you have any advice on how to dump the BIOS properly so I can get the whitelist removed?
 
Joined
May 24, 2011
Messages
248
Motherboard
Lenovo T440S / Toshiba X205-SLI6 / Toshiba C850 / Dell T110 / Lenovo T410 / MP3,1 / MBP4,1
CPU
i5 4300U / T9300 / i3 3110M / 8x 2.8Ghz Xeon / i5 560m / 8x 3.2Ghz X5482 / T9300
Graphics
HD4400 / 2x 8600M GT / Intel HD4000 / Intel IronLake / HD5770 / 8800GT & GTX650 / 8600M GT
Mac
MacBook Pro, Mac Pro
Classic Mac
eMac
Mobile Phone
iOS
@Ludacrisvp - I have a T440 as well. I've been trying to get the BIOS modded by one of the moderators over at bios-mods.com, but no matter what I do he keeps telling me that I have a bad BIOS dump. I've tried a TL866 programmer and two difference CH341 SPI programmers (the green one and then the black one) and so many different versions of the software.

Do you have any advice on how to dump the BIOS properly so I can get the whitelist removed?
Just flash the 2.36 bios version. It doesn't have a functional white list. Meaning all cards work due to a firmware bug from Lenovo.

If it's not the correct version I'll let you know when I get home.
 
Top