Contribute
Register

[Guide] Lenovo T440s Clover UEFI

Joined
Dec 6, 2015
Messages
10
Mac
Classic Mac
Mobile Phone
Has anyone been able to get the media card reader working? I realize its an unsupported chipset but am curious.
Also just wanted to let people know you can get the broadcom bluetooth/wifi combo working by installing bios v2.36 which whitelists all cards, then using the usb injector and editing your dsdt from hxci to hxc.
How is your battery life? It seems I get about 2 to 2 1/2 hours.
 
Joined
Sep 5, 2011
Messages
363
Motherboard
Lenovo T440s
CPU
i5-4200u
Graphics
HD4400
Has anyone been able to get the media card reader working? I realize its an unsupported chipset but am curious.
Also just wanted to let people know you can get the broadcom bluetooth/wifi combo working by installing bios v2.36 which whitelists all cards, then using the usb injector and editing your dsdt from hxci to hxc.
How is your battery life? It seems I get about 2 to 2 1/2 hours.
I don't think it's possible with this hardware, but I'd love to hear if someone else was able to somehow get it working.

Also there seems to be some confusion over the VGA port. It's my understanding that the VGA ports have no worked for a few version of OSX. Has anyone got the VGA port working on this laptop on El Capitan or later? Mine is not working on El Capitan, but I figured that was just like the media card reader...it's strictly unsupported.
 
Joined
Sep 24, 2012
Messages
78
Motherboard
Dell M4800
CPU
I7-4810MQ
Graphics
HD 4600/AMD
Mac
MacBook Pro
Mobile Phone
iOS
for a VGA port to work, you would have to patch the framebuffers to change the personality of a port from DV/HDMI to VGA.
 
Joined
Dec 6, 2015
Messages
10
Mac
Classic Mac
Mobile Phone
Hey!

Just for updates on the laptop, I purchased the 3 cell battery off amazon (the larger one available) and have seen a serious improvement in my battery life, from around 2 hours working time while programming to around 5 while programming. Really happy with the result.

Coincidentally, my bluetooth hardware is no longer detected, I am using a broadcom with BrcmFirmwareRepo.kext and BrcmPatchRAM2.kext. It was working for about 3 or 4 months now and even just the other night. Any reason it would stop working? It shows up in IOreg, which I have attached.

@RehabMan or @Gemuesekanal though I think you've moved on from this laptop

Thanks!
 

Attachments

Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,716
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hey!

Just for updates on the laptop, I purchased the 3 cell battery off amazon (the larger one available) and have seen a serious improvement in my battery life, from around 2 hours working time while programming to around 5 while programming. Really happy with the result.

Coincidentally, my bluetooth hardware is no longer detected, I am using a broadcom with BrcmFirmwareRepo.kext and BrcmPatchRAM2.kext. It was working for about 3 or 4 months now and even just the other night. Any reason it would stop working? It shows up in IOreg, which I have attached.

@RehabMan or @Gemuesekanal though I think you've moved on from this laptop

Thanks!
Your ioreg shows no bluetooth controller on the USB bus (not sure why you think it is there...???)
Maybe you make the mistake of enabling fast boot in BIOS.
 
Joined
Dec 16, 2011
Messages
1
Motherboard
tosiba c640
CPU
i3 340
Graphics
hd 3000
Mac
MacBook Air
Classic Mac
Mobile Phone
iOS
Hi everyone
I need install mac os for my laptop T440s
Please help me install step by step
Thanks all
 
Joined
Oct 19, 2010
Messages
68
Motherboard
Gigabyte Z370 AORUS Gaming 5
CPU
i5-8400
Graphics
RX 580
Mac
MacBook, MacBook Pro
Classic Mac
Classic
Mobile Phone
Android, iOS
I had my T440S going after following instructions in this epic thread, and thanks to all of you for making this thread awesome.

I now have a problem:

I wanted to flash an earlier BIOS (for wifi whitelist) , and that required me to boot a PEWin Pen drive on the system.
The Pendrive didn't boot, but hung. Since then, I am constantly in a boot-loop on my 10.10.5 install

If I remove the FakePCIID_Intel_HD_Graphics.kext from extras in the EFI partition, the system does then make it all the way, but graphics is not longer accelerated and smooth. I've been at this all day trying different things, all to no avail.

Anyone got any ideas?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,716
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I had my T440S going after following instructions in this epic thread, and thanks to all of you for making this thread awesome.

I now have a problem:

I wanted to flash an earlier BIOS (for wifi whitelist) , and that required me to boot a PEWin Pen drive on the system.
The Pendrive didn't boot, but hung. Since then, I am constantly in a boot-loop on my 10.10.5 install

If I remove the FakePCIID_Intel_HD_Graphics.kext from extras in the EFI partition, the system does then make it all the way, but graphics is not longer accelerated and smooth. I've been at this all day trying different things, all to no avail.

Anyone got any ideas?
My guess: You damaged your Intel MEI, and now it is not working... macOS/OS X requires a working Intel MEI.

Read FAQ, "Problem Reporting"
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
 
Joined
Oct 19, 2010
Messages
68
Motherboard
Gigabyte Z370 AORUS Gaming 5
CPU
i5-8400
Graphics
RX 580
Mac
MacBook, MacBook Pro
Classic Mac
Classic
Mobile Phone
Android, iOS
My guess: You damaged your Intel MEI, and now it is not working... macOS/OS X requires a working Intel MEI.

Read FAQ, "Problem Reporting"
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Possibly not... I never got to flash the BIOS because the WinPE USB stick I tried to use would not boot.

I pulled the stick out, then wanted to reboot back to OSX, but then the boot-looping started.

As I was saying, if I remove FakePCIID_Intel_HD_Graphics.kext, it boots, albeit with no graphics acceleration.

PS.. in the initial post, and other posts here, the procedure talks about the specific FakePCIID_HD4600_HD4400.kext

Is that still available? I cannot find it. I could only find FakePCIID_Intel_HD_Graphics.kext.

Could that be the issue?
 
Top