Contribute
Register

[Guide] Laptop backlight control using AppleBacklightFixup.kext

Joined
Dec 12, 2011
Messages
6
Motherboard
Acer V5 473
CPU
i5-4200
Graphics
HD 4400M (GT740M Disabled)
Hi, I tried to follow the guide but wasn't able to get the brightness slider or the brightness working.

Please advise.

Thanks
 

Attachments

  • debug_1636.zip
    9.8 MB · Views: 183

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,623
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi, I tried to follow the guide but wasn't able to get the brightness slider or the brightness working.

Please advise.

Thanks

Your ACPI configuration is wrong.
See guide for good starter plists and recommended version of Clover:
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/

Then read applicable ACPI patching guides:
https://www.tonymacx86.com/threads/guide-patching-laptop-dsdt-ssdts.152573/
https://www.tonymacx86.com/threads/guide-disabling-discrete-graphics-in-dual-gpu-laptops.163772/
 
Joined
Nov 20, 2017
Messages
5
Motherboard
Asus Zenbook UX305UA
CPU
intel core i7 skylake
Graphics
intel graphics 520
Hello. I am having some issues getting this to work. I believe I followed the guide correctly, but I might be wrong. I can't get the slider to show up inn display setting at least. Here is my files:
 

Attachments

  • debug_25716.zip
    1.8 MB · Views: 179

Feartech

Moderator
Joined
Aug 3, 2013
Messages
25,988
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Hello. I am having some issues getting this to work. I believe I followed the guide correctly, but I might be wrong. I can't get the slider to show up inn display setting at least. Here is my files:
config.plist:
CsrActiveConfig should be 0x67

change MacBookPro13,2 to MacBookPro13,1

and use a mobile ig-platform-id 0x191b0000
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,623
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hello. I am having some issues getting this to work. I believe I followed the guide correctly, but I might be wrong. I can't get the slider to show up inn display setting at least. Here is my files:

Your kextcache output proves you didn't even install AppleBacklightInjector.kext.
Also, GFX0->IGPU patch is missing in config.plist/ACPI/DSDT/Patches.
See guide for correct starter plists:
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/

Due to these basic mistakes, I didn't bother to check anything else.
 
Joined
Aug 24, 2018
Messages
3
Motherboard
Acer Aspire V3 772G
CPU
i7-4712MQ
Graphics
HD 4600 + GTX 850M
Hi RehabMan,

I follow your guide here (using AppleBacklight) but can not get the backlight control (slider) in SysPrefs > Display.
  • The SSDT-PNLF.aml go to ACPI/patched
  • The AppleBacklight patch in KextToPatch
  • The AppleBacklightInjector.kext go to /L/E + reboot + rebuild cache too many time
So I tried to use the ACPIBacklight.kext here https://github.com/RehabMan/OS-X-ACPI-Backlight, nothing change, still not get the slider.
  • The SSDT-PNLF.aml go to ACPI/patched
  • The ACPIBacklight.kext go to /L/E + reboot + rebuild cache many time
Can you help me figure out what I'm doing wrong? How to get the slider in SysPrefs > Display?
I attached two reported files for the two case above.
Thank you very much!
 

Attachments

  • ACPIBacklight-ReportFile.zip
    3.8 MB · Views: 176
  • AppleBacklight-ReportFile.zip
    3.8 MB · Views: 174

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,623
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi RehabMan,

I follow your guide here (using AppleBacklight) but can not get the backlight control (slider) in SysPrefs > Display.
  • The SSDT-PNLF.aml go to ACPI/patched
  • The AppleBacklight patch in KextToPatch
  • The AppleBacklightInjector.kext go to /L/E + reboot + rebuild cache too many time
So I tried to use the ACPIBacklight.kext here https://github.com/RehabMan/OS-X-ACPI-Backlight, nothing change, still not get the slider.
  • The SSDT-PNLF.aml go to ACPI/patched
  • The ACPIBacklight.kext go to /L/E + reboot + rebuild cache many time
Can you help me figure out what I'm doing wrong? How to get the slider in SysPrefs > Display?
I attached two reported files for the two case above.
Thank you very much!

You cannot expect to use a desktop ig-platform-id for a laptop. Your ioreg proves it... 0x0d220003 is desktop.
See guide for correct plists:
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/

It is also possible you have SSDT-IGPU.aml misconfigured (you really should not be using it anyway,... best to use config.plist for graphics injection). But if you insist on SSDT-IGPU, make sure it is configured correctly with SSDT-RMCF.

Also,
Your kextcache output proves kexts are not installed correctly.
All kexts you need must be installed to the system volume.
Read post #2 of the Clover guide for details:
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/
 
Joined
Nov 27, 2011
Messages
32
Motherboard
HP Envy 15 as-043 (Clover)
CPU
i7-6560U
Graphics
HD 540 - 4K
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Your kextcache output proves you didn't even install AppleBacklightInjector.kext.
Also, GFX0->IGPU patch is missing in config.plist/ACPI/DSDT/Patches.
See guide for correct starter plists:
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/

Due to these basic mistakes, I didn't bother to check anything else.
Hi Rehabman,
Maybe you can give me some idea what to do. I am on Mojave Beta 9. I implemented backlight control and it's working properly, but after booting or rebooting my screen goes black, before it was booting fine. To get screen back I should close laptop's lid and wait 3-4 min. After that I open the lid and my login screen is back and I can work normally.
What can cause this? Any ideas? I attached problem reporting files.
I tried to replace GFX0->IGPU in my DSDT, but it caused KP. the same fix through config.plist works fine.
 

Attachments

  • CLOVER.zip
    4.7 MB · Views: 197
  • MacBook Pro.zip
    642.5 KB · Views: 170
  • Terminal Saved Output.zip
    2 KB · Views: 173

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,623
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi Rehabman,
Maybe you can give me some idea what to do. I am on Mojave Beta 9. I implemented backlight control and it's working properly, but after booting or rebooting my screen goes black, before it was booting fine. To get screen back I should close laptop's lid and wait 3-4 min. After that I open the lid and my login screen is back and I can work normally.
What can cause this? Any ideas? I attached problem reporting files.
I tried to replace GFX0->IGPU in my DSDT, but it caused KP. the same fix through config.plist works fine.

MacBookPro13,3 is a poor choice. You should use MacBookPro13,1 or MacBookPro11,1.

EmuVariableUefi-64.efi is not used with AptioMemoryFix.efi. Remove EmuVariableUefi-64.efi.
OsxAptioFix*.efi should not be combined with AptioMemoryFix.efi. Remove OsxAptioFix*.efi.

Your kextcache output proves kexts are not installed correctly.
All kexts you need must be installed to the system volume.
Read post #2 of the Clover guide for details:
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/

Also,
"Problem Reporting" files are incomplete.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.

Also, ioreg collected in black screen scenario (if still happening after SMBIOS change) would be useful.
 
Top