Contribute
Register

[Guide] Intel NUC7/NUC8 using Clover UEFI (NUC7i7Bxx,NUC8i7Bxx,etc)

Joined
May 31, 2015
Messages
10
Motherboard
NUC8
CPU
i5
Graphics
Iris Plus 655
So I finally have time to start my Hackintosh adventure with my Nuc8i5. And before I start to tinker, I wonder if I can update the bios? Will it work with fully updated Bios or should I keep the "standard" OOTB Bios?
 
Joined
May 11, 2011
Messages
240
Motherboard
NUC8i5
CPU
i5-8259U
Graphics
Iris Plus Graphics 655
Mac
  1. MacBook Air
  2. Mac mini
Mobile Phone
  1. Android
  2. iOS
So I finally have time to start my Hackintosh adventure with my Nuc8i5. And before I start to tinker, I wonder if I can update the bios? Will it work with fully updated Bios or should I keep the "standard" OOTB Bios?
Which BIOS does your NUC currently have? It should not matter, as the recommended BIOS settings are normally common among all versions
 
Joined
Jul 31, 2019
Messages
16
Motherboard
Intel Nuc7i3DNKE
CPU
i3
Graphics
HD 620
I reply to myself
i 've just changed : Misc -> Security -> ScanPolicy set to 0 to show all drives
and my windows 10 HD is now visible in boot menu.
Hi my friend, I have the same issue. where did you change the scanpolicy? in what program or menu is it? Sorry for the dumb questions. noob.
 
Joined
Feb 25, 2013
Messages
65
Motherboard
NUC 8i5BEH-0087
CPU
i5-8259U
Graphics
UHD 655
Mobile Phone
  1. Android
Hi my friend, I have the same issue. where did you change the scanpolicy? in what program or menu is it? Sorry for the dumb questions. noob.
hi,
edit your config.plist find section : Misc -> Security -> ScanPolicy and set to 0 to show all drives
 
Joined
Sep 20, 2011
Messages
105
Motherboard
Gigabyte Z370M D3H
CPU
i5-8600K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Hi, I have some problems with sleep after update to 11.2. It wakes up after a few minutes. Update with OC 0.6.4 went smooth and ALC, Lilu and WhateverGreen was also upgraded to latest version. I tried update bios to latest version 87, and that did not help.
Earlier on 11.1 I had the problem that it went to sleep but many times could not wake the screen again.
Maybe try OC 0.6.6?
 

Leesureone

Moderator
Joined
Feb 21, 2010
Messages
3,248
Motherboard
Asus Z690i Gaming Wifi
CPU
i9-12900K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
Hi, I have some problems with sleep after update to 11.2. It wakes up after a few minutes. Update with OC 0.6.4 went smooth and ALC, Lilu and WhateverGreen was also upgraded to latest version. I tried update bios to latest version 87, and that did not help.
Earlier on 11.1 I had the problem that it went to sleep but many times could not wake the screen again.
Maybe try OC 0.6.6?
Sleep/ Wake issues are almost always related to improper USB port configuration. Also the version of OpenCore typically makes no difference if you don't have your USB ports properly mapped. Same with bios versions. Sleep issues can also be software or USB hardware related as well, do your best to eliminate any of those potential problems first and see if the behavior repeats itself.

Beyond that its known that the NUC8i7, i5 and i3 models can vary in how ports need to be mapped. My suggestion is you follow this guide and see if it helps, it should.

 
Last edited:
Joined
Sep 20, 2011
Messages
105
Motherboard
Gigabyte Z370M D3H
CPU
i5-8600K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Thanks Leesureone! You are right, I forgot that I changed my usb audio-dac. It looks as if it does not understand the sleep process and starts itself again after a while. Its a Topping e-30, sounds very good, so I shall solve this somehow.
 
Joined
Feb 8, 2021
Messages
2
Motherboard
Intel
CPU
i5
Graphics
iris 655
Hi @Leesureone,

I'm new here, I'm currently using NUCi5BEH Mojave, which I installed before.

My question is,
How can I upgrade to Big Sur and I want to use Bluetooth. Already got Bcm94360Cs2 installed but only wifi works Bluetooth not working.

Do I need to migrate to Opencore?

I did the Hackintosh long time ago, now completely forgot what I learned before.

I saw that you said that just use USB to test out the latest Opencore files, I did everything you said, and I got boot up and everything working (except the Bluetooth not working, same as before). But I'm not sure it boots up using Opencore or what, no familiar with Opencore (attached a bootup image using the USB with EFINUC8i7 OC6.6 this file.)

I also tried to mount EFI and copy EFINUC8i7 OC6.6 to my hard drive, but it didn't boot up.

I'm completely lost, any advice, please?

Thank you.
 

Attachments

  • Photo 09-02-2021, 3 17 08 AM.jpg
    Photo 09-02-2021, 3 17 08 AM.jpg
    2.8 MB · Views: 37

Leesureone

Moderator
Joined
Feb 21, 2010
Messages
3,248
Motherboard
Asus Z690i Gaming Wifi
CPU
i9-12900K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
Hi @Leesureone,

I'm new here, I'm currently using NUCi5BEH Mojave, which I installed before.

My question is,
How can I upgrade to Big Sur and I want to use Bluetooth. Already got Bcm94360Cs2 installed but only wifi works Bluetooth not working.
Please elaborate how you have the BCM94360CS2 installed? I assume you are using an adapter to the M2 slot that requires an internal USB connection as well as antennas. If that's so are you sure you have the USB cable you probably had to make correct? You have the antennas connected correctly?

We also know from past postings here that the adapter USB connection to the header is not mapped in any of the EFI folders I posted. If all the above is correct you will need to custom map your USB ports for it to work. See this guide here for how:
Do I need to migrate to Opencore?
No, but you can using the EFI folder you are using on your USB drive
I did the Hackintosh long time ago, now completely forgot what I learned before.

I saw that you said that just use USB to test out the latest Opencore files, I did everything you said, and I got boot up and everything working (except the Bluetooth not working, same as before). But I'm not sure it boots up using Opencore or what, no familiar with Opencore (attached a bootup image using the USB with EFINUC8i7 OC6.6 this file.)
Yes, that is the OpenCanopy Boot menu for OpenCore
I also tried to mount EFI and copy EFINUC8i7 OC6.6 to my hard drive, but it didn't boot up.
Do you know how to mount the hidden EFI partition on your hard drive? There are utilities like EFI Agent that will do it without terminal commands. Once you mount the EFI partition copy and paste my EFI folder there.
I'm completely lost, any advice, please?

Thank you.
Are you aware that in the EFI folder you downloaded it enables the onboard intel bluetooth module? If you are going to use an add in card make sure the intel card is turned off in the bios and remove the IntelFirmware.Kext from the config.plist to avoid conflicts.
 
Last edited:
Joined
Feb 8, 2021
Messages
2
Motherboard
Intel
CPU
i5
Graphics
iris 655
@Leesureone

Please elaborate how you have the BCM94360CS2 installed? I assume you are using an adapter to the M2 slot that requires an internal USB connection as well as antennas. If that's so are you sure you have the USB cable you probably had to make correct? You have the antennas connected correctly?

We also know from past postings here that the adapter USB connection to the header is not mapped in any of the EFI folders I posted. If all the above is correct you will need to custom map your USB ports for it to work. See this guide here for how:

Yes, I've attached a photo for my BCM94360CS2, I've checked with other people Nuc8, and I think my antenna was wrong so I swap it, but it still not working.

Are you aware that in the EFI folder you downloaded it enables the onboard intel bluetooth module? If you are going to use an add in card make sure the intel card is turned off in the bios and remove the IntelFirmware.Kext from the config.plist to avoid conflicts.

I tried to turn off the onboard Bluetooth, but when I start my computer, the Bluetooth icon is totally gone, looks like not detected.

When I turn on, I used the Hackintool checked, it show like IOUSBHostDevice only, No Bluetooth detected.

Also, I can't find the IntelFirmware.Kext name in my config.plist.
Do you know how to mount the hidden EFI partition on your hard drive? There are utilities like EFI Agent that will do it without terminal commands. Once you mount the EFI partition copy and paste my EFI folder there.

Yes, open up the clover configurator -> mount EFI -> Mount Partition. Am I right?

Copy paste means to replace everything inside my EFI? or merge it? My clover folder still remain or delete?

Thank you
 

Attachments

  • Photo 09-02-2021, 6 34 39 PM.jpg
    Photo 09-02-2021, 6 34 39 PM.jpg
    4.7 MB · Views: 67
  • Screenshot 2021-02-10 at 1.49.30 AM.png
    Screenshot 2021-02-10 at 1.49.30 AM.png
    108 KB · Views: 64
  • Screenshot 2021-02-10 at 2.00.34 AM.png
    Screenshot 2021-02-10 at 2.00.34 AM.png
    201.9 KB · Views: 62
Top