Contribute
Register

[Guide] HP ProBook/EliteBook/Zbook using Clover UEFI hotpatch

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,692
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Not sure i did it completely right, but what i did was:

1. attached the last verbose screen photo before the apple and empty progress bar comes up
2. read the problem reporting faq
3. fixed my profile by adding the laptops data HP Probook 450 G5, i5 8250, UHD 620, 16 GB RAM, trying to boot Mojave from SSD in my personal profile page, not in the signature only.

If there's more i can do, of course i will ;)

thanks a lot and kind regards!
Your profile is missing screen resolution.
What do you mean by "empty progress bar"?
You should try invalid ig-platform-id (0x12345678).
 
Joined
Aug 25, 2015
Messages
23
Motherboard
HP Probook 450 G1-F6Q45PA
CPU
i5 4200M
Graphics
intel hd 4600- amd 8750M
Hi Rehabman, can you fix my the problem resolution is 1024x768 at clover bootscreen .this is my debug.
 

Attachments

Joined
Apr 30, 2013
Messages
2
Motherboard
Hp 840 G1
CPU
Intel Core i5-4300U
Graphics
Intel HD 4400
Mobile Phone
Android, iOS
Hi, I just Updated to Mojave from High Sierra. Wifi and everything work fine except audio. Usually after updating, it can be fixed by rebuilding kextcache and restarting couples times. But, this time, it doesn't work. Can someone help me to fix this? Thanks.
 

Attachments

Joined
May 9, 2013
Messages
76
Motherboard
HP Probook 450 G5
CPU
I5-8250
Graphics
UHD 620, 1920x1080
Mac
MacBook Pro
Your profile is missing screen resolution.
What do you mean by "empty progress bar"?
You should try invalid ig-platform-id (0x12345678).
thanks for your reply RehabMan! Added the FullHD screen resolution 1920x1080 to the profile.
with empty progress bar i mean the screenshot below, in this situation i mostly end up when trying to boot into mojave, the progress bar below the apple is empty and doesn't "increase", as it usually does when booting non verbose.
i changed the "#ig-platform-id" from the initial "0x191b0000" to "0x1245678" in config.plist, booting looks good and fast in verbose mode, just that i soon end up in the "apple and empty progress bar" screen, which i attached here. tried removing the "#" (comment?) from the "#ig-platform-id", leading to many ACPI-errors i also attached a screenshot of those to this post.
somehow the system is almost booted, just instead of the mojave desktop i always get that apple and empty bar. wonder what i could still do.

thanks so much for your patience and help!

kind regards!

p.s.: one phenomena i got before was, that the screen went into standby (or at least it was dark) after the apple logo and empty progress bar, then i pressed a key to wake it up (or touched the trackpad) and i could see and move the trackpad cursor (arrow pointer of osx) on the screen, until i pressed a key again, the the pointer was gone. feels like i'm always in mojave ;)

IMG-8736-2.jpeg
IMG-8734-2.jpeg
 
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,692
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
the problem resolution is 1024x768 at clover bootscreen
It is as expected with CSM enabled.
Nothing to fix (it works just fine).
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,692
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hi, I just Updated to Mojave from High Sierra. Wifi and everything work fine except audio. Usually after updating, it can be fixed by rebuilding kextcache and restarting couples times. But, this time, it doesn't work. Can someone help me to fix this? Thanks.
You failed to update to the current repo, and run all post install steps (./download.sh, ./install_download.sh, install_acpi.sh, updating config.plist, etc).

Read post #1.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,692
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
thanks for your reply RehabMan! Added the FullHD screen resolution 1920x1080 to the profile.
with empty progress bar i mean the screenshot below, in this situation i mostly end up when trying to boot into mojave, the progress bar below the apple is empty and doesn't "increase", as it usually does when booting non verbose.
i changed the "#ig-platform-id" from the initial "0x191b0000" to "0x1245678" in config.plist, booting looks good and fast in verbose mode, just that i soon end up in the "apple and empty progress bar" screen, which i attached here. tried removing the "#" (comment?) from the "#ig-platform-id", leading to many ACPI-errors i also attached a screenshot of those to this post.
somehow the system is almost booted, just instead of the mojave desktop i always get that apple and empty bar. wonder what i could still do.

thanks so much for your patience and help!

kind regards!

p.s.: one phenomena i got before was, that the screen went into standby (or at least it was dark) after the apple logo and empty progress bar, then i pressed a key to wake it up (or touched the trackpad) and i could see and move the trackpad cursor (arrow pointer of osx) on the screen, until i pressed a key again, the the pointer was gone. feels like i'm always in mojave ;)

View attachment 369299 View attachment 369302
No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
 
Joined
May 9, 2013
Messages
76
Motherboard
HP Probook 450 G5
CPU
I5-8250
Graphics
UHD 620, 1920x1080
Mac
MacBook Pro

Attachments

Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,692
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
here i added clover.zip, booting from usb via config-depracated.plist, cant boot into the mojave desktop.
config-deprecated.plist is not a valid plist... it is just a collection of patches that we no longer use.
 
Joined
Nov 26, 2018
Messages
3
Motherboard
HP Probook 650 G1 - Clover
CPU
i5-4210M/HM87
Graphics
HD 4600, 1920x1080
Mobile Phone
iOS
Hi for everyone. My Mojave install stuck on
Start RandomSeed
End RandomSeed
+++++++++++++++++++++++++++++++++++++++

I follow guide, and make bootable usb whit two method. What can I do now?
 
Top