Contribute
Register

[Guide] HP 6300 Pro / HP 8300 Elite - A 100 percent Working and Easily Affordable CustoMac

Joined
Jul 1, 2017
Messages
4
Motherboard
HP Elite 8300 minitower
CPU
i5 3470
Graphics
RX 580
Update regarding my 8300 minitower and RX 580 not showing video when multiple monitors are connected at boot / startup / restart.

I re-enabled legacy mode, and set the video rom option to legacy only under advanced. Now all is working as expected.
 
Joined
Jan 1, 2011
Messages
75
Motherboard
GA-X58A-UD5-FB
CPU
i7-950
Graphics
RX-580
Mobile Phone
  1. iOS
Purchased MSI Radeon RX560 graphics card, installed in PCI X16 slot as recommended, using DVI cable, I cannot boot, system doesn't recognize the card. I tried KTEXTs (Lilu, IntelGraphicFixup, Whatevergreen) recommended here, still no luck. Anyone had luck with MSI Radeon RX560 graphics card on HP Elite 8300 SFF? How to have HP Elite 8300 recognize this card? I read on the box recommended PSU is 400W or greater.
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
22,246
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
Purchased MSI Radeon RX560 graphics card, installed in PCI X16 slot as recommended, using DVI cable, I cannot boot, system doesn't recognize the card. I tried KTEXTs (Lilu, IntelGraphicFixup, Whatevergreen) recommended here, still no luck. Anyone had luck with MSI Radeon RX560 graphics card on HP Elite 8300 SFF? How to have HP Elite 8300 recognize this card? I read on the box recommended PSU is 400W or greater.
Many have used this card successfully. It may be an incorrect BIOS setting or a config.plist setting. Check your BIOS settings and make sure you've got Inject Intel set to false in your Clover config.plist. Also check that your are on 10.13.4 or later. You could also try the HDMI output on the card to see if that works. You can connect it to a TV to test that if your monitor doesn't have HDMI.
 
Joined
Jan 1, 2011
Messages
75
Motherboard
GA-X58A-UD5-FB
CPU
i7-950
Graphics
RX-580
Mobile Phone
  1. iOS
Thanks @trs96! I tried connecting PC to the TV using HDMI without any luck. My BIOS setting is per HP Elite 8300 Guide. I am on 10.13.6. Also tried to set "Inject Intel" to false, nothing changed, still does not work. I wonder if card is defective (I purchased it as open item on BHPhoto.com)?
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
22,246
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
Thanks @trs96! I tried connecting PC to the TV using HDMI without any luck. My BIOS setting is per HP Elite 8300 Guide. I am on 10.13.6. Also tried to set "Inject Intel" to false, nothing changed, still does not work. I wonder if card is defective (I purchased it as open item on BHPhoto.com)?
Try the card in a Windows PC and see if it works or not.
 
Joined
Jan 1, 2011
Messages
75
Motherboard
GA-X58A-UD5-FB
CPU
i7-950
Graphics
RX-580
Mobile Phone
  1. iOS
I tried, looks like this gfx card is defective, returning...thanks for your help!
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
22,246
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
Joined
Jan 21, 2012
Messages
997
Motherboard
HP 8300 Elite
CPU
i5-3570
Graphics
GT 710
Mobile Phone
  1. Android
Installed High Sierra then immediately updated a HP 8300 i3470 with Nvidia 710 to Mojave 18A389 (almost GM), not tested much but it seems to run ok.
 
Last edited:
Joined
Feb 24, 2018
Messages
8
Motherboard
HP 8300 Elite
CPU
Core i5-3470
Graphics
MSI GeForce GT710 1GB
Mac
  1. iMac
  2. MacBook Air
Classic Mac
  1. iBook
Mobile Phone
  1. Android
Installed High Sierra then immediately updated a HP 8300 i3470 with Nvidia 710 HS to Mojave 18A389 (almost GM), not tested much but it seems to run ok.
Been running Mojave beta 11 on my 8300 for about a week now. Runs excellent, no issues at all. Plus dark mode looks amazing.
 
Joined
Feb 9, 2018
Messages
44
Motherboard
HP 8300 Elite full size tower
CPU
i7 - 3770
Graphics
Intel HD 4000
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Been running Mojave beta 11 on my 8300 for about a week now. Runs excellent, no issues at all. Plus dark mode looks amazing.
So you did a straight update like any real Mac? No going back after the update and messing with kexts?
 
Top