Contribute
Register

Guide: GA-Z68X-UD3H-B3 with ATI 6870 - Clean ML/Lion Install

Joined
Nov 16, 2010
Messages
2,723
Motherboard
AsRock Z370M ITX/ac
CPU
i7-8700K
Graphics
RX 570
Mac
iMac, MacBook Pro, Mac mini
Mobile Phone
iOS
Re: Guide: GA-Z68X-UD3H-B3 with ATI 6870 - Clean Lion Install

budiosx said:
tom5151 said:
Thanks for sharing :clap:

What about sleep ?
I can't get it work :banghead:
Sleep - General Troubleshooting Tips :
===========================

1. You must have the proper DSDT edits as per this post. All of the Gigabyte DSDTs in the DSDT Database are edited properly for sleep.
http://tonymacx86.blogspot.com/2009/12/ ... n-p55.html

2. To enable sleep, make sure to remove NullCPUPowerManagement.kext

3. Make sure you check all of the checkboxes in System Preferences/Energy Saver as shown in the picture below.



4. Make sure your DSDT is named DSDT.aml and found in /Extra folder.
#1, #2, and #4 are all taken care of by using a DSDT from the database and this guide.
 
Joined
Sep 14, 2011
Messages
287
Motherboard
Z97X-UD5H rev. 1.0
CPU
4690K
Graphics
EVGA NVIDIA GeForce GTX 650 (not Ti)
Re: Guide: GA-Z68X-UD3H-B3 with ATI 6870 - Clean Lion Install

Thanks, Gordo. Really appreciate the work and the help.

I have no graphics card and am using the built in HD 3000. This required some adaptation of the recipie.

First, I needed the GraphicsEnabler=No option in rBoot when booting the Lion Installer UDB Drive.

The installed Lion wouldn't boot after running MB4 with the checkbox options suggested. Checking the GraphicsEnabler=No option in MB wasn't enough. But I switched to the Chimera v1.5.4 r1394 boot theme and now Lion boots on its own. This makes sense: the main difference between your Z68 system and mine is graphics and the MB4 Features PDF actually says Chimera v1.5.4 r1394 supports HD 3000. Doh!

Networking is up. Don't know about Audio.

But I'm stuck for now on 1024x768. If anyone knows how to get that going, please point me in the right direction. Using Mac Mini System Definition hasn't solved it. The System Profiler says of the graphics: No Kext Loaded
 
Joined
Apr 12, 2011
Messages
7
Motherboard
GA-P67A-UD3P-B3 BIOS F7
CPU
Intel Core i5-2500k
Graphics
AMD Radeon HD6850
Mac
Classic Mac
Mobile Phone
Re: Guide: GA-Z68X-UD3H-B3 with ATI 6870 - Clean Lion Install

I've got problem. After step #8 of this guide i can see white Apple boot screen about 30 seconds, and after that Apple bot screen disappears and i see nothing. And my monitor show me "No signal" message. Boot with options "-x" and "PCIRootUID=1" doesn't work too.
 
Joined
Apr 12, 2011
Messages
7
Motherboard
GA-P67A-UD3P-B3 BIOS F7
CPU
Intel Core i5-2500k
Graphics
AMD Radeon HD6850
Mac
Classic Mac
Mobile Phone
Re: Guide: GA-Z68X-UD3H-B3 with ATI 6870 - Clean Lion Install

Sorry, I boot with GraphicsEnabler=No option and my problem disappear :)
 
Joined
Nov 16, 2010
Messages
2,723
Motherboard
AsRock Z370M ITX/ac
CPU
i7-8700K
Graphics
RX 570
Mac
iMac, MacBook Pro, Mac mini
Mobile Phone
iOS
Re: Guide: GA-Z68X-UD3H-B3 with ATI 6870 - Clean Lion Install

thefsb said:
Thanks, Gordo. Really appreciate the work and the help.

I have no graphics card and am using the built in HD 3000. This required some adaptation of the recipie.

First, I needed the GraphicsEnabler=No option in rBoot when booting the Lion Installer UDB Drive.

The installed Lion wouldn't boot after running MB4 with the checkbox options suggested. Checking the GraphicsEnabler=No option in MB wasn't enough. But I switched to the Chimera v1.5.4 r1394 boot theme and now Lion boots on its own. This makes sense: the main difference between your Z68 system and mine is graphics and the MB4 Features PDF actually says Chimera v1.5.4 r1394 supports HD 3000. Doh!

Networking is up. Don't know about Audio.

But I'm stuck for now on 1024x768. If anyone knows how to get that going, please point me in the right direction. Using Mac Mini System Definition hasn't solved it. The System Profiler says of the graphics: No Kext Loaded
Try and boot with GraphicsEnabler=Yes. It should support HD3000.
 
Joined
Mar 27, 2011
Messages
1
Motherboard
Mountain Lion
CPU
i5
Graphics
ati 2600
Mac
Classic Mac
Mobile Phone
Re: Guide: GA-Z68X-UD3H-B3 with ATI 6870 - Clean Lion Install

Thanks Gordo.

Followed your instructions and now I have a fully working Lion. This after weeks of the installer partition failing to boot.

Great Job, the instructions were well written and easy to follow.
 
Joined
Sep 11, 2011
Messages
5
Motherboard
Hackintosh OSX Lion
CPU
Intel i7 920
Graphics
ATi 4750
Mac
Classic Mac
Mobile Phone
Re: Guide: GA-Z68X-UD3H-B3 with ATI 6870 - Clean Lion Install

Thanks sooo much for this guide. After many failed attempts at getting a vanilla install fully working on my hardware, I decided to just go for the fresh Lion install and following this guide and it went pretty smooth sailing right through everything.
 
Joined
Aug 10, 2011
Messages
7
Motherboard
Intel DH67VR
CPU
i3
Graphics
HD 6850
Stuck while booting

Hi,
I tried using the xmove method. I am stuck on the following line.
I used the -v option and PCIRootUID=0.
Code:
AppleIntelE1000e: Ethernet address <my MAC address>
:banghead:
Please help!
My system config:
Intel DH67VR Mobo
Core i3 2100 SandyBridge Processor
Graphics Intel HD 2000
(I know it is not supported, I don't care, I am desperate for a working Lion and I hope the above issue is not caused by my graphics. If not, I will deal with the graphics later.)
Seagate 1TB HDD + Seagate 250GB HDD(for SL/Lion)
4GB Corsair RAM
 
Joined
Sep 14, 2011
Messages
287
Motherboard
Z97X-UD5H rev. 1.0
CPU
4690K
Graphics
EVGA NVIDIA GeForce GTX 650 (not Ti)
Re: Guide: GA-Z68X-UD3H-B3 with ATI 6870 - Clean Lion Install

Gordo74 said:
Try and boot with GraphicsEnabler=Yes. It should support HD3000.
Previously I found GraphicsEnabler=No would get my Lions (including your USB drive installer) to boot but that might have been before learned to set 384MB frame buffer in the bios. Now with GraphicsEnabler=Yes Lion boots but that change doesn't rectify the problem that I'm stuck with 1024x768.

Boot log includes this: kernel: SNB Framebuffer did not show up, unload. It's the last kernel syslog message and posted at the moment that the Lion logon screen is displayed. If booting with -v, that's when the display switches from text into Lion graphics.

System Information Extensions says AppleIntelSNBGraphicsFB.kexts is loaded but AppleIntelHDGraphics.kexts is absent from the list.

Display information:
Intel HD Graphics 3000:
Chipset Model: Intel HD Graphics 3000
Type: GPU
Bus: Built-In
VRAM (Total): 64 MB of Shared System Memory
Vendor: Intel (0x8086)
Device ID: 0x0126
Revision ID: 0x0009
Kernel Extension Info: No Kext Loaded
Displays:
    Display:
      Resolution: 1024 x 768
      Pixel Depth: 32-Bit Color (ARGB8888)
      Main Display: Yes
      Mirror: Off
      Online: Yes



Setting onboard graphics to "enable if no ext PGA" hasn't helped.
 
Joined
Nov 16, 2010
Messages
2,723
Motherboard
AsRock Z370M ITX/ac
CPU
i7-8700K
Graphics
RX 570
Mac
iMac, MacBook Pro, Mac mini
Mobile Phone
iOS
Re: Guide: GA-Z68X-UD3H-B3 with ATI 6870 - Clean Lion Install

thefsb said:
Gordo74 said:
Try and boot with GraphicsEnabler=Yes. It should support HD3000.
Previously I found GraphicsEnabler=No would get my Lions (including your USB drive installer) to boot but that might have been before learned to set 384MB frame buffer in the bios. Now with GraphicsEnabler=Yes Lion boots but that change doesn't rectify the problem that I'm stuck with 1024x768.

Boot log includes this: kernel: SNB Framebuffer did not show up, unload. It's the last kernel syslog message and posted at the moment that the Lion logon screen is displayed. If booting with -v, that's when the display switches from text into Lion graphics.

System Information Extensions says AppleIntelSNBGraphicsFB.kexts is loaded but AppleIntelHDGraphics.kexts is absent from the list.

Display information:
Intel HD Graphics 3000:
Chipset Model: Intel HD Graphics 3000
Type: GPU
Bus: Built-In
VRAM (Total): 64 MB of Shared System Memory
Vendor: Intel (0x8086)
Device ID: 0x0126
Revision ID: 0x0009
Kernel Extension Info: No Kext Loaded
Displays:
    Display:
      Resolution: 1024 x 768
      Pixel Depth: 32-Bit Color (ARGB8888)
      Main Display: Yes
      Mirror: Off
      Online: Yes



Setting onboard graphics to "enable if no ext PGA" hasn't helped.
I noticed in your signature you say it's connected via VGA, that is why. You need to use either DVI or HDMI... also, could you post a screenshot of "about this mac"?
 
Top