Contribute
Register

[Guide] Dell XPS 9530 Clover UEFI / Hotpatch

Joined
Jun 17, 2012
Messages
105
Motherboard
Dell Precision m3800
CPU
Core i7 4702HQ
Graphics
Quadro K1100m, Intel HD4600
Mobile Phone
Android, iOS

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,123
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
hi @RehabMan , yes that's the guide i followed. did i not make it properly?

is it lilu.kext and intelgraphicsfixit.kext?

because it says, it's for

For 10.12.5 and HD515/HD520/HD530/HD615/HD620/HD630
You did not follow the guide.
 
Joined
Jun 17, 2012
Messages
105
Motherboard
Dell Precision m3800
CPU
Core i7 4702HQ
Graphics
Quadro K1100m, Intel HD4600
Mobile Phone
Android, iOS
You did not follow the guide.
i did, i followed the same guide for z50-70, and i have successfully installed el capitan in my z50-70. i believe only difference is the config.plist, the kexts and which options to choose in clover. i'll try doing it again, will follow step by step in case i missed anything
 
Joined
Jun 17, 2012
Messages
105
Motherboard
Dell Precision m3800
CPU
Core i7 4702HQ
Graphics
Quadro K1100m, Intel HD4600
Mobile Phone
Android, iOS
i did, i followed the same guide for z50-70, and i have successfully installed el capitan in my z50-70. i believe only difference is the config.plist, the kexts and which options to choose in clover. i'll try doing it again, will follow step by step in case i missed anything
APFS.efi?

in the drivers64UEFI folder, there are a lot more files than:

FSInject-64.efi
HFSPLus.efi
OsxAptioFixDrv-64.efi
OsxFatBinaryDrv-64.efi

should i leave them there? or should there be only those 4 files?

also, for the XPS 9530, i seee a lot of users using OsxAptioFixDrv2-64.efi, this is what i should use also?

thanks
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,123
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
You did not.
Your config.plist is not from my guide. And after seeing that (obvious you didn't follow the guide), I didn't even bother to check anything else.
 
Joined
Jun 17, 2012
Messages
105
Motherboard
Dell Precision m3800
CPU
Core i7 4702HQ
Graphics
Quadro K1100m, Intel HD4600
Mobile Phone
Android, iOS
You did not.
Your config.plist is not from my guide. And after seeing that (obvious you didn't follow the guide), I didn't even bother to check anything else.
am i not supposed to use the dark-void's installation config.plist?

which one should i use? config_HD4600_4400_4200.plist? i already tried that as well, still doesn't work


i know plist files are in your guide, but i always thought i should use plist depending on the system. most guides provide their own installation plist, that's why i thought i should use those.

i'll try again, following all, just your guide and all your files/tools
 
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,123
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
am i not supposed to use the dark-void's installation config.plist?
That file appears to depend on specific content in ACPI/patched.
I usually recommend that patched ACPI is not used for installation (instead, keep things simple).

which one should i use? config_HD4600_4400_4200.plist? i already tried that as well, still doesn't work
No idea when you don't provide any "Problem Reporting" files as per FAQ.
 
Joined
Jun 17, 2012
Messages
105
Motherboard
Dell Precision m3800
CPU
Core i7 4702HQ
Graphics
Quadro K1100m, Intel HD4600
Mobile Phone
Android, iOS
That file appears to depend on specific content in ACPI/patched.
I usually recommend that patched ACPI is not used for installation (instead, keep things simple).



No idea when you don't provide any "Problem Reporting" files as per FAQ.

hi @RehabMan , i used your 4600_4400_4200 plist. DVMT pre-alloc is 128mb, also tried 160mb, same results

would get this verbose screen, then blank screen with blinking cursor, blinking every 30 seconds, lasted for more than 10 minutes, then a blank screen without back light.
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,123
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
hi @RehabMan , i used your 4600_4400_4200 plist. DVMT pre-alloc is 128mb, also tried 160mb, same results
How do you know DVMT-prealloc is 128mb?
Your config.plist has no patch for DVMT-prealloc 128mb or 160mb...
This guide uses a different config.plist... you should check that you're following post #1 instructions, and check the config.plist for the DVMT-prealloc assumed.
 
Top